WAMP 0.2.4.c (Startzeit von mysql)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

WAMP 0.2.4.c (Startzeit von mysql)

Postby horstschulz » 07. January 2003 11:52

hallo,
ich arbeite jetzt schon sehr lange (Anfang 2001) mit dem 1. Wamp - System und habe damit nur beste Erfahrungen gemacht!
Eigentlich gab es für mich auch keinen Grund auf eine neuere Version zu wechseln aber ...., na ja!
Ich habe letztendlich die Version WAMP 0.2.4.c installiert auf ein Windows 98 - System.
Jetzt habe ich ein dickes Prob!: wenn ich MySql starte, dann dauert der Startvorgang (nicht nur beim 1. Mal) bis zu 40 Minuten).
Divers Einstellungen in der my.cnf - Datei etwa "innodb_data_file_path=ibdata1:30M" verändern die Zeit des Startvorganges im Minutenbereich (nur noch ca. 25), wenn ich runtergehe auf 15M.
Auf jeden Fall schein mir das Problem wirklich bei der "innodb....." zu sein.
Also ist da vielleicht doch etwas mehr zu tun als nur entpacken und fertig?
Ich habe die Version auch schon auf 2 verschiedene Rechner installiert, aber jeweils mit dem selben Erfolg!
ich hasse Streß
Horst
horstschulz
 
Posts: 71
Joined: 29. December 2002 11:38
Location: Stade

Postby Oswald » 07. January 2003 12:36

Hallo Horst!

Das ist quasi normal. MySQL mit InnoDB braucht so lange beim starten.

Allerdings braucht es nur beim ersten mal so lange. Beim zweiten und jeden weiterem Start sollte es wie gewohnt schnell gehen. Beim ersten Start muss das x MB große Data-File angelegt werden und das kann - je nach Umfang - lange dauern.

Bei Dir scheint es ja aber bei jedem Start so lange zu dauern? Richtig? Da fällt mir nur eines ein: Fährst Du die Datenbank ordentlich runter? Wenn nicht, dann kann darin die Ursache für das immer wieder langsame Starten liegen.

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Guest » 07. January 2003 13:15

vielen Dank für die schnelle Antwort!
Ich fahre Db und auch Windows korrekt runter, aber ich vermute, daß insgesamt mein PC-System nicht mehr so richtig configuriert ist, denn andere scheinen das Prob nicht zu haben.
Außerdem bekomme ich am Wochende einen ganz "jungfreulichen PC", dann mache ich mich noch einmal erneut an die Install.
Bis dahin räume ich hier mal das Feld!
Guest
 

Postby nemesis » 08. January 2003 00:25

Anonymous wrote:Ich habe letztendlich die Version WAMP 0.2.4.c installiert auf ein Windows 98 - System.


das system müllt sich nach ner gewissen zeit von selber zu, hatte so nen turnus drinnen das ich alle 3-4 Monate Formatiere und neu draufspiele.
P.S.: Der Apache2 kann wahrscheins auch durch die Funktion besser skalierbar zu sein (multithreads) bei kleineren System etwas "ruckeln" Für Privatzweocke reicht der 1.3er im normalfall aus.

Gruss, nemesis
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 20 guests