Port 80 Problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Port 80 Problem

Postby teck » 11. November 2016 10:58

Hallo liebe Community,
ich habe gestern xampp-win32-7.0.9-0-VC14 auf meinem Win 10 (64 BIT) rechner installiert und wollte es mit dem Sontrol Panel starten. Aber schon der Start des Apache-Server schlug fehl und das Start -log file teilt mir mit dass PORT 80 belegt ist. Mit Netstat habe ich gesehen, dass Port 80 von "System" belegt ist. Da ich wirklich XAMPP Laie bin und auch nicht DER PC-Freak komme ich einfach nicht weiter. Ich habe das ganze auch schon mit Adminrechte gestartet - der gleiche Fehler. Unten kopier ich das Log-file mal rein. Sicher können viele von euch damit mehr anfangen als ich. Wäre toll, wenn jemand eine Antwort für mich hätte. Danke schon mal im Voraus.
PS: gibt es eigentlch keine 64-Version für Windows??? Ich habe nirgends eine gefunden (Nur für Linux und Mac) :(

Startprotokoll:

21:22:21 [main] Initialisere Control Panel
21:22:21 [main] Windows Version: Pro 64-bit
21:22:21 [main] XAMPP Version: 7.0.9
21:22:21 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
21:22:21 [main] Mit Administratorrechten gestartet - gut!
21:22:21 [main] XAMPP Installationsverzeichnis: "c:\xampp\"
21:22:21 [main] Voraussetzungen werden geprüft
21:22:21 [main] Alle Voraussetzungen sind erfüllt
21:22:21 [main] Initialisiere Module
21:22:21 [Apache] Problem festgestellt!
21:22:21 [Apache] Port 80 in Benutzung von "Unable to open process" (PID 4)!
21:22:21 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
21:22:21 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
21:22:21 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
21:22:21 [main] Das FileZilla Modul ist deaktiviert
21:22:21 [main] Das Mercury Modul ist deaktiviert
21:22:21 [main] Das Tomcat Modul ist deaktiviert
21:22:21 [main] Starte Check-Timer
21:22:21 [main] Control Panel bereit
21:22:23 [Apache] Problem festgestellt!
21:22:23 [Apache] Port 80 in Benutzung von "Unable to open process" (PID 4)!
21:22:23 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
21:22:23 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
21:22:23 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
21:22:23 [Apache] Versuche Apache zu starten...
21:22:23 [Apache] Statusänderung erkannt: gestartet
21:22:24 [Apache] Statusänderung erkannt: gestoppt
21:22:24 [Apache] Fehler: Apache wurde unerwartet beendet
21:22:24 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
21:22:24 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
21:22:24 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
21:22:24 [Apache] im Windows Event Viewer für weitere Hinweise
21:22:24 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
21:22:24 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.

Netstat sagt:
Adresse = 0.0.0.0; Port = 80; PID = 4, Name = System
teck
 
Posts: 2
Joined: 11. November 2016 10:46
XAMPP version: 7.0.9-0-VC14
Operating System: Win10 64-bit

Re: Port 80 Problem

Postby tm01 » 11. November 2016 19:57

Hi!
Du musst den Port in der Firewall freigeben.
Guck mal zum Beispiel hier: https://xuad.net/artikel/xampp-und-der- ... t-starten/
tm01
 
Posts: 35
Joined: 03. November 2016 16:20
XAMPP version: 3.2.2
Operating System: Win7

Re: Port 80 Problem

Postby Nobbie » 11. November 2016 21:29

Die Einstellung in der Firewall wird nicht reichen, die eigentliche Ursache liegt in Microsofts Webserver (der quasi zu Apache konkurriert). Gib die zentrale Fehlermeldung "Port 80 in Benutzung von "Unable to open process" (PID 4)!" in Google ein, da wird Dir geholfen.

PS: gibt es eigentlch keine 64-Version für Windows??? Ich habe nirgends eine gefunden (Nur für Linux und Mac) :(


Ja, es gibt bislang keine Xampp 64-bit Version für Windows. Aber bisher ist es auch noch niemandem gelungen, selbst auf Anfrage einen nachvollziehbaren Grund anzugeben, wieso es notwendig wäre (außer "ich hätte aber gerne"). Windows unterstützt nach wie vor 32-bit Programme und die Webserver Umgebung von Xampp läuft auch quasi ohne EInschränkungen unter 32-bit. Was genau fehlt Dir in Deiner Entwicklungsumgebung, nur weil Apache etc. in 32-bit laufen?

Interessanterweise wird im Xampp Linux Forum herumgemäkelt, weil es dort keine 32-bit Version mehr gibt. Es scheint also egal zu sein, ob es 32 oder 64 gibt - es ist immer falsch und es fehlt anscheinend immer genau die andere Version. Wie man es auch macht, man macht es falsch... :shock:
Nobbie
 
Posts: 9509
Joined: 09. March 2008 13:04

Re: Port 80 Problem

Postby teck » 13. November 2016 12:06

Hallo an alle, die mir geantwortet haben. Vielen Dank dafür. Ich habe den Server nun am Laufen. Sehr hilfreich war auch der Tip mit der Fehlermeldung zu googlen. Hab ein schönes Youtube Video gefunden, was schrittweise eine Lösung gezeigt hat. Dabei hab ich den Apacheserver nun auf den Port 8080 umgelegt.. jetzt läuft es reibungslos.
Meine Farge nach einer 64-Bit Version war aber keine Kritik (wie es "Nobbie" wohl verstanden hat), sondern nur ne echte Frage, da ich eigentlich immer 64-Bit Anwendungen auf meinem 64-Bit rechner installiere, wenn es eine entsprechende Version gibt. (auf einem 4K-Fernseher schaue ich ja auch keine SD Programm, wenn es eine HD Variante gibt) :D

Aber jetzt doch noch ne weiter Frage: Da ich auf dem Server einen Onlineshop testen will, hab ich nun das Problem, dass dieser mit der PHP-Version 7.0.9 nicht zurecht kommt. Er benötigt (max.) 5.6.99. Gibt es da eine entsprechende XAMPP Version dafür oder kann ich die PHP Version mit einer älteren überschreiben?
teck
 
Posts: 2
Joined: 11. November 2016 10:46
XAMPP version: 7.0.9-0-VC14
Operating System: Win10 64-bit

Re: Port 80 Problem

Postby Nobbie » 13. November 2016 13:13

teck wrote:Hab ein schönes Youtube Video gefunden, was schrittweise eine Lösung gezeigt hat. Dabei hab ich den Apacheserver nun auf den Port 8080 umgelegt.. jetzt läuft es reibungslos.


Schade, scheint sich ein Schrottvideo eingeschlichen zu haben. Die "Lösung" ist Käse, richtig ist es, denn Microsoft IIS zu beenden und Apache auf Port 80 zu lassen. Jetzt hast Du immer den häßlichen Port 8080 in der URL stehen und der Microsoft IIS belegt sinnlos den Port 80.

teck wrote:(auf einem 4K-Fernseher schaue ich ja auch keine SD Programm, wenn es eine HD Variante gibt) :D


So ist das mit den hinkenden Vergleichen. Sicherlich siehst Du einen Unterschied zwischen SD und HD oder auch 4k. Aber wo siehst oder bemerkst Du einen Unterschied bei 32 oder 64bit Xampp? Wie läuft der hier aktive Server? Auf 32 oder 64bit?

teck wrote:Gibt es da eine entsprechende XAMPP Version dafür oder kann ich die PHP Version mit einer älteren überschreiben?


Da muss man ja schon boshaft blind sein, um das nicht zu sehen. Die 5.x Versionen stehen sogar noch über(!) der 7er Version, wie kann man das übersehen???

https://www.apachefriends.org/de/download.html
Nobbie
 
Posts: 9509
Joined: 09. March 2008 13:04

Re: Port 80 Problem

Postby Skywalkerin » 14. November 2016 18:30

hi friends,

ich hänge mich mal hier dazu, trotz intensiven studierens diverser beiträge hier und im weitern i-net
bekomme ich mein apache mit dem xampp control panel v3.2.2 nicht ans laufen.

jemand noch eine idee?

im anhang meine log

danke für eine hilfe
mfg
skywalkerin

[Initialisere Control Panel
17:58:34 [main] Windows Version: Pro 64-bit
17:58:34 [main] XAMPP Version: 5.6.24
17:58:34 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
17:58:34 [main] Dein Benutzerprofil besitzt keine Administratorenrechte! Das reicht aus für die meisten
17:58:34 [main] Anwendungsfunktionen, aber wann immer du etwas mit Windows-Diensten tun möchtest,
17:58:34 [main] wird eine Sicherheitsabfrage erscheinen oder etwas wird garnicht erst funktionieren!
17:58:34 [main] Also denke daran diese Anwendung mit Administratorrechten zu starten!
17:58:34 [main] XAMPP Installationsverzeichnis: "c:\xampp\"
17:58:34 [main] Voraussetzungen werden geprüft
17:58:34 [main] Alle Voraussetzungen sind erfüllt
17:58:34 [main] Initialisiere Module
17:58:34 [Apache] Problem festgestellt!
17:58:34 [Apache] Port 80 in Benutzung von "C:\Program Files (x86)\Skype\Phone\Skype.exe" (PID 2636)!
17:58:34 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
17:58:34 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
17:58:34 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
17:58:34 [Apache] Problem festgestellt!
17:58:34 [Apache] Port 443 in Benutzung von "C:\Program Files (x86)\Skype\Phone\Skype.exe" (PID 2636)!
17:58:34 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
17:58:34 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
17:58:34 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
17:58:34 [main] Das FileZilla Modul ist deaktiviert
17:58:34 [main] Das Mercury Modul ist deaktiviert
17:58:34 [main] Das Tomcat Modul ist deaktiviert
17:58:34 [main] Starte Check-Timer
17:58:34 [main] Control Panel bereit
17:58:50 [Apache] Problem festgestellt!
17:58:50 [Apache] Port 80 in Benutzung von "C:\Program Files (x86)\Skype\Phone\Skype.exe" (PID 2636)!
17:58:50 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
17:58:50 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
17:58:50 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
17:58:50 [Apache] Problem festgestellt!
17:58:50 [Apache] Port 443 in Benutzung von "C:\Program Files (x86)\Skype\Phone\Skype.exe" (PID 2636)!
17:58:50 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
17:58:50 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
17:58:50 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
17:58:50 [Apache] Versuche Apache zu starten...
17:58:50 [Apache] Statusänderung erkannt: gestartet
17:58:51 [Apache] Statusänderung erkannt: gestoppt
17:58:51 [Apache] Fehler: Apache wurde unerwartet beendet
17:58:51 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
17:58:51 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
17:58:51 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
17:58:51 [Apache] im Windows Event Viewer für weitere Hinweise
17:58:51 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
17:58:51 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.
17:59:04 [mysql] Versuche MySQL zu starten...
17:59:05 [mysql] Statusänderung erkannt: gestartet
17:59:18 [main] Führe aus: "services.msc"
18:05:22 [Apache] Problem festgestellt!
18:05:22 [Apache] Port 80 in Benutzung von "C:\Program Files (x86)\Skype\Phone\Skype.exe" (PID 2636)!
18:05:22 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
18:05:22 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
18:05:22 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
18:05:22 [Apache] Problem festgestellt!
18:05:22 [Apache] Port 443 in Benutzung von "C:\Program Files (x86)\Skype\Phone\Skype.exe" (PID 2636)!
18:05:22 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
18:05:22 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
18:05:22 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
18:05:22 [Apache] Versuche Apache zu starten...
18:05:22 [Apache] Statusänderung erkannt: gestartet
18:05:22 [Apache] Statusänderung erkannt: gestoppt
18:05:22 [Apache] Fehler: Apache wurde unerwartet beendet
18:05:22 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
18:05:22 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
18:05:22 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
18:05:22 [Apache] im Windows Event Viewer für weitere Hinweise
18:05:22 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
18:05:22 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.
18:09:17 [main] Führe aus: "services.msc"]
Skywalkerin
 
Posts: 5
Joined: 23. March 2016 17:32
Operating System: Win 10 pro

Re: Port 80 Problem

Postby tm01 » 14. November 2016 19:54

Steht doch alles in Klartext und auf Deutsch da:
1. Du hast xampp leider ins Programme Verzeichnis installiert und dadurch fehlt es der Installation an Rechten. Also entweder als Admin ausführen oder nach c: oder sonst wo installieren.
2. Skype blockiert den Port 80. Also: Skype beenden oder Skype sagen dass der sich von Port 80 zurückziehen soll.
tm01
 
Posts: 35
Joined: 03. November 2016 16:20
XAMPP version: 3.2.2
Operating System: Win7

Re: Port 80 Problem

Postby Nobbie » 15. November 2016 11:46

tm01 wrote:Steht doch alles in Klartext und auf Deutsch da:
1. Du hast xampp leider ins Programme Verzeichnis installiert und dadurch fehlt es der Installation an Rechten. Also entweder als Admin ausführen oder nach c: oder sonst wo installieren.


Das steht im Klartext und auf Deutsch aber ganz und gar nicht so da, wie kommst Du darauf?? s.o.:

17:58:34 [main] XAMPP Installationsverzeichnis: "c:\xampp\"
Nobbie
 
Posts: 9509
Joined: 09. March 2008 13:04

Re: Port 80 Problem

Postby tm01 » 15. November 2016 12:37

Mein Fehler. War ich wohl in der Zeile verrutscht und zu sehr auf Skype fixiert. Denn das steht tatsächlich klipp und klar da.
tm01
 
Posts: 35
Joined: 03. November 2016 16:20
XAMPP version: 3.2.2
Operating System: Win7

Re: Port 80 Problem

Postby Nobbie » 15. November 2016 12:47

tm01 wrote:Denn das steht tatsächlich klipp und klar da.


Skype ist klar, das ist auch die Ursache. Du bist ja relativ neu hier und lernst gleich von Anfang an, dass sowieso niemand(!) jemals Meldungen liest. Das kann noch so klar und einfach da stehen (und der Hinweise auf Skype ist ja wirklich bald mit mit Holzhammer eingraviert), gelesen wird das nicht. Ist grausam. Diese Frage habe ich sicherlich schon tausend Mal gestellt bekommen... (irgendwann hat man keine Lust mehr, darauf zu antworten).
Nobbie
 
Posts: 9509
Joined: 09. March 2008 13:04

Re: Port 80 Problem

Postby tm01 » 15. November 2016 12:55

Wär doch eigentlich ne gute Idee Postingbeiträge beim Erstellen nach genau sowas zu durchforsten und dann dem Hilfesuchenden gleich die passende Antwort zu geben.
0- "Du hast vergessen die Ausgabe des Control Panels anzugeben"
1- "Du scheinst ein Problem mit dem belegten Port 80 zu haben"
|-> "PID 4" -> IIS weg
|-> "Skype" -> konfig
2-"Install dir (windows)"-> Weg von Programs
usw

vielleicht auch weg vom Forum und einfach in ein extra Logfileanalysingformular. Bei jedem neuen Forenthread von nem neuregistrierten dann ne required Checkbox "ich habe das Formular bereits verwendet" oder so.

Edit:
Alternativ: Richtig nerviges Popup in xampp reinbasteln wenn sowas auftritt. Die Ausgabe scheint ja nicht als lesbar verstanden zu werden. Irgendwo in der Konfig kann man dann auch das Popupverhalten ausschalten.
tm01
 
Posts: 35
Joined: 03. November 2016 16:20
XAMPP version: 3.2.2
Operating System: Win7

Re: Port 80 Problem

Postby Nobbie » 15. November 2016 13:35

Ich kann nix in Xampp einbasteln, ich bin auch nur normaler User hier im Forum. Das muss Bitnami machen. Ansonsten gibt es ja von "Altrea" eine universelle Antwort (aber auf Englisch) auf die verschiedenen Apache Probleme beim Start:

viewtopic.php?f=16&t=69784

Da steht eigentlich alles drin.
Nobbie
 
Posts: 9509
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests