Seltsames Problem mit xampp und Java..?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Seltsames Problem mit xampp und Java..?

Postby CubaLibre » 17. September 2004 03:01

So, nun komme ich ebenso mit einem Problem.

Ich möchte xalan und xerxes in den neusten Versionen nutzen.
Java habe ich soweit eingebunden was bedeutet, daß ich die .dll in den extension eingegeben habe, die Java Pfade zugeordnet habe, Apache neu gestartet, info.php aufgerufen, es wird alles vernünftig angezeigt!

Nun wollte ich folgendes Testscript ausführen:
Code: Select all
<?php

  $system = new Java("java.lang.System");
  print "Java version=".$system->getProperty("java.version")." <br>\n";
  print "Java vendor=".$system->getProperty("java.vendor")." <p>\n\n";
  print "OS=".$system->getProperty("os.name")." ".
              $system->getProperty("os.version")." on ".
              $system->getProperty("os.arch")." <br>\n";

  $formatter = new Java("java.text.SimpleDateFormat","EEEE,
   MMMM dd, yyyy 'at' h:mm:ss a zzzz");
  print $formatter->format(new Java("java.util.Date"))."\n";
 
?>


..da schmiert mir doch glatt der Apache ab!

In den Logfiles finde ich nur..

Parent: child process exited with status 3221225477 -- Restarting

Interessant ist, daß Apache wohl nen Schlag weg bekommen hat, denn nun wird mir angezeigt, daß MySql nicht mehr aktiviert ist obwohl es läuft.
Zudem bekomme ich bei postgreSQL die selbe Meldung.

Gleichzeitig bekomme ich in Windows eine Violation Meldung mit der Option das Programm zu schließen oder zu debuggen. Wenn ich debuggen möchte, läßt er mich aber nicht.

Wäre ziemlich doof, wenn ich den ganzen Krempel nochmals installieren müßte.

Info:
W2K SP4
xampp 1.46
Apache 2
PHP 5.01
Tomcat
Cocoon
MySQL
PosgreSQL
mod_perl
mod_python
Alles als Service

Ich hoffe irgend jemand hat irgendwann mal eine Idee, worann das liegen könnte. :wink:
CubaLibre
 
Posts: 25
Joined: 18. January 2004 01:35
Location: Weilburg

Postby CubaLibre » 22. September 2004 12:00

Just for Info:
Problem gelöst!

PostgreSQL scheint sich nicht mit Zend Optimizer zu vertragen. Mehrfach eingebunden und wieder heraus genommen. Ohne geht es, mit nicht!


Java Problem:

Axis nutzt teilweise die selben Libraries wie xalan und xerxes! Hier gab es natürlich Konflikte, da muß man erst mal darauf kommen. Zudem hatte ich vorher zum Testen jwsdp-1.4 installiert, nun ratet mal was da alles drin ist...?!?
CubaLibre
 
Posts: 25
Joined: 18. January 2004 01:35
Location: Weilburg


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests