Apache startet nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht

Postby ankeeddy » 24. September 2016 12:28

Hallo,

ich bin absoluter Anwender was xampp angeht und relativ neu in der Thematik und habe auch in den vorhandenen Einträgen nichts gefunden, was mir hilft und zwar startet Apache nicht und ich weiß nun nicht, was ich tun kann um das zu ändern. Ich habe mir extra windows zugelegt, weil ich das aufm Mac überhaupt nicht zum laufen bekommen habe. Ich hoffe jemand kann mir helfen! :? :(
Es tut mir sehr leid, wenn ich damit jetzt jemanden nerven sollte, weil das der huntertausendste post dazu ist, aber ich weiß einfach nicht mehr weiter.
Liebe Grüße
Anke
Folgendes sagt error.log:

[Tue Sep 20 16:57:13.078358 2016] [ssl:warn] [pid 3180:tid 372] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Sep 20 16:57:13.343995 2016] [ssl:warn] [pid 3180:tid 372] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Sep 20 16:57:13.581068 2016] [mpm_winnt:notice] [pid 3180:tid 372] AH00455: Apache/2.4.23 (Win32) OpenSSL/1.0.2h PHP/5.6.24 configured -- resuming normal operations
[Tue Sep 20 16:57:13.581068 2016] [mpm_winnt:notice] [pid 3180:tid 372] AH00456: Apache Lounge VC11 Server built: Jul 7 2016 11:13:22
[Tue Sep 20 16:57:13.581068 2016] [core:notice] [pid 3180:tid 372] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Sep 20 16:57:13.596692 2016] [mpm_winnt:notice] [pid 3180:tid 372] AH00418: Parent: Created child process 2304
[Tue Sep 20 16:57:15.033461 2016] [ssl:warn] [pid 2304:tid 408] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Sep 20 16:57:15.283474 2016] [ssl:warn] [pid 2304:tid 408] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Sep 20 16:57:15.377227 2016] [mpm_winnt:notice] [pid 2304:tid 408] AH00354: Child: Starting 150 worker threads.
[Tue Sep 20 16:58:49.793675 2016] [ssl:warn] [pid 2696:tid 392] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Sep 20 16:58:50.059311 2016] [ssl:warn] [pid 2696:tid 392] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Sep 20 16:58:50.137442 2016] [mpm_winnt:notice] [pid 2696:tid 392] AH00455: Apache/2.4.23 (Win32) OpenSSL/1.0.2h PHP/5.6.24 configured -- resuming normal operations
[Tue Sep 20 16:58:50.137442 2016] [mpm_winnt:notice] [pid 2696:tid 392] AH00456: Apache Lounge VC11 Server built: Jul 7 2016 11:13:22
[Tue Sep 20 16:58:50.137442 2016] [core:notice] [pid 2696:tid 392] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Sep 20 16:58:50.153068 2016] [mpm_winnt:notice] [pid 2696:tid 392] AH00418: Parent: Created child process 5884
[Tue Sep 20 16:58:51.527492 2016] [ssl:warn] [pid 5884:tid 384] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Sep 20 16:58:51.780402 2016] [ssl:warn] [pid 5884:tid 384] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Sep 20 16:58:51.874156 2016] [mpm_winnt:notice] [pid 5884:tid 384] AH00354: Child: Starting 150 worker threads.
ankeeddy
 
Posts: 4
Joined: 24. September 2016 12:18
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Apache startet nicht

Postby Nobbie » 24. September 2016 16:30

Wie Du selbst siehst, steht kein einziger Fehler darin. In der Ausgabe des Xampp Control Dialogs steht sicherlich mehr (u.a. übrigens, dass man den Inhalt hier zeigen soll). So jedenfalls erkenne ich da noch gar nichts.
Nobbie
 
Posts: 8765
Joined: 09. March 2008 13:04

Re: Apache startet nicht

Postby ankeeddy » 26. September 2016 15:55

Meinst Du diesen Dialog: ?

16:45:50 [main] Initialisere Control Panel
16:45:50 [main] Windows Version: Windows 8.1 64-bit
16:45:50 [main] XAMPP Version: 5.6.24
16:45:50 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
16:45:50 [main] Dein Benutzerprofil besitzt keine Administratorenrechte! Das reicht aus für die meisten
16:45:50 [main] Anwendungsfunktionen, aber wann immer du etwas mit Windows-Diensten tun möchtest,
16:45:50 [main] wird eine Sicherheitsabfrage erscheinen oder etwas wird garnicht erst funktionieren!
16:45:50 [main] Also denke daran diese Anwendung mit Administratorrechten zu starten!
16:45:50 [main] XAMPP Installationsverzeichnis: "c:\xampp\"
16:45:50 [main] Voraussetzungen werden geprüft
16:45:54 [main] Alle Voraussetzungen sind erfüllt
16:45:54 [main] Initialisiere Module
16:45:54 [main] Aktiviere Autostart für Modul "Apache"
16:45:54 [main] Aktiviere Autostart für Modul "MySQL"
16:45:54 [main] Starte Check-Timer
16:45:54 [main] Control Panel bereit
16:45:54 [Apache] Autostart aktiv: Starte...
16:45:54 [Apache] Versuche Apache zu starten...
16:45:55 [mysql] Autostart aktiv: Starte...
16:45:55 [mysql] Versuche MySQL zu starten...
16:45:55 [Apache] Statusänderung erkannt: gestartet
16:45:55 [mysql] Statusänderung erkannt: gestartet
16:45:57 [Apache] Statusänderung erkannt: gestoppt
16:45:57 [Apache] Fehler: Apache wurde unerwartet beendet
16:45:57 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
16:45:57 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
...
ankeeddy
 
Posts: 4
Joined: 24. September 2016 12:18
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Apache startet nicht

Postby Nobbie » 26. September 2016 22:04

Im Prinzip meine ich das, aber wie Du selbst erneut siehst, steht da nicht viel Information zur Verfügung. Eine der häufigsten Ursachen, warum Apache nicht startet, ist eine "Kollision" mit Skype. Hast Du Skype installiert?
Nobbie
 
Posts: 8765
Joined: 09. March 2008 13:04

Re: Apache startet nicht

Postby ankeeddy » 28. September 2016 15:25

skype ist bereits deeinstalliert. :/
ankeeddy
 
Posts: 4
Joined: 24. September 2016 12:18
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Apache startet nicht

Postby Nobbie » 28. September 2016 15:51

Dann liegt es an etwas anderem. Bekannte Kollisionen gibt es u.a. auch mit VirtualBox oder VMWare, außerdem mit Microsoft IIS, last not least kann auch ein anderer Apache schon installiert sein und "aller last not least" ist vielleicht der Xampp Apache schon gestartet (der Installer startet Apache meistens direkt im Anschluss) und kann nicht nochmal gestartet werden. Im Xampp Control Dialog gibt es u.a. oben rechts einen Button "Netstat", dahinter verbirgt sich eine Anzeige der aktuellen Prozesse und welche Ports sie belegen. Vielleicht sieht man da irgendetwas von Port 80.

Wenn gar nichts hilft, starte ein Terminal (CMD.EXE bzw. eine "Eingabeaufforderung"), verzweige ins Xampp Verzeichnis (c:/xampp) und gib dort mal "apache_start" ein. Damit wird auf niedrigster Ebene versucht, einen Apache zu starten, bei schweren Fehlern (in der Konfiguration beispielsweise) bekommt mit man etwas Glück hier einen Hinweis auf die Fehlerursache.
Nobbie
 
Posts: 8765
Joined: 09. March 2008 13:04

Re: Apache startet nicht

Postby ankeeddy » 29. September 2016 14:48

Vielen Dank erstmal! Ich verstehe davon leider nicht viel, aber ich werde mich da mal "reinfuchsen". :) Vllt bekomm ich den sch*** ja endlich mal zum Laufen! :D
ankeeddy
 
Posts: 4
Joined: 24. September 2016 12:18
XAMPP version: 3.2.2
Operating System: Windows 10


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests