Start-Probleme

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Start-Probleme

Postby MrVectrex » 24. August 2016 21:40

Hallo zusammen. Ich wollte mir gerade auf dem Laptop Xampp und hinterher Wordpress installieren um an einer Idee zu arbeiten.
Ich habe auf dem PC bereits Xampp installiert und dort läuft es.

Hier kann ich weder MySQL noch Apache starten. Bei beiden bekomme ich einen Fehler der Ports.
15:35:24 [Apache] Port 80 in Benutzung von "Unable to open process" (PID 4)!

15:35:36 [mysql] Port 3306 in Benutzung von "C:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.in


Hat jemand ein Lösung für das Problem?

Danke, Florian
MrVectrex
 
Posts: 3
Joined: 24. August 2016 21:36
XAMPP version: 7.0.8
Operating System: Win10

Re: Start-Probleme

Postby Nobbie » 25. August 2016 10:20

MrVectrex wrote:Port 80 in Benutzung von "Unable to open process" (PID 4)


Diese Meldung einfach in Google eingeben.

MrVectrex wrote:Port 3306 in Benutzung von "C:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.in


Was bedeutet, dass MySQL schon läuft.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Start-Probleme

Postby MrVectrex » 25. August 2016 19:34

ich habe nun MySQL am laufen und ich kriege keine Fehlermeldung mehr bei Apache.
Alles was in der Leiste auftaucht ist "Versuche Apache zu starten..."
Dann passiert absolut nichts mehr
MrVectrex
 
Posts: 3
Joined: 24. August 2016 21:36
XAMPP version: 7.0.8
Operating System: Win10

Re: Start-Probleme

Postby Nobbie » 25. August 2016 20:09

MrVectrex wrote:Ich habe bereits versucht die Ports von Apache in der Konfig zu ändern. leider ohne erfolg


Das ist ja auch der falsche Ansatz. NIcht Xampp ändern, sondern die Ursache beseitigen (Microsoft IIS abstellen).

MrVectrex wrote:Denoch bekomme ich von Xampp keine Meldung das es läuft


Kann ja sein, aber wenn es läuft dann läufts, Egal ob irgendwo irgendwer irgendwas "meldet".
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Start-Probleme

Postby MrVectrex » 25. August 2016 20:32

Microsoft IIS ist auf meinem PC nicht vorhanden

Außerdem reagiert der Webbrowser auf nicht auf den localhost befehlt, also scheint dieser nicht zu funktionieren
MrVectrex
 
Posts: 3
Joined: 24. August 2016 21:36
XAMPP version: 7.0.8
Operating System: Win10

Re: Start-Probleme

Postby Nobbie » 25. August 2016 21:53

MrVectrex wrote:Microsoft IIS ist auf meinem PC nicht vorhandenn


Dann kann Dir leider hier niemand helfen, denn bei allen anderen ist das die Ursache für diese Fehlermeldung, eine andere Ursache ist nicht bekannt.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Start-Probleme

Postby hein_bloed » 31. August 2016 10:58

MrVectrex wrote:ich habe nun MySQL am laufen und ich kriege keine Fehlermeldung mehr bei Apache.
Alles was in der Leiste auftaucht ist "Versuche Apache zu starten..."
Dann passiert absolut nichts mehr


Leider wird der Output des Starts nicht an das Logfenster vom XAMPP-Control-Panel weitergeben.
Ich hatte schon einmal einen Konfig-Fehler in der httpd.conf und nur selbige - IMHO unaussagekräftige - Fehlermeldung.

Hier empfiehlt es sich eine DOS-BOX (Eingabeaufforderung) aufzumachen in das XAMPP-Installationsverzeichnis zu gehen und dort einmal händisch
Code: Select all
apache_start.bat

auszuführen. Vielfach hilft das dann schon weiter - wie in meinem Fall mit dem

synatax error on line....

HTH
hein_bloed
 
Posts: 9
Joined: 19. August 2016 09:59
Location: Hannover
XAMPP version: 5.6.23-0-VC11
Operating System: Win2k12-R2 Std.

Re: Start-Probleme

Postby toohoo » 01. September 2016 19:14

Hallo Alle,

ich habe das gleiche Problem. Ich bin mit diesem Thread nicht zur Lösung gekommen.
Was Skype betrifft, habe ich den Haken für Port 80 in den Optionen heraus genommen.
Den XAMPP habe ich mit apache_start.bat gestartet. Die Fehlermeldung dabei ist folgende:

D:\xampp>apache_start.bat
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulõssig. : AH00072: make_sock: could not bind to address [::]:80
(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulõssig. : AH00072: make_sock: could not bind to address 0.0.0.0:80
AH00451: no listening sockets available, shutting down
AH00015: Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .

Wenn jemand noch eine Idee hat, wäre ich dankbar.

Danke und Gruß
toohoo
 
Posts: 2
Joined: 01. September 2016 18:53
XAMPP version: 3.2.2
Operating System: Windows10

Re: Start-Probleme

Postby Altrea » 01. September 2016 21:57

Hallo,

toohoo wrote:Wenn jemand noch eine Idee hat, wäre ich dankbar.

Etwas blockiert den Zugriff auf Port 80. Entweder wird dieser Port bereits von einem anderen Prozess belegt, oder eine Sicherheitssoftware verhindert das blockieren des Ports.

Mehr kann ich mit den Informationen nicht sagen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Start-Probleme

Postby toohoo » 01. September 2016 22:50

Folgendes gefunden:
http://stackoverflow.com/questions/30758894/apache-server-xampp-doesnt-run-on-windows-10-port-80

Grüße, danke
toohoo
 
Posts: 2
Joined: 01. September 2016 18:53
XAMPP version: 3.2.2
Operating System: Windows10

Re: Start-Probleme

Postby Altrea » 02. September 2016 06:58

Man findet dazu sehr viel.
Doch da es mehrere Programme gibt die dieses Problem verursachen macht es keinen Sinn blind eine davon auszuprobieren.

Vielmehr ist der erste Schritt herauszufinden welches Programm das Problem verursacht und damit dann gezielt das Problem zu lösen.

Es gibt dazu auf mehrer als wichtig gekennzeichneten posts im englischen Teil dieses Boards.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests