Probleme beim Aufruf von localhost

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme beim Aufruf von localhost

Postby burli1980 » 12. August 2016 20:46

Hallo zusammen,

ich bin bald am Rande der verzweiflung. Ich habe XAMPP heute installiert und ersteinmal versucht, den
blockierten Port 80 unter Win 7 64-bit wieder freizugeben. Leider ohne erfolg. Da dies nicht ging, habe ich Apache
den Port 8080 zugewiesen. Jetzt startet er auch ohne Probleme und ohne Fehlermeldung.
Mein Problem ist jetzt, dass ich unter "localhost" angezeigt bekomme:

NOT FOUND
HTTP Error 404. The requested resource is not found.

Wenn ich auf meine index.html über localhost zugreifen möchte, geht dies nur über
"localhost:8080", also mit angabe des zugewiesenen Ports. Hat vielleicht jemand eine Idee, wo das Problem bei mir liegen könnte

Gruß
burli1980
 
Posts: 1
Joined: 12. August 2016 20:36
XAMPP version: 3.2.2
Operating System: win7 64-Bit

Re: Probleme beim Aufruf von localhost

Postby Altrea » 12. August 2016 21:08

Hallo,

Bei dir gibt es kein Problem. Es ist alles so wie es soll.
Das ist der Nachteil daran die Standardports zu ändern.

Mit freundlichen Grüssen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Probleme beim Aufruf von localhost

Postby Nobbie » 12. August 2016 21:29

burli1980 wrote:Wenn ich auf meine index.html über localhost zugreifen möchte, geht dies nur über
"localhost:8080"


Genau das ist der Riesennnachteil, wenn man den Port nicht auf 80 läßt. Man kann die Angabe des Ports nur dann weglassen, wenn man den dafür definierten Defaultport 80 benutzt.
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Probleme beim Aufruf von localhost

Postby hein_bloed » 19. August 2016 11:17

Um es nochmal technisch zu beschreiben.

Dein Browser macht zwei Dinge, wenn Du localhost/index.html in die Adresszeile schreibst. Es schreibt das Protokoll dazu http:// sowie den Standard-Port für Webseiten 80. Ergo wird daraus
http://localhost:80/index.html
in jungen Jahren des InterNetz musste mal das selbst noch schreiben. Da du nun den Port umgelegt hat, greift dieser Mechnismus nicht mehr bzw. hält sich immer noch an den Standard.
Da Du es umkonfiguriert hast, musst Du es eben jedesmal mit angeben. Aber dafür gibt's in jedem moderem Browser Lesezeichen/Bookmarks. Da XAMPP eh nur für Test-Installationen ist, sollte das IMHO verschmerzbar sein.

HTH,
Hein
hein_bloed
 
Posts: 9
Joined: 19. August 2016 09:59
Location: Hannover
XAMPP version: 5.6.23-0-VC11
Operating System: Win2k12-R2 Std.


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests