Hilfe mit Xampp bitte.

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Hilfe mit Xampp bitte.

Postby Dreh » 27. July 2016 22:48

Hallo
ich habe xampp installiert um ein Projekt für die Schule zu machen. Leider funktioniert die Sache mit dem Localhost nicht, d.h. wenn ich eine - beispielsweise - Textdatei in meinen htdocs Ordner lege und diese dann im Browser aufrufen möchte erscheint:

Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 404
localhost


Ich weiß nicht genau was für Informationen noch von Nutzen wären.

Apache (port 80, 443)und My-SQL(port 3306) laufen.

Bitte helft mir ich bin ratlos und im Netz sind zig Möglichkeiten was der Fehler sein könnte !!!

Danke
Dreh
 
Posts: 2
Joined: 27. July 2016 22:36
XAMPP version: 7.0.8
Operating System: Windows 8

Re: Hilfe mit Xampp bitte.

Postby Altrea » 27. July 2016 22:56

Hallo,

Dreh wrote:Ich weiß nicht genau was für Informationen noch von Nutzen wären.


Dateiname, vollständiger Pfad, URL, Apache access.log
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Hilfe mit Xampp bitte.

Postby Dreh » 27. July 2016 23:31

Hallo Danke für die schnelle Antwort.
Ich musste erst einmal suchen wo man das apache access log herbekommt.

Dateiname: a.txt
Pfad: C:\xampp\htdocs\a.txt
URL: localhost/a.txt
Apache access log:
::1 - - [27/Jul/2016:23:20:35 +0200] "GET / HTTP/1.1" 302 - "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0"
::1 - - [27/Jul/2016:23:20:48 +0200] "GET /a.txt HTTP/1.1" 404 1179 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0"
123.151.42.61 - - [27/Jul/2016:23:23:41 +0200] "GET http://www.baidu.com/ HTTP/1.1" 302 - "-" "-"
::1 - - [27/Jul/2016:23:27:16 +0200] "GET /drupal/a.txt HTTP/1.1" 404 1179 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0"
::1 - - [28/Jul/2016:00:13:07 +0200] "GET / HTTP/1.1" 302 - "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0"
::1 - - [28/Jul/2016:00:13:23 +0200] "GET /a.txt HTTP/1.1" 404 1179 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0"
Dreh
 
Posts: 2
Joined: 27. July 2016 22:36
XAMPP version: 7.0.8
Operating System: Windows 8

Re: Hilfe mit Xampp bitte.

Postby Nobbie » 28. July 2016 10:58

Mit Sicherheit hast Du die Datei mit Notepad angelegt, hast im Explorer die Anzeige der "bekannten" Dateierweiterungen abgeschaltet (das ist die Standardeinstellung) und dennoch wird die Datei mit dem Namen "a.txt" angezeigt (eigentlich müßte da nur "a" stehen, wenn man es genauer betrachtet). Und das liegt daran, dass wahrscheinlich Notepad wieder einmal ein zusätzliches .txt an die Datei angehängt hat und sie heißt in Wirklichkeit a.txt.txt und wird deswegen auch nicht gefunden.

Ist mal ein Schuss ins Blaue, aber ich würde vermuten: Treffer - versenkt!?
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests