phpMyAdmin meldet: Keine Verbindung

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

phpMyAdmin meldet: Keine Verbindung

Postby Counter3576 » 11. June 2016 11:05

Hallo User! :)

Mein XAMPP-phpMyAdmin meldet:
Fehler MySQL meldet: Die Verbindung konnte aufgrund von ungültigen Einstellungen nicht hergestellt werden. phpMyAdmin hat versucht eine Verbindung zum MySQL-Server aufzubauen und die Verbindung wurde zurückgewiesen. Sie sollten Ihre Einstellungen für Host, Benutzername und Passwort in Ihrer config.inc.php überprüfen und sich vergewissern, dass diese den Informationen, die Sie vom Administrator erhalten haben, entsprechen.


Die config.inc.php habe ich überprüft und kann darin keine Fehler feststellen. Was habe ich kurz vorher gemacht? Ich habe mit dem Befehl "mysqladmin.exe -u root password secret" wohl das Password auf "secret" gesetzt. Seitdem besteht die Störung. Wie kann ich das wieder rückgängig machen? :cry:

Grüße
Counter3576
:D
Counter3576
 
Posts: 7
Joined: 10. May 2016 18:46
XAMPP version: v3.2.2
Operating System: Windows 7

Re: phpMyAdmin meldet: Keine Verbindung

Postby Nobbie » 11. June 2016 11:27

Rückgängig brauchst Du es ja nicht zu machen (ich weiß nicht, ob mysqladmin es unterstützt, ein leeres Passwort anzugeben, das müßtest Du ausprobieren), einfach und besser ist es sicherlich, das neue Passwort in config.php.inc einzutragen. Da dürfte ja noch das alte Passwort (nämlich leer) drin stehen.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: phpMyAdmin meldet: Keine Verbindung

Postby Counter3576 » 11. June 2016 11:34

Hallo Nobbie!

Das hat funktioniert, vielen Dank.

Nun möchte ich eine Serververbindung aufbauen. Leider ergibt:
mysql -u root -p secret -h localhost -D test

nur: "Enter Password" Da gebe ich nochmals "secret" ein und dann ergibt das leider nur:
ERROR 1049 (42000): Unknown database 'secret'
:(

Viele liebe Grüße
Counter3576
:D
Counter3576
 
Posts: 7
Joined: 10. May 2016 18:46
XAMPP version: v3.2.2
Operating System: Windows 7

Re: phpMyAdmin meldet: Keine Verbindung

Postby Altrea » 11. June 2016 13:13

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: phpMyAdmin meldet: Keine Verbindung

Postby Nobbie » 11. June 2016 19:52

Counter3576 wrote: Leider ergibt:
mysql -u root -p secret -h localhost -D test



... das Müll. Altrea hat Dir ja die Doku verlinkt, Du vergibst hier zu viele Spaces, um es mal vorwegzunehmen. Und ein wenig mehr Eigeninitiative, ich frage mich wirklich, wieso bist Du so total hilflos?? Beide Probleme sind relativ einfach zu beheben, liest Du überhaupt Dokumentation? Mal im Ernst: beim ersten Problem schreibst Du, Du hättest die config.inc.php "überprüft" und könntest "keine Fehler" feststellen. Wieso siehst Du nicht das Offensichtliche, dass das Passwort fehlt bzw. nicht auf "secret" angepasst wurde (was ohnehin nur Du selbst machen kannst)? Das verstehe ich ehrlich nicht.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests