"XAMPP: Objekt not found!" und leere PHP-Seite

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

"XAMPP: Objekt not found!" und leere PHP-Seite

Postby Davaaron » 09. June 2016 17:09

Hi,

ich habe mir gerade ein Tutorial angeguckt und hänge schon bei der korrekten Installation von XAMPP, so wie es aussieht, obwohl es doch recht einfach ist.
Also ich habe mir von deren Homepage die .exe (XAMPP Apache + MariaDB + PHP + Perl) geholt und installiert unter C:\Server\xampp.
Danach bin ich in den Control Panel und habe Apache installiert und er ist an, Port 80 und 443.
Also PHP-Testdatei habe ich mir eine Datei phpinfo.php anlegt mit dem Inhalt
Code: Select all
<?
phpinfo();
?>


Laut Tutorial soll nun eine Tabelle (http://localhost/phpinfo.php) auftauchen, in der Informationen über PHP vorhanden sind.
Leider bleibt mir die Seite leer. Daher habe ich mal probiert, ob http://localhost/xampp funktioniert, allerdings steht da:

Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 404
localhost
Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.21


Meine Apache-Log sieht folgendermaßen aus:
[Thu Jun 09 16:58:10.429893 2016] [ssl:warn] [pid 21476:tid 576] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 16:58:10.547341 2016] [ssl:warn] [pid 21476:tid 576] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 16:58:10.582870 2016] [mpm_winnt:notice] [pid 21476:tid 576] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.21 configured -- resuming normal operations
[Thu Jun 09 16:58:10.582870 2016] [mpm_winnt:notice] [pid 21476:tid 576] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Thu Jun 09 16:58:10.583871 2016] [core:notice] [pid 21476:tid 576] AH00094: Command line: 'c:\\server\\xampp\\apache\\bin\\httpd.exe -d C:/Server/xampp/apache'
[Thu Jun 09 16:58:10.595879 2016] [mpm_winnt:notice] [pid 21476:tid 576] AH00418: Parent: Created child process 21396
[Thu Jun 09 16:58:11.181177 2016] [ssl:warn] [pid 21396:tid 600] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 16:58:11.292259 2016] [ssl:warn] [pid 21396:tid 600] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 16:58:11.323155 2016] [mpm_winnt:notice] [pid 21396:tid 600] AH00354: Child: Starting 150 worker threads.
[Thu Jun 09 17:32:38.720268 2016] [ssl:warn] [pid 5260:tid 548] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 17:32:38.752666 2016] [core:warn] [pid 5260:tid 548] AH00098: pid file C:/Server/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Jun 09 17:32:38.818830 2016] [ssl:warn] [pid 5260:tid 548] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 17:32:39.026631 2016] [mpm_winnt:notice] [pid 5260:tid 548] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.21 configured -- resuming normal operations
[Thu Jun 09 17:32:39.026631 2016] [mpm_winnt:notice] [pid 5260:tid 548] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Thu Jun 09 17:32:39.026631 2016] [core:notice] [pid 5260:tid 548] AH00094: Command line: 'c:\\server\\xampp\\apache\\bin\\httpd.exe -d C:/Server/xampp/apache'
[Thu Jun 09 17:32:39.035139 2016] [mpm_winnt:notice] [pid 5260:tid 548] AH00418: Parent: Created child process 2484
[Thu Jun 09 17:32:39.419317 2016] [ssl:warn] [pid 2484:tid 556] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 17:32:39.516081 2016] [ssl:warn] [pid 2484:tid 556] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 17:32:39.541700 2016] [mpm_winnt:notice] [pid 2484:tid 556] AH00354: Child: Starting 150 worker threads.
[Thu Jun 09 17:50:20.579330 2016] [ssl:warn] [pid 8272:tid 552] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 17:50:20.607350 2016] [core:warn] [pid 8272:tid 552] AH00098: pid file C:/Server/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Jun 09 17:50:20.670397 2016] [ssl:warn] [pid 8272:tid 552] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 17:50:20.695416 2016] [mpm_winnt:notice] [pid 8272:tid 552] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.21 configured -- resuming normal operations
[Thu Jun 09 17:50:20.695416 2016] [mpm_winnt:notice] [pid 8272:tid 552] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Thu Jun 09 17:50:20.695416 2016] [core:notice] [pid 8272:tid 552] AH00094: Command line: 'c:\\server\\xampp\\apache\\bin\\httpd.exe -d C:/Server/xampp/apache'
[Thu Jun 09 17:50:20.704424 2016] [mpm_winnt:notice] [pid 8272:tid 552] AH00418: Parent: Created child process 1940
[Thu Jun 09 17:50:21.054366 2016] [ssl:warn] [pid 1940:tid 532] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 17:50:21.141711 2016] [ssl:warn] [pid 1940:tid 532] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 09 17:50:21.168231 2016] [mpm_winnt:notice] [pid 1940:tid 532] AH00354: Child: Starting 150 worker threads.


Hat da jemand eine Idee? Wieso will er ein Zertifikat von www.example.com?
Davaaron
 
Posts: 2
Joined: 09. June 2016 16:59
XAMPP version: 3.2.2
Operating System: Windows 10

Re: "XAMPP: Objekt not found!" und leere PHP-Seite

Postby Nobbie » 10. June 2016 09:54

Davaaron wrote:Also PHP-Testdatei habe ich mir eine Datei phpinfo.php anlegt mit dem Inhalt?


Du benutzt sog. "Short Tags" (<?), das ist in Xampp deaktiviert. Du musst <?php am Anfang benutzen.

Die example.com Geschichte ist nur ein Syntaxbeispiel in der Konfiguration, hat nichts zu bedeuten.

Und die Seite localhost/xampp gibt es schon länger nicht mehr, gib einfach localhost ein, das ist der neuere Startscreen von Xampp.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: "XAMPP: Objekt not found!" und leere PHP-Seite

Postby Altrea » 10. June 2016 12:04

Hi,

Und verwende besser nicht solch ein veraltetes Tutorial. Du dürftest sonst auf weitere veraltete und längst überholte Konstrukte stoßen die dir Kopfzerbrechen bereiten.

Mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: "XAMPP: Objekt not found!" und leere PHP-Seite

Postby Davaaron » 11. June 2016 13:30

Danke euch für die Hilfe!

Dass die Seite localhost/xampp nicht ging, lieg dran,dass im Tutorial stand, dass man alles aus htdocs löschen soll.
Naja hab es wiederhergestellt und auch diesen Fehler konnte ich somit beheben.
Davaaron
 
Posts: 2
Joined: 09. June 2016 16:59
XAMPP version: 3.2.2
Operating System: Windows 10


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 20 guests