Hilfe! MySQL setzt Passwort, obwohl keins gesetzt ist?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Hilfe! MySQL setzt Passwort, obwohl keins gesetzt ist?

Postby Foreach » 01. May 2016 19:01

Hi, habe ein dringendes Problem, dass auch durch mehrere Neuinstallationen nicht geholfen hat.

Und zwar jedesmal, nach einer gewissen Zeitspanne kann ich mich nicht mehr mit phpmyadmin anmelden.

Die Fehlermeldung lautet wie folgt:
Fehler

MySQL meldet:
Die Verbindung konnte aufgrund von ungültigen Einstellungen nicht hergestellt werden.
phpMyAdmin hat versucht eine Verbindung zum MySQL-Server aufzubauen und die Verbindung wurde zurückgewiesen. Sie sollten Ihre Einstellungen für Host, Benutzername und Passwort in Ihrer config.inc.php überprüfen und sich vergewissern, dass diese den Informationen, die Sie vom Administrator erhalten haben, entsprechen.


Jetzt komm der Witz, habe ja Xampp, also schaue ich in die besagte config rein und siehe da, das ist garkein Passwort hinterlegt (habe ja auch keins vergeben).
Auszug Config:

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';

/* Bind to the localhost ipv4 address and tcp */
$cfg['Servers'][$i]['host'] = '127.0.0.1';
$cfg['Servers'][$i]['connect_type'] = 'tcp';

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma__bookmark';
$cfg['Servers'][$i]['relation'] = 'pma__relation';
$cfg['Servers'][$i]['table_info'] = 'pma__table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma__table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma__pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma__column_info';
$cfg['Servers'][$i]['history'] = 'pma__history';
$cfg['Servers'][$i]['designer_coords'] = 'pma__designer_coords';
$cfg['Servers'][$i]['tracking'] = 'pma__tracking';
$cfg['Servers'][$i]['userconfig'] = 'pma__userconfig';
$cfg['Servers'][$i]['recent'] = 'pma__recent';
$cfg['Servers'][$i]['table_uiprefs'] = 'pma__table_uiprefs';
$cfg['Servers'][$i]['users'] = 'pma__users';
$cfg['Servers'][$i]['usergroups'] = 'pma__usergroups';
$cfg['Servers'][$i]['navigationhiding'] = 'pma__navigationhiding';
$cfg['Servers'][$i]['savedsearches'] = 'pma__savedsearches';
$cfg['Servers'][$i]['central_columns'] = 'pma__central_columns';
$cfg['Servers'][$i]['designer_settings'] = 'pma__designer_settings';
$cfg['Servers'][$i]['export_templates'] = 'pma__export_templates';
$cfg['Servers'][$i]['favorite'] = 'pma__favorite';


Wenn ich ein Passwort vergebe, dann ändert sich da reingarnichts. Die Meldung bleibt bestehen. Selbst Neuinstallationen beheben das Problem nur kurzzeitig. Nach ein paar Minuten kommt dann wieder der oben genannte Fehler. Bin mit meinem Latein zu Ende. Habe bereits 4 mal neuinstalliert und immer wieder kommt diese Meldung nach ein paar Minuten. Habe das mal beobachtet, es fängt dann an das im phpmyadmin lauter seltsame Errors kommen und dann ist auch schon schluss.

Also wie sieht derLösungssansatz aus, habe bereits gefühlte 100 Lösungsstrategien durchgemacht. Nichts gebracht. Scheint wohl ein Kernel Bug zu sein oder weiß der Teufel...
Foreach
 
Posts: 2
Joined: 01. May 2016 18:55
XAMPP version: 3.2.2
Operating System: win 10

Re: Hilfe! MySQL setzt Passwort, obwohl keins gesetzt ist?

Postby Foreach » 01. May 2016 20:49

EDIT: habe glaube das Problem gefunden. Scheinbar ist es so, wenn man sehr viele SQL Befehle schnell ausführt, dann zerschießts die Datenbank. (Hatte zwar nur eine Session und die sollte laut InnoDB standardmäßig repeatable read als isolation level haben, aber naja ist ja doch mariadb?) Habe die Befehle überwiegend Prozeduren und Events "stückweise" ausgeführt und siehe da kein Problem. Ist zwar etwas komfortabilitätsverlustbehaftet aber at last it works...
Foreach
 
Posts: 2
Joined: 01. May 2016 18:55
XAMPP version: 3.2.2
Operating System: win 10

Re: Hilfe! MySQL setzt Passwort, obwohl keins gesetzt ist?

Postby WilliL » 02. May 2016 22:54

in meiner Config steht statt "config" "cookie"
Code: Select all
/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests