Warum startet Apache nicht? Wer kann mir helfen?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Warum startet Apache nicht? Wer kann mir helfen?

Postby RSch » 24. April 2016 22:49

Hallo Kollegen,
ich habe soeben XAMPP v3.2.2 auf Win7 64 installiert, und habe ebenfalls das Problem, das Apache nicht startet.
Leider habe ich nicht so ein schönes Control Panel Protokoll erhalten, um zu erfahren, wer den Port 80 blockiert (die Apache logs sind alle leer ...).
MySQL, FileZilla und Tomcat starten erfolgreich.
Ich habe die Kontrolle der Firewall an Norton 360 abgetreten ...
Wo kann ich nachsehen?
Viele Grüße,
Reinhardt
RSch
 
Posts: 3
Joined: 24. April 2016 22:41
XAMPP version: v3.2.2
Operating System: Win7 64

Re: Warum startet Apache nicht? Wer kann mir helfen?

Postby Nobbie » 25. April 2016 09:59

RSch wrote:Leider habe ich nicht so ein schönes Control Panel Protokoll erhalten, um zu erfahren, wer den Port 80 blockiert (die Apache logs sind alle leer ...).


Irgendetwas muss da stehen. Wenn ansonsten alles leer ist, gibt es nichts mehr zum nachsehen. Woher weisst Du, dass Apache nicht startet, wenn Du nirgends eine Meldung bekommst?
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: Warum startet Apache nicht? Wer kann mir helfen?

Postby nicoschubert » 25. April 2016 10:11

Da bei mir auch der Webserver nicht gestartet ist und die Logfiles leer waren sowie das Control Panel nichts angezeigt hatte, war für mich die Lösung, einfach nicht das Control Panel zu starten. Alternativ habe ich die apache_start.bat ausgeführt welche sehr viele Informationen anzeigt beim Starten unter Windows. Diese Fehlermeldungen sind sehr hilfreich, wenn die Installation Probleme verursacht.
User avatar
nicoschubert
 
Posts: 2
Joined: 24. April 2016 17:30
Location: Orlamünde
XAMPP version: v5.6.20
Operating System: Windows 7 Ulitimate SP1

Re: Warum startet Apache nicht? Wer kann mir helfen?

Postby RSch » 25. April 2016 18:26

Hallo zusammen,
erst einmal vielen Dank, dass Ihr mir helfen wollt ...

Hier das Protokoll im Control Panel (von dem ich immer nur den Rest wahrgenommen hatte .. :oops: )
19:15:28 [main] Initialisere Control Panel
19:15:28 [main] Windows Version: Windows 7 Enterprise SP1 64-bit
19:15:28 [main] XAMPP Version: 5.6.20
19:15:28 [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
19:15:28 [main] Mit Administratorrechten gestartet - gut!
19:15:28 [main] XAMPP Installationsverzeichnis: "c:\program files (x86)\xampp\"
19:15:28 [main] ACHTUNG: Der XAMPP Installationspfad enthält Leerzeichen. Dies könnte die Funktionalität von Programmen/Scripten beeinflussen
19:15:28 [main] ACHTUNG: Der XAMPP Installationspfad enthält Sonderzeichen. Dies könnte die Funktionalität von Programmen/Scripten beeinflussen
19:15:28 [main] Voraussetzungen werden geprüft
19:15:28 [main] Alle Voraussetzungen sind erfüllt
19:15:28 [main] Initialisiere Module
19:15:28 [Apache] Initialisiere Modul...
19:15:28 [Apache] Prüfe ob Modul existiert...
19:15:28 [Apache] Prüfe benötigte Tools...
19:15:28 [Apache] Überprüfe Dienst (name="Apache2.4"): Dienst nicht installiert
19:15:28 [Apache] Dienst-Pfad: Dienst nicht installiert
19:15:28 [Apache] Überprüfe Standardports...
19:15:28 [Apache] Port-blockierende Anwendung gefunden: System

19:15:28 [Apache] Prüfe Anwendung: c:\program files (x86)\xampp\apache\bin\httpd.exe
19:15:28 [Apache] Pfad der Port-blockierenden Anwendung: Unable to open process
19:15:28 [Apache] Pfad des Port-blockierenden Dienstes:
19:15:28 [Apache] Problem festgestellt!
19:15:28 [Apache] Port 80 in Benutzung von "Unable to open process" (PID 4)!
19:15:28 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
19:15:28 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
19:15:28 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
19:15:28 [mysql] Initialisiere Modul...
19:15:28 [mysql] Prüfe ob Modul existiert...
19:15:28 [mysql] Prüfe benötigte Tools...
19:15:28 [mysql] Überprüfe Dienst (name="mysql"): Dienst nicht installiert
19:15:28 [mysql] Dienst-Pfad: Dienst nicht installiert
19:15:28 [mysql] Überprüfe Standardports...
19:15:28 [mysql] Port-blockierende Anwendung gefunden: mysqld.exe
19:15:28 [mysql] Prüfe Anwendung: c:\program files (x86)\xampp\mysql\bin\mysqld.exe
19:15:28 [mysql] Pfad der Port-blockierenden Anwendung: c:\program files (x86)\xampp\mysql\bin\mysqld.exe
19:15:28 [mysql] Pfad des Port-blockierenden Dienstes:
19:15:28 [mysql] XAMPP MySQL ist bereits gestartet auf Port 3306
19:15:28 [filezilla] Initialisiere Modul...
19:15:28 [filezilla] Prüfe ob Modul existiert...
19:15:28 [filezilla] Prüfe benötigte Tools...
19:15:28 [filezilla] Überprüfe Dienst (name="FileZillaServer"): Dienst nicht installiert
19:15:28 [filezilla] Dienst-Pfad: Dienst nicht installiert
19:15:28 [filezilla] Überprüfe Standardports...
19:15:28 [filezilla] Port-blockierende Anwendung gefunden: filezillaserver.exe
19:15:28 [filezilla] Prüfe Anwendung: c:\program files (x86)\xampp\FileZillaFTP\filezillaserver.exe
19:15:28 [filezilla] Pfad der Port-blockierenden Anwendung: c:\program files (x86)\xampp\filezillaftp\filezillaserver.exe
19:15:28 [filezilla] Pfad des Port-blockierenden Dienstes:
19:15:28 [filezilla] XAMPP FileZilla ist bereits gestartet auf Port 21
19:15:28 [filezilla] Port-blockierende Anwendung gefunden: filezillaserver.exe
19:15:28 [filezilla] Prüfe Anwendung: c:\program files (x86)\xampp\FileZillaFTP\filezillaserver.exe
19:15:28 [filezilla] Pfad der Port-blockierenden Anwendung: c:\program files (x86)\xampp\filezillaftp\filezillaserver.exe
19:15:28 [filezilla] Pfad des Port-blockierenden Dienstes:
19:15:28 [filezilla] XAMPP FileZilla ist bereits gestartet auf Port 14147
19:15:28 [mercury] Initialisiere Modul...
19:15:28 [mercury] Prüfe ob Modul existiert...
19:15:28 [mercury] Prüfe benötigte Tools...
19:15:28 [mercury] Überprüfe Standardports...
19:15:28 [Tomcat] Initialisiere Modul...
19:15:28 [Tomcat] Prüfe ob Modul existiert...
19:15:28 [Tomcat] Prüfe benötigte Tools...
19:15:28 [Tomcat] Überprüfe Dienst (name="Tomcat7"): Dienst nicht installiert
19:15:28 [Tomcat] Dienst-Pfad: Dienst nicht installiert
19:15:28 [Tomcat] Überprüfe Standardports...
19:15:28 [main] Aktiviere Autostart für Modul "Apache"
19:15:28 [main] Aktiviere Autostart für Modul "MySQL"
19:15:28 [main] Aktiviere Autostart für Modul "FileZilla"
19:15:28 [main] Aktiviere Autostart für Modul "Tomcat"
19:15:28 [main] Starte Check-Timer
19:15:28 [main] Control Panel bereit
19:15:29 [Apache] Autostart aktiv: Starte...
19:15:29 [Apache] Überprüfe Standardports...
19:15:29 [Apache] Port-blockierende Anwendung gefunden: System
19:15:29 [Apache] Prüfe Anwendung: c:\program files (x86)\xampp\apache\bin\httpd.exe
19:15:29 [Apache] Pfad der Port-blockierenden Anwendung: Unable to open process
19:15:29 [Apache] Pfad des Port-blockierenden Dienstes:
19:15:29 [Apache] Problem festgestellt!
19:15:29 [Apache] Port 80 in Benutzung von "Unable to open process" (PID 4)!
19:15:29 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
19:15:29 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
19:15:29 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
19:15:29 [Apache] Versuche Apache zu starten...
19:15:29 [Apache] Führe aus: "c:\program files (x86)\xampp\apache\bin\httpd.exe"
19:15:29 [Apache] Rückgabecode: 0
19:15:29 [mysql] Autostart abgebrochen: MySQL ist bereits gestartet
19:15:29 [filezilla] Autostart abgebrochen: FileZilla ist bereits gestartet
19:15:29 [Tomcat] Autostart aktiv: Starte...
19:15:29 [Tomcat] Überprüfe Standardports...
19:15:29 [Tomcat] Versuche Tomcat zu starten...
19:15:29 [Tomcat] Führe aus: "c:\Windows\sysnative\cmd.exe" "/c "c:\program files (x86)\xampp\catalina_start.bat""
19:15:29 [Apache] Statusänderung erkannt: gestartet
19:15:30 [Apache] Statusänderung erkannt: gestoppt
19:15:30 [Apache] Fehler: Apache wurde unerwartet beendet
19:15:30 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
19:15:30 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
19:15:30 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
19:15:30 [Apache] im Windows Event Viewer für weitere Hinweise
19:15:30 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
19:15:30 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.
19:15:30 [Tomcat] Statusänderung erkannt: gestartet

Kann das an der Firewall liegen?

Viele Grüße,
Reinhardt
RSch
 
Posts: 3
Joined: 24. April 2016 22:41
XAMPP version: v3.2.2
Operating System: Win7 64

Re: Warum startet Apache nicht? Wer kann mir helfen?

Postby Nobbie » 25. April 2016 21:11

RSch wrote:Kann das an der Firewall liegen?


Nein, es liegt am Microsoft Internet Service II, das ist das Pendant zu Apache von Microsoft. Gib einfach " Port 80 in Benutzung von "Unable to open process" (PID 4)!" in Google ein, da gibt es genügend Erklärungen, Tutorials und Videos zu.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: Warum startet Apache nicht? Wer kann mir helfen?

Postby RSch » 25. April 2016 21:48

Whowww,
Vielen lieben Dank für den Tipp, wäre ich nie darauf gekommen.
Jetzt läuft Apache. Mals sehen, ob ich jetzt Drupal, Joomla etc. installieren kann.
Nochmals vielen Dank,
Viele Grüße,
Reinhardt :P
RSch
 
Posts: 3
Joined: 24. April 2016 22:41
XAMPP version: v3.2.2
Operating System: Win7 64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests