Thumbnail-Script funktioniert nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Thumbnail-Script funktioniert nicht

Postby Pedro » 09. September 2004 06:58

Hallo,

ich wollte von IIS auf Apachefriend umsteigen und habe folgendes Problem:

- Mein Thumbnail-Script funktioniert nicht. Es kommt kurz ein cmd Fenster hoch, leider so schnell das ich nichts lesen kann und das Script läuft sich zu tode. Alles andere scheint zu funktionieren.

Komisch an der Sache ist, auf dem IIS und bei meinem Provider auch Apache funktionier alles einwandfrei.

Hat jemand eine Idee?

Pedro
Pedro
 
Posts: 5
Joined: 09. September 2004 06:48

Nähere Erleuterungen

Postby Pedro » 09. September 2004 21:26

Hallo, ich habe den Code einwenig durchgeschaut.

Zwei Dinge funktionieren nicht:

1. system ("chmod 0777 ".$cachedir); Befehl läst Script nicht mehr zurückkommen

2. exif_read_data funktioniert nicht

Kann mir jemand eine Lösung sagen, wieso das erste nicht funktioniert, das ist aber nicht mein Hauptproblem. Das zweite ist sehr wichtig, wie kann ich die Option aktivieren, das ich exif_read_data nutzen kann?

Danke!

Pedro
Pedro
 
Posts: 5
Joined: 09. September 2004 06:48

2. Ist gelöst leider noch nicht 1.

Postby Pedro » 10. September 2004 13:23

Hallo,

das 2. Problem ist gelöst.

Kann mir jemand sagen, woran das erste liegt.

Pedro
Pedro
 
Posts: 5
Joined: 09. September 2004 06:48

Re: Nähere Erleuterungen

Postby Wiedmann » 10. September 2004 14:50

Pedro wrote:1. system ("chmod 0777 ".$cachedir); Befehl läst Script nicht mehr zurückkommen

Mach mal in deinem Windows die Eingabeaufforderung auf, und gib den Befehl "chmod" ein...

Mit "system()" kann du ein Programm (Befehl) ausführen, dass auf dem Rechner natürlich auch vorhanden sein muss. Was bei "chmod" unter Windows wohl i.d.R. nicht so sein dürfte.

Vergiss hier (Windows) den "chmod" einfach. --> siehe FAQ
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests