XAMPP (5.5.24) PHP ist deaktiviert

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP (5.5.24) PHP ist deaktiviert

Postby jochla » 19. March 2016 23:03

Hallo,

als XAMPP-Neuling stehe ich gleich vor einem Problem bei dem ich nicht allein weiterkomme. Die Installation habe ich unter Windows 8.1. gemacht.

Auf der XAMPP Status Seite wird angezeigt, dass PHP deaktiviert ist. phpinfo() sagt, dass dass das Configuration File von C:\xampp\php\php.ini geladen ist.

Ich habe einen Virtual Host eingerichtet und auch den entsprechenden Eintrag in der hosts gemacht:

Code: Select all
<VirtualHost 127.0.0.1:80>
    DocumentRoot "D:/www/typo3cms/jcsk"
    ServerName localhost/jazz
      DirectoryIndex index.php
      <Directory "D:/www/typo3cms/jcsk">
         AllowOverride All
         Allow from All
      </Directory>
</VirtualHost>


Wenn ich jetzt http://localhost/jazz/index.php aufrufe bekomme ich einen Fehler: Objekt nicht gefunden - Error 404

Frage: Wie kommt es, dass PHP "deaktiviert" ist, und wie kann ich es wieder aktivieren?
Meine Suche bei Google hat für mich zu keinem Ergebnis geführt.

Gruß, Johannes.
jochla
 
Posts: 3
Joined: 19. March 2016 22:29
Operating System: Windows 8.1

Re: XAMPP (5.5.24) PHP ist deaktiviert

Postby Altrea » 20. March 2016 05:12

Hallo,

Wenn phpinfo() funktioniert, funktioniert auch php.
Die Statusanzeigen waren schon immer sehr Fehleranfällig und wurden daher vollkommen zurecht aus aktuellen XAMPP Versionen entfernt.

Mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP (5.5.24) PHP ist deaktiviert

Postby Nobbie » 20. March 2016 11:11

>ServerName localhost/jazz

Das ist ein ungültiger Servername, es sind keine Ordnernamen o.ä. erlaubt. Das muss ein einfacher Name sein.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: XAMPP (5.5.24) PHP ist deaktiviert

Postby jochla » 20. March 2016 12:34

Danke für eure Antworten.

Ergänzend noch diese Information: Die Virtual Host Konfiguration habe ich in der Datei httpd-vhosts.conf gemacht.

Nach Hinweis von Nobbie habe ich den Servernamen in jazzclub geändert und natürlich auch in hosts den Eintrag angepasst.
Zusätzlich habe ich im Rootverzeichnis meines Virtual Host die Datei test.php angelegt:

Code: Select all
<?php
phpinfo();


Wenn ich nun die Datei mit http://jazzclub/test.php aufrufe, erhalte ich jetzt einen 403-Fehler "Zugriff verweigert"!?

Die Seite von http://localhost/xampp wird angezeigt. Das Installationsverzeichnis liegt auf C:\xampp.

Würde ich mein Projektverzeichnis unter C:\xampp\htdocs anlegen, würde ich dieses Problem vermutlich nicht haben.

Aber ich möchte meine Projektverzeichnisse schon gern auf dem Laufwerk D: haben.
Irgend was stimmt an der Konfiguration wohl noch nicht ganz!?
jochla
 
Posts: 3
Joined: 19. March 2016 22:29
Operating System: Windows 8.1

[GELÖST] XAMPP (5.5.24) PHP ist deaktiviert

Postby jochla » 20. March 2016 12:46

Habe eben diesen Beitrag noch gefunden: https://community.apachefriends.org/f/viewtopic.php?f=4&t=51701

Damit hat's geklappt:

Code: Select all
<VirtualHost 127.0.0.1:80>
    DocumentRoot "D:/www/typo3cms/jcsk"
    ServerName jazzclub
      DirectoryIndex index.php
      <Directory "D:/www/typo3cms/jcsk">
         Options Indexes FollowSymLinks Includes ExecCGI
         AllowOverride All
         Require all granted
      </Directory>
</VirtualHost>
jochla
 
Posts: 3
Joined: 19. March 2016 22:29
Operating System: Windows 8.1


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests