Xampp 7.0.3 und PHP intl extension

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp 7.0.3 und PHP intl extension

Postby hogiro » 26. February 2016 22:43

Hallo, ich wollte die neue XAMPP 7.0.3 Version testen. Leider habe ich festgestellt, dass die Intl Extension nicht aktiv wird, obwohl ich die Extension in php.ini aktiviert habe und auch die icu...dll Dateien in Apache/bin Ordner kopiert habe. In phpinfo() wird die Extension trotzdem nicht aufgelistet und Cakphp gibt auch einen Fehler aus, dass die Intl Extension fehlt.

Kann mir hierzu jemand helfen? Hat jemand schon so ein Problem gehabt?

Vielen Dank im Voraus.
hogiro
 
Posts: 2
Joined: 26. February 2016 22:36
Operating System: Windows 10

Re: Xampp 7.0.3 und PHP intl extension

Postby Altrea » 27. February 2016 00:28

Hallo,

vielen Dank für die Information. ich kann das Problem in der Version XAMPP 7.0.3-1 (.zip) reproduzieren.
Dies bezieht sich nicht nur auf php_intl.dll sondern auch auf andere Erweiterungen wie php_ldap.dll.

Im Apache error,log findet man Einträge hierzu
PHP Warning: PHP Startup: Unable to load dynamic library 'E:\\xampp-7.0.3-1\\php\\ext\\php_intl.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'E:\\xampp-7.0.3-1\\php\\ext\\php_ldap.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0

Da das Verzeichnis und die Erweiterungen existieren und andere Erweiterungen ebenfalls aktiviert und geladen werden können vermute ich ein Problem mit dem Kompilat mancher PHP Erweiterungen.

Ich habe das Problem den XAMPP Entwicklern von Bitnami gemeldet.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Xampp 7.0.3 und PHP intl extension

Postby Altrea » 29. February 2016 17:59

Hi,

Okay, also die Information, dass die icu* Dateien kopiert worden sind kann so nicht stimmen. Die Lösung des Problems ist es nämlich tatsächlich alle icu* Dateien vom php Verzeichnis ins Apache/bin Vereichnis zu kopieren. Schade, dass ich das nicht vorher nochmals getestet hatte, da du ja sagtest diese bereits kopiert zu haben. Das war bei vorigen XAMPP Versionen auch schon notwendig (Bitnami wird das aber für zukünftige Versionen dahingehend ändern dass sich die dlls bereits im Auslieferungszustand auch im Apache/bin Verzeichnis befinden).

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Xampp 7.0.3 und PHP intl extension

Postby hogiro » 16. March 2016 07:50

Ich habe das Problem entdeckt. Es lag nicht an ICU Dateien, sondern an eine Einstellung in httpd-xampp.conf Datei.
hogiro
 
Posts: 2
Joined: 26. February 2016 22:36
Operating System: Windows 10

Re: Xampp 7.0.3 und PHP intl extension

Postby Altrea » 16. March 2016 19:41

hogiro wrote:Es lag nicht an ICU Dateien, sondern an eine Einstellung in httpd-xampp.conf Datei.

An welcher Einstellung?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests