php.ini - änderungen werden nicht übernommen (API-Modus)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

php.ini - änderungen werden nicht übernommen (API-Modus)

Postby tHarry » 05. September 2004 17:54

Hallo!
Jedesmal wenn ich in der PHP.INI (im Apache\bin Order) Änderungen vornehme werden diese nicht übernommen (nach Neustart ;)).
Ich benutze zwar die API modus.. aber auch beim PHP.INI im PHP-Ordner (Obwohl dann CGI wäre) werden keine Änderungen übernommen.

Ich weiß nicht weiter...
denn dieses Error-Reporting geht mir auf die Nerven (wegen undefinierten Variablen)... (Ich habe die PHP.INI dafür aber angepasst!)

Außerdem... geht bei PHP5 eigentlich <?$variable?> statt <? echo $variable; ?> überhaupt nicht mehr?

LG, Harry
Whistler/Sp2, AMD2000+, Xampp 1.5.2,
Whistler/Sp2, P4/2Ghz, Xampp 1.5.2,
Apache und MySQL als Service
---------------
Max OS X 10.4 - iBook G4 - Xampp 0.5
tHarry
 
Posts: 54
Joined: 19. April 2003 17:58

Postby Wiedmann » 05. September 2004 21:43

denn dieses Error-Reporting geht mir auf die Nerven (wegen undefinierten Variablen)...

Wenn das deine eigenen Scripte sind, würd ich dann aber schauen das trotzdem keine Meldungen kommen.

(Ich habe die PHP.INI dafür aber angepasst!)

Und was hast du genau getan?

Außerdem... geht bei PHP5 eigentlich <?$variable?> statt <? echo $variable; ?> überhaupt nicht mehr?

Mal abgeshen davon, dass "<?$variable?>" noch nie ging... lässt sich das auch in der php.ini einstellen (short_open_tag).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tHarry » 05. September 2004 22:28

Mit angepasst meinte ich das ich Änderungen vorgenommen hatte.. aber diese nicht übernommen wurden... eben E_ALL, E_NOTICE usw...
bzw.. das MAX an MB der Dateiupload.. ich habe dies auf 2 MB eingestellt.. aber runterladen kann ich trotzdem mehr als 30 MB

das mit <?$variable?> geht schon ;) jedenfalls noch bei PHP 4.3.x
ich habe das bei beispiel scripts von xampp gesehen...
Bei HTML-Formulare kann mann dann statt

<input type="text" value="<? echo $var; ?>">

folgendes eingeben...

<input type="text" value="<?$var?>">

spart einiges an schreibarbeit und aus meiner Sicht raus auch übersichtlichkeit...

Liebe Grüße,
Harry
Whistler/Sp2, AMD2000+, Xampp 1.5.2,
Whistler/Sp2, P4/2Ghz, Xampp 1.5.2,
Apache und MySQL als Service
---------------
Max OS X 10.4 - iBook G4 - Xampp 0.5
tHarry
 
Posts: 54
Joined: 19. April 2003 17:58

Postby tHarry » 05. September 2004 22:50

hat sich jetzt teilweise erledigt.. ich habe nochmal das ganze xampp gelöscht und wieder neuinstalliert und konfiguriert... jetzt past es teilweise wieder... ich bekomme aber die Fehlermeldungen trotzdem nicht weg... nur dann wenn ich "display_errors = Off" stelle.

Aber "error_reporting = E_ALL & ~E_NOTICE" das keine E_NOTICE (also Undifined variable, Undifined Index) gemacht werden?! bei mir gibt PHP5.. dies trotzdem zurück.

Lg, Harry
Whistler/Sp2, AMD2000+, Xampp 1.5.2,
Whistler/Sp2, P4/2Ghz, Xampp 1.5.2,
Apache und MySQL als Service
---------------
Max OS X 10.4 - iBook G4 - Xampp 0.5
tHarry
 
Posts: 54
Joined: 19. April 2003 17:58

Postby Wiedmann » 05. September 2004 23:58

"error_reporting = E_ALL & ~E_NOTICE" ... bei mir gibt PHP5.. dies trotzdem zurück.

Das lag evtl. da dran, dass dein Browser die Seite aus dem Cache angezeigt hat.

Wenn du den XAMPP aber zum Entwickeln von Scripten oder zum Lernen von PHP benutzt, kann man dir trotzdem nur "E_ALL" oder sogar "E_ALL | E_STRICT" (bei PHP5) ans Herz legen.

das MAX an MB der Dateiupload.. aber runterladen kann ich trotzdem mehr als 30 MB

Dateiupload und runterladen (Dateidownload) sind auch zwei verschiedene Sachen. "upload_max_filesize" legt fest, wie gross die Datei, die in einem Upload-Formular übertragen wird, sein darf.

<input type="text" value="<? echo $var; ?>">
...
<input type="text" value="<?$var?>">

"<?$var?>" ist immer noch falsch. Richtig wäre: "<?= $var ?>".

Guter Stil und auch zukunftsicher (in Hinblick auf XML/XHTML-Konformität des Codes) wäre anstatt "<? echo $var; ?>" dieses zu schreiben: "<?php echo $var; ?>". So laufen deine Scripte dann zudem auch auf Webservern, die anders als deiner eingestellt sind. Kann man dir also auch ans Herz legen...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tHarry » 06. September 2004 02:04

ähm.. ich muss mich entschuldigen wegen dem <?$var?> und <?=$var?>... stimmt.. hab ich im Moment total übersehen... unglaublich was man nach 2 wochen Urlaub alles vergessen kann :'(

[quote]
Zitat:
"error_reporting = E_ALL & ~E_NOTICE" ... bei mir gibt PHP5.. dies trotzdem zurück.

Das lag evtl. da dran, dass dein Browser die Seite aus dem Cache angezeigt hat.
[/quote]

Aus Entwicklungsgründen habe ich den Cache im Browser deaktiviert, bzw. drücke öfters hintereinander "Aktualisieren" und hin und wieder gehe ich auf Nummer sicher und lösche ein weiteres -trotz deaktivierter Cache- Mal doch den Cache.


[quote]Zitat:
das MAX an MB der Dateiupload.. aber runterladen kann ich trotzdem mehr als 30 MB

Dateiupload und runterladen (Dateidownload) sind auch zwei verschiedene Sachen. "upload_max_filesize" legt fest, wie gross die Datei, die in einem Upload-Formular übertragen wird, sein darf.[/quote]

und wieder muss ich mich entschuldigen... mit 2 MB (max) eingestellt.. konnte ich auch mehr als 30 MB hochladen..

[quote]Wenn du den XAMPP aber zum Entwickeln von Scripten oder zum Lernen von PHP benutzt, kann man dir trotzdem nur "E_ALL" oder sogar "E_ALL | E_STRICT" (bei PHP5) ans Herz legen.[/quote]

Nun.. ausgelernt hat man nie *gg*
Zum entwickeln nutze ich Xampp, aber nicht mit E_NOTICE... ich will nun wirklich NICHT am Anfang jedes Scriptes alle benutzen Variablen im gesamten Script vordefinieren.
Bzw. auch die Variablen die irgendwann mal im gesammten Ablauf nur 1x dynamisch verwendet werden.

Nun... die meisten Problemen haben sich nun behoben - durch das ich eine Neuinstallation von Xampp gemacht habe. (Upload passt auch wieder und änderungen werden jetzt übernommen).

Nur das mit ~E_NOTICE ist geblieben :'(

so hab ichs im PHP.INI stehen.

error_reporting = E_ALL & ~E_NOTICE & E_STRICT

lg, harry
Whistler/Sp2, AMD2000+, Xampp 1.5.2,
Whistler/Sp2, P4/2Ghz, Xampp 1.5.2,
Apache und MySQL als Service
---------------
Max OS X 10.4 - iBook G4 - Xampp 0.5
tHarry
 
Posts: 54
Joined: 19. April 2003 17:58

Postby tHarry » 06. September 2004 12:00

Hallo!
Das Problem hat sich jetzt komplett behoben!
Ich habe den Server einpaarmal hintereinander komplett neuhochfahren lassen... nach dem 6. Neustart hat das mit den Error-Reporting gepasst wie gewünscht.
Danke trotzdem für die Hilfe!
Liebe Grüße, Harald
Whistler/Sp2, AMD2000+, Xampp 1.5.2,
Whistler/Sp2, P4/2Ghz, Xampp 1.5.2,
Apache und MySQL als Service
---------------
Max OS X 10.4 - iBook G4 - Xampp 0.5
tHarry
 
Posts: 54
Joined: 19. April 2003 17:58


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests