GELÖST: Apache will wegen Port 80 & Port 443 nicht starten!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

GELÖST: Apache will wegen Port 80 & Port 443 nicht starten!

Postby Sero » 25. January 2016 19:13

Moin Freunde,

hab heute XAMPP (v3.2.2.) installiert und alles ausser Apache startet auch. Apache gibt im Error-Log folgendes an:
[Mon Jan 25 18:27:01.594785 2016] [ssl:warn] [pid 6176:tid 540] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 25 18:27:02.595894 2016] [ssl:warn] [pid 6176:tid 540] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 25 18:27:02.711683 2016] [mpm_winnt:notice] [pid 6176:tid 540] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.15 configured -- resuming normal operations
[Mon Jan 25 18:27:02.727307 2016] [mpm_winnt:notice] [pid 6176:tid 540] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Mon Jan 25 18:27:02.727307 2016] [core:notice] [pid 6176:tid 540] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Jan 25 18:27:02.748942 2016] [mpm_winnt:notice] [pid 6176:tid 540] AH00418: Parent: Created child process 7544
[Mon Jan 25 18:27:03.753078 2016] [ssl:warn] [pid 7544:tid 556] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 25 18:27:04.255745 2016] [ssl:warn] [pid 7544:tid 556] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 25 18:27:04.507604 2016] [mpm_winnt:notice] [pid 7544:tid 556] AH00354: Child: Starting 150 worker threads.


18:47:17 [Apache] Problem festgestellt!
18:47:17 [Apache] Port 80 in Benutzung von "Unable to open process" (PID 6176)!
18:47:17 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
18:47:17 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
18:47:17 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
18:47:17 [Apache] Problem festgestellt!
18:47:17 [Apache] Port 443 in Benutzung von "Unable to open process" (PID 6176)!
18:47:17 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
18:47:17 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
18:47:17 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen

18:47:19 [Apache] Fehler: Apache wurde unerwartet beendet
18:47:19 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
18:47:19 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
18:47:19 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
18:47:19 [Apache] im Windows Event Viewer für weitere Hinweise
18:47:19 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
18:47:19 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.


Und das jedesmal wenn ich es versuche zu starten. Ich werde leider nicht weiter schlau von dieser Meldung. Daher wäre ich über eure Hilfe sehr dankbar :)
Last edited by Sero on 27. January 2016 15:56, edited 1 time in total.
Sero
 
Posts: 4
Joined: 25. January 2016 19:03
Location: Hamburg
Operating System: Windows 10

Re: Hilfe! Apache will wegen Port 80 & Port 443 nicht starte

Postby Altrea » 25. January 2016 21:32

Hi,

Starte dein XAMPP control panel mal bitte neu, und zwar mit erhöhten Administratorrechten (Rechtsclick -> als Administrator ausführen)

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Hilfe! Apache will wegen Port 80 & Port 443 nicht starte

Postby Sero » 26. January 2016 22:55

Hallo,

Das hatte leider auch nichts gebracht und auch MySQL funktionierte dann nicht mehr...

Hab es dann vorhin noch mal versucht (so 5 std nach dem ersten versuch) und nun geht alles problemlos an... Also ohne es "als admin" starten zu müssen. Ich hab kein schimmer woran es lag.
Sero
 
Posts: 4
Joined: 25. January 2016 19:03
Location: Hamburg
Operating System: Windows 10

Re: Hilfe! Apache will wegen Port 80 & Port 443 nicht starte

Postby Altrea » 27. January 2016 00:28

Das kommt ganz darauf an, was dir "etwas bringt".

Ohne als Admin zu starten, siehst du nur Informationen wie diese:
18:47:17 [Apache] Port 80 in Benutzung von "Unable to open process" (PID 6176)!


Wird das control panel allerdings als Admin gestartet, kann das control panel auch informationen zum blockenden Prozess auslesen.
Statt die PID selbst auflösen zu müssen, wird dir der Dateiname des Prozesses angezeigt.

Also ich finde schon, dass das etwas bringt, wenn auch vielleicht auch nur einen konkreten Hinweis, wo das Problem liegt.
Du stocherst jetzt im Dunkeln und weißt nicht woran es gelegen hat.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Hilfe! Apache will wegen Port 80 & Port 443 nicht starte

Postby Sero » 27. January 2016 15:15

Ich wollte halt mal Wordpress installieren. Dafür brauch ich doch Apache, MySQL und FileZilla(?). (Tomcat und Mercury sind da wohl eher unwichtig.)
Jetzt z.B. hab ich erneut das Problem mit Apache. Auch wenn ich es als Admin ausführe. Kann es sonst was mit dem AntiVir Programm zu tun haben (hab Avira Antivirus Pro)? Das der da irgendwas Blockt? Es kommt zumindest keine Meldung.

Habe nun auch mal den Dienst installiert (so das links ein grüner Haken abgebildet wird.), doch auch dann passiert nichts. Das "Apache"-Feld bleibt außerdem nun permanent Rot:

Image

EDIT:
Ok, hab gerade im Log das mit "skype.exe" gelesen und Skype mal geschlossen und es dann gestartet. Nun funktioniert es. Wieso bezieht der sich auf Skype und lässt sich dadurch nicht öffnen??
Last edited by Sero on 27. January 2016 15:49, edited 1 time in total.
Sero
 
Posts: 4
Joined: 25. January 2016 19:03
Location: Hamburg
Operating System: Windows 10

Re: Hilfe! Apache will wegen Port 80 & Port 443 nicht starte

Postby Nobbie » 27. January 2016 15:31

Sero wrote:Wieso beziehen der sich auf Skype und lässt sich da nicht öffnen??


Weil Skype auch ein Programm ist, welches mit dem Internet kommuniziert und das geschieht über sog. "Ports", jeder Port kann nur von einem einzigen Programm benutzt werden, andere Programme müssen andere Ports benutzen (dazu müßtest Du ein wenig über TCPIP lesen und lernen, wie das funktioniert). Dummerweise haben die Skype Entwickler es so eingebaut, dass Skype die gleichen Ports benutzen kann wie Apache (Port 80 und 443), das ist eigentlich nicht sehr schlau, denn das sind eigentlich Ports, die für HTTP reserviert sind. Man kann das aber in Skype beeinflussen, man muss nicht zwingend Skype abstellen, sondern man kann bei den Einstellungen eine Option aktivieren, dass Skype doch nicht Port 80 usw. benutzt. Klicke da mal herum, das wirst Du schon finden. Und dann kann man sowohl Skype als auch Apache benutzen.
Nobbie
 
Posts: 8769
Joined: 09. March 2008 13:04

Re: Hilfe! Apache will wegen Port 80 & Port 443 nicht starte

Postby Sero » 27. January 2016 15:48

Nobbie wrote:
Sero wrote:Wieso beziehen der sich auf Skype und lässt sich da nicht öffnen??


Weil Skype auch ein Programm ist, welches mit dem Internet kommuniziert und das geschieht über sog. "Ports", jeder Port kann nur von einem einzigen Programm benutzt werden, andere Programme müssen andere Ports benutzen (dazu müßtest Du ein wenig über TCPIP lesen und lernen, wie das funktioniert). Dummerweise haben die Skype Entwickler es so eingebaut, dass Skype die gleichen Ports benutzen kann wie Apache (Port 80 und 443), das ist eigentlich nicht sehr schlau, denn das sind eigentlich Ports, die für HTTP reserviert sind. Man kann das aber in Skype beeinflussen, man muss nicht zwingend Skype abstellen, sondern man kann bei den Einstellungen eine Option aktivieren, dass Skype doch nicht Port 80 usw. benutzt. Klicke da mal herum, das wirst Du schon finden. Und dann kann man sowohl Skype als auch Apache benutzen.


Verstehe! Ja, ich sollt mich mal über TCPIP schlau machen. Vielen Dank euch beiden für die Hilfe! :)
Sero
 
Posts: 4
Joined: 25. January 2016 19:03
Location: Hamburg
Operating System: Windows 10


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 18 guests