Xampp 1.4.6 + Dyndns + 2 locale Webseiten

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp 1.4.6 + Dyndns + 2 locale Webseiten

Postby ub60 » 02. September 2004 23:02

Ich benutze WinXP PRO. + SP2
und Xampp 1.4.6

Habe mir 2 Seiten local eingerichtet.
Habe auch einen Account bei Dyndns eingerichtet.
Unter diesem Account habe ich 2 Domains angemeldet.
Was muß ich tun, damit wenn ich den 1. Dyndns Namen aufrufe die 1. Locale Webseite aufgerufen wird und wenn ich den 2. Dyndns Namen aufrufe die 2. Locale Webseite angesprochen wird.

Zum Updaten der IP benutze ich: DyndnsUpdater 2.1 von Kana Solution

Habe etwas von virtualen Hosts gelesen, kann aber leider nichts mit anfangen.

Währe schön wenn mir (Anfänger) einer helfen könnte.
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby DJ DHG » 02. September 2004 23:25

Moin Moin

Hier wird dir erklährt was vhosts sind, und wie es funktioniert.
http://httpd.apache.org/docs-2.0/de/vhosts/

Ein beispiel gibt hier.
http://community.apachefriends.org/f/viewtopic.php?t=2717

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby ub60 » 02. September 2004 23:49

Erstmal Danke für die schnelle Antwort.

Gleichzeitig ein dickes Lob an alle die an XAMPP arbeiten.

Wenn ich alles richtig gemacht habe, kann man hier die resultate sehen.

#<VirtualHost *>
# ServerAdmin webmaster@dummy-host.example.com
# DocumentRoot /www/docs/dummy-host.example.com
# ServerName dummy-host.example.com
# ErrorLog logs/dummy-host.example.com-error_log
# CustomLog logs/dummy-host.example.com-access_log common
#</VirtualHost>

NameVirtualHost bowlingforum.dyndns.org:80
<VirtualHost bowlingforum.dyndns.org:80>
ServerName bowlingforum.dyndns.org
ServerAlias bowlingforum.dyndns.org
ServerAdmin brandtudo@ub60.de
DocumentRoot D:/xampp/htdocs/
<Directory D:/xampp/htdocs/webcam>
Options +Indexes
</Directory>
</VirtualHost>

NameVirtualHost brunswickforum.dyndns.org:80
<VirtualHost brunswickforum.dyndns.org:80>
ServerName brunswickforum.dyndns.org
ServerAlias brunswickforum.dyndns.org
ServerAdmin brandtudo@ub60.de
DocumentRoot D:/xampp/htdocs/
<Directory D:/xampp/htdocs/wbb2>
Options +Indexes
</Directory>
</VirtualHost>


http://bowlingforum.dyndns.org
http://brunswickforum.dyndns.org

Wenn ich diese Adressen eingebe kommt dann immer: Die Seite kann nicht angezeigt werden.
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby Rolidor » 02. September 2004 23:57

Morsche.
Also, deine Seiten sind zu erreichen. :D
ub60 wrote:Wenn ich diese Adressen eingebe kommt dann immer: Die Seite kann nicht angezeigt werden.
Dazu läuft hier gerade noch ein anderer Thread: http://community.apachefriends.org/f/viewtopic.php?t=7269

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby DJ DHG » 02. September 2004 23:59

nicht wirklich *glaub*

unter beiden urls ist die selbe seite zufinden.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby ub60 » 03. September 2004 00:33

Dürfte ich Euch bitten die beiden Links noch einmal auszuprobieren?
Danke

http://bowlingforum.dyndns.org
http://brunswickforum.dyndns.org

Hier noch die dazugehörigen Einträge in die http.conf


NameVirtualHost bowlingforum.dyndns.org:80
<VirtualHost bowlingforum.dyndns.org:80>
ServerName bowlingforum.dyndns.org
ServerAlias bowlingforum.dyndns.org
ServerAdmin brandtudo@ub60.de
DocumentRoot D:/xampp/htdocs/webcam
</VirtualHost>

NameVirtualHost brunswickforum.dyndns.org:80
<VirtualHost brunswickforum.dyndns.org:80>
ServerName brunswickforum.dyndns.org
ServerAlias brunswickforum.dyndns.org
ServerAdmin brandtudo@ub60.de
DocumentRoot D:/xampp/htdocs/wbb2
</VirtualHost>
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby Rolidor » 03. September 2004 00:35

Moin
DJ DHG wrote:nicht wirklich *glaub*

Er hat ja auch für beide Hosts die gleiche DocumentRoot gehabt ;)

Unter beiden Adressen erscheint eine Seite 'Udo's privaten Server | Datenbank'. Ob die jetzt auf allen Ebenen identisch sind, weiß ich nicht. Sehen auf jeden Fall identisch aus.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby ub60 » 03. September 2004 00:39

Wieso ???

einmal ist es /webcam
und einmal /wbb2

URL1 bowlingforum.dyndns.org soll gehen auf 127.0.0.1/webcam

URL2 brunswickforum.dyndns.org soll gehen auf 127.0.0.1/wbb2

Zur Zeit kann ich ja beide benutzen um auf die Seiten zu kommen.
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby Wiedmann » 03. September 2004 08:43

Code: Select all
NameVirtualHost bowlingforum.dyndns.org:80
<VirtualHost bowlingforum.dyndns.org:80>
...
NameVirtualHost brunswickforum.dyndns.org:80
<VirtualHost brunswickforum.dyndns.org:80>
...

ändere das mal in:
Code: Select all
NameVirtualHost *:80
<VirtualHost *:80>
...
<VirtualHost *:80>
...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ub60 » 03. September 2004 09:14

Vielen Dank ... :D :) :lol:

Jetzt klappt alles, so wie ich es mir vorgestellt habe.

Hier dann nocheinmal der Auszug aus der httpd.conf:

NameVirtualHost *:80
<VirtualHost *:80>
ServerName bowlingforum.dyndns.org
ServerAlias bowlingforum.dyndns.org
ServerAdmin brandtudo@ub60.de
DocumentRoot D:/xampp/htdocs/webcam
<Directory D:/xampp/htdocs/webcam>
Options +Indexes
</Directory>
</VirtualHost>

NameVirtualHost *:80
<VirtualHost *:80>
ServerName brunswickforum.dyndns.org
ServerAlias brunswickforum.dyndns.org
ServerAdmin brandtudo@ub60.de
DocumentRoot D:/xampp/htdocs/wbb2
<Directory D:/xampp/htdocs/wbb2>
Options +Indexes
</Directory>
</VirtualHost>
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby Wiedmann » 03. September 2004 10:17

Fein das es läuft :-)

Nur noch zwei Anmerkungen:

a) "NameVirtualHost *:80" sollte nur 1x in der Datei stehen.
b) Den ServerAlias kannst du weglassen (ist ja bei dir identisch mit dem ServerName).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ub60 » 03. September 2004 10:36

Danke für den Hinweis.

Dafür gibt es nun ein weiteres kleines Problem.

Von Extern aufrufen klappt. Es werden die richtigen Seite angesprochen.

Mit Intern "http://127.0.0.1" oder "http://localhost kommt jetzt immer die erste eingetragene Seite (das webcam Verzeichnis).
Gebe ich "http://127.0.0.1/wbb2" ein, kommt: Seite kann nicht angezeitg werden.
Auch nicht mit "http://localhost/wbb2"

Die Änderungen habe ich in der httpd.config vorgenommen.
Muß ich noch etwas ändern, damit es LOCAL auch wieder klappt ???

An Wiedermann:
Danke noch mal für die freundliche Hilfe. Da ich zu 80% Anfänger bin, ist man für jede Hilfe Dankbar.
[/quote]
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby Wiedmann » 03. September 2004 10:51

Im Verzeichnis "C:\WINDOWS\system32\drivers\etc\" gibt es die Datei "HOSTS" (notfalls neu anlegen. Datei wie hier geschrieben: ohne Endung!). Diese Datei erweiterst du um folgende 2 Einträge:
Code: Select all
127.0.0.1 bowlingforum.dyndns.org
127.0.0.1 brunswickforum.dyndns.org


Bei "http://127.0.0.1/..." wird jetzt immer der 1. VHost kommen. Du hast namesbasierende VHost's eingerichtet. Zur Unterscheidung mußt du also den Servnamen angeben. Gibst du keinen oder keinen definierten an, wird der 1. VHost genommen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ub60 » 03. September 2004 11:15

Änderungen vorgenommen. :D
Kann alles wieder aufrufen. :)

Vielen Dank
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby Priest » 28. November 2004 09:19

hast du die Links wieder geändert? Bei mir zeigt er auf beiden Dyndns das selbe an.
Priest
 
Posts: 22
Joined: 19. April 2004 16:46

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests