Nach Umstellung auf fcgi kein Zugang zu phpMyAdmin

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Nach Umstellung auf fcgi kein Zugang zu phpMyAdmin

Postby Scarabaeus » 06. August 2015 12:57

Hallo liebe Gemeinde,

ich benötige mal Hilfe.

Ich habe meine php 5.5.19 über FastCGI zum Laufen gebracht. Allerdings kann ich mich nun nicht mehr mit meinen Zugangsdaten, die ich vor der Umstellung auf CGI über den Sicherheitscheck von Xampp eingegeben hatte, in phpMyAdmin einloggen. Zwischenzeitlich konnte ich im Netz nachlesen, warum das nicht mehr geht (fehlende Angaben im http-Header bei CGI oder so ähnlich), allerdings fand ich keine Lösung, wie ich das Problem beheben könnte.

Kann mir hier jemand helfen? Ich bin für jeden Hinweis dankbar.

Viele Grüsse
Scarabaeus
Viele Grüsse
Scarabaeus
Scarabaeus
 
Posts: 3
Joined: 06. August 2015 12:47
Operating System: Win7, Win 10

Re: Nach Umstellung auf fcgi kein Zugang zu phpMyAdmin

Postby Nobbie » 06. August 2015 19:34

Leider ist die Beschreibung so gut wie nicht zu verstehen. Was genau machst Du, wie wurde/wird PhpMyadmin geschützt, wie wurde/wird versucht, den Zugang zu ermögliche, welche Fehlermeldungen tauchen wo auf. "Sicherheitscheck von Xampp" sagt mir leder überhaupt gar nichts.

Wie hast Du in PhpMyAdmin die Datei config.inc.php konfiguriert, gibt es im phpmyadmin Verzeichnis evtl. eine Datei mit Namen .htaccess? Was steht im Access Log, was steht im Error Log?

Wozu brauchst Du den fcgi Modus in einer Entwicklungsumgebung?
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Nach Umstellung auf fcgi kein Zugang zu phpMyAdmin

Postby Scarabaeus » 06. August 2015 20:05

Hallo Nobbie,
erst mal vielen Dank für Deine Antwort.

Zunächst habe ich xampp ganz normal auf meinem Windows Rechner installiert, danach im Menüpunkt "Sicherheitscheck" die http://localhost/security/xamppsecurity.php aufgerufen und dort Zugangsdaten für phpMyAdmin eingegeben, also root, und mein Passwort.

Später habe ich unter Apache/conf/extra die httpd-xampp.conf bearbeitet, damit php über fastCGI läuft. Klappt auch prima. Nur komme ich nach der Umstellung auf fastCGI einfach nicht mehr in mein phpMyAdmin rein, da die Zugangsdaten nicht mehr erkannt werden. Die Datei config.inc.php habe ich nicht angerührt, also weder modifiziert, noch sonst etwas damit angestellt. Auch gibt es keine htaccess im phpMyAdmin Verzeichnis.

Und ich möchte in der Entwicklungsumgebung die gleiche Konfiguration nutzen, wie ich sie auf dem Webserver habe, zumal php über fastCGI definitiv schneller ist. Darüber hinaus werden Dateien und Verzeichnisse mit den selben Schreib- und Besitzrechten versehen.

Hoffe, ich konnte Dir mein Problem jetzt besser verdeutlichen und würde mich über eine weitere Antwort freuen
Viele Grüsse
Scarabaeus
Scarabaeus
 
Posts: 3
Joined: 06. August 2015 12:47
Operating System: Win7, Win 10

Re: Nach Umstellung auf fcgi kein Zugang zu phpMyAdmin

Postby Nobbie » 06. August 2015 21:46

Scarabaeus wrote:Hoffe, ich konnte Dir mein Problem jetzt besser verdeutlichen und würde mich über eine weitere Antwort freuen


Vergiss in jedem Fall die katastrophale "Sicherheitscheck" Sche****, die ist seit Jahren nicht funktioniert und nur Xampp zerstört. Wenn Du irgendwo irgendwelche Passwörter einbauen willst, mache es an den entsprechenden Stellen mit dem notwendigen Know How. Alles andere ist Gemurkse.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Nach Umstellung auf fcgi kein Zugang zu phpMyAdmin

Postby Scarabaeus » 07. August 2015 06:25

Super. Danke, das war sehr hilfreich
Viele Grüsse
Scarabaeus
Scarabaeus
 
Posts: 3
Joined: 06. August 2015 12:47
Operating System: Win7, Win 10


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests