MySql zeigt leere Seite

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySql zeigt leere Seite

Postby camelot » 28. June 2015 19:32

Hallo liebe User,

ich möchte mich im Thema Xampp einarbeiten und habe eine erste Neuinstallation gemacht.
Das Xampp Control-Panel v 3.2.1 läuft und der Apache läßt sich starten. Keine Konflikte mit irgendwelchen Porten.

Aber wenn ich MySql über den Admin Button aus dem Control-Panel starten möchte, erscheint nur eine leere weiße Seite und ich komme nicht auf das Anmeldeformular.
Ich habe bereits localhost mit 127.0.0.1 getauscht usw., hat alles nichts gebracht.

Mit der Angabe http://localhost/phpmyadmin/ funktioniert es nicht

Mit der Angabe https://localhost/phpmyadmin/ funktioniert es.

Woran liegt das? Wo muß ich was umstellen oder ist das so normal?

Benutze win 7 / PHP Myadmin Version 4.4.10 (neuester Stand)

Ich hoffe, Ihr könnt ein wenig Licht in das Dunkel bringen :idea:
camelot
 
Posts: 9
Joined: 28. June 2015 19:15
Operating System: win7

Re: MySql zeigt leere Seite

Postby MikroMX563 » 28. June 2015 20:17

Was mir nur spontan einfällt da du es nicht erwähnt hast: Der MySQL ist auch gestartet ja? Du kannst logischerweise nicht MySQL administrieren wennd er Dienst nicht gestartet ist.
MikroMX563
 
Posts: 6
Joined: 28. June 2015 18:57
Operating System: Windows 2008 R2

Re: MySql zeigt leere Seite

Postby camelot » 28. June 2015 20:42

ja klar, der Apache und MySql sind gestartet, beide sind im Control-Panel grün hinterlegt.
camelot
 
Posts: 9
Joined: 28. June 2015 19:15
Operating System: win7

Re: MySql zeigt leere Seite

Postby glitzi85 » 28. June 2015 20:49

Wie hast du phpMyadmin installiert? Das ist nicht die Version von XAMPP.
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: MySql zeigt leere Seite

Postby camelot » 28. June 2015 21:23

Die Xampp-Software ganz normal.
Da war das Problem auch schon.

Die phpmyadmin Version habe ich dann geupdated. Am Problem hat sich aber nichts geändert.

Das update habe ich so ausgeführt wie in dieser Anleitung: https://www.ostraining.com/blog/coding/update-phpmyadmin/

Ich denke, das hängt irgendwie mit dem openssl zusammen?
camelot
 
Posts: 9
Joined: 28. June 2015 19:15
Operating System: win7

Re: MySql zeigt leere Seite

Postby glitzi85 » 28. June 2015 21:29

Nur um sicher zu gehen: Du hast ein Problem wenn du per http darauf zugreifst und es funktioniert mit https. Wie soll das ein openssl-Problem sein?

Normalerweise ist es gerade umgekehrt, da ssl nicht ordentlich eingerichtet ist (bzw. sein kann).

Wie hast du XAMPP installiert? War das eine Neuinstallation oder ein Upgrade? Irgendwelche Fehlermeldungen beim starten vom apachen?
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: MySql zeigt leere Seite

Postby camelot » 29. June 2015 18:05

Hallo,

Xampp ist eine Neuinstallation, auf dem Rechner war vorher keine alte Xampp Installation.

Ja, glitzi85, Du hast es richtig erkannt. Mit https komme ich zum phpmyadmin Anmeldefenster, mit http nicht bzw. ich sehe nur
eine leere Seite.

Kann man das irgendwo einstellen?
camelot
 
Posts: 9
Joined: 28. June 2015 19:15
Operating System: win7

Re: MySql zeigt leere Seite

Postby glitzi85 » 29. June 2015 18:24

Mir fällt auf die schnelle nix ein was das verursachen sollte. Normalerweise ist das genau umgekehrt...

Kannst du mal bitte die config.inc.php aus dem phpMyAdmin-Verzeichnis posten.

Hast du sonst irgendwas an den Configs von php (php.ini) oder Apache (httpd.conf) geändert?
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: MySql zeigt leere Seite

Postby camelot » 29. June 2015 19:20

Hier die Datei:
-------------------------------------------------------------------------------------------------------------------------------------------------
<?php
/*
* This is needed for cookie based authentication to encrypt password in
* cookie
*/
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
* Servers configuration
*/
$i = 0;

/*
* First server
*/
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'cookie'; // Authentication method (config, http or cookie based)
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'fm1';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';

/* Bind to the localhost ipv4 address and tcp */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
$cfg['Servers'][$i]['tracking'] = 'pma_tracking';
$cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';
$cfg['Servers'][$i]['recent'] = 'pma_recent';
$cfg['Servers'][$i]['table_uiprefs'] = 'pma_table_uiprefs';
$cfg['Servers'][$i]['users'] = 'pma_users';
$cfg['Servers'][$i]['usergroups'] = 'pma_usergroups';
$cfg['Servers'][$i]['navigationhiding'] = 'pma_navigationhiding';
$cfg['Servers'][$i]['savedsearches'] = 'pma_savedsearches';

/*
* End of servers configuration
*/

?>
----------------------------------------------------------------------------------------------------------------------------------------------

Alle configs sind in der Originalversion, also keine Änderungen.
camelot
 
Posts: 9
Joined: 28. June 2015 19:15
Operating System: win7

Re: MySql zeigt leere Seite

Postby camelot » 29. June 2015 19:29

noch etwas zur leeren Seite über http://.....

Das Icon und der Seitentitel (phpmyadmin) im Reiter des Browsers (FF) werden geladen, sonst aber kein Anmeldefenster
In der Adresszeile steht: localhost/phpmyadmin/
camelot
 
Posts: 9
Joined: 28. June 2015 19:15
Operating System: win7

Re: MySql zeigt leere Seite

Postby glitzi85 » 29. June 2015 21:12

Langsam wird's seltsam :?

Hast du es mal mit einem anderen Browser probiert (IE, Chrome)? Gerade FF ist manchmal etwas komisch.

Hast du das Upgrade exakt nach Anleitung durchgeführt (vor allem den alles-löschen-Teil)?

Hat die original XAMPP-Version funktioniert?
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: MySql zeigt leere Seite

Postby camelot » 29. June 2015 21:40

Hallo glitz85,

ich habe gerade mal das http://localhost/phpmyadmin in der Adressleiste des IE ausprobiert, und siehe da, es funktioniert.

Nun muss ich mal schauen, wo das Problem bei dem FF liegt. Ich habe allerdings schon alle Add-ons und Erweiterungen durhgeschaut, da ist
keines dabei, was irgendwie daraufhin weisen könnte

Vielleicht in den Einstellungen des FF (Version 38), da werde ich aber auch nicht fündig
camelot
 
Posts: 9
Joined: 28. June 2015 19:15
Operating System: win7

Re: MySql zeigt leere Seite

Postby glitzi85 » 30. June 2015 08:46

Wie gesagt, FF ist manchmal etwas komisch, ich hatte da auch schon ganz seltsame Effekte. Normalerweise lässt sich sowas dann über das löschen des Browser-Caches lösen (aber leider auch nicht immer).
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: MySql zeigt leere Seite

Postby camelot » 30. June 2015 20:57

Hallo glitzi85,

Problem mit weißer leerer Seite ist gelöst:

Es ist ein Add-on im FF ---> KarmaBlocker, ich habe Ihn einfach deaktiviert, und phpmyadmin läuft nun auch über http://.....
Zwar gibt es nun wieder häßliche Werbeeinblendungen, werde dafür aber alternative Blocker suchen :D

Grüße
camelot
 
Posts: 9
Joined: 28. June 2015 19:15
Operating System: win7

Re: MySql zeigt leere Seite

Postby glitzi85 » 30. June 2015 22:03

Du kannst in der Config auch einfach localhost freischalten:

Code: Select all
[Group]
name = 'Allow localhost'
score = -1000
rule = $url.host=='localhost'


Das ganze direkt nach Settings vor alle anderen Group-Blöcken.
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests