XAMPP + LAN-Stecker

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP + LAN-Stecker

Postby asterix » 24. March 2015 21:46

Hallo zusammen
Folgendes Problem: Ich habe eine XAMPP-Installation auf XP.
Nun läuft alles korrekt, solange ein LAN-Kabel angesteckt ist. Wenn ich aber das LAN-Kabel abhänke, dann komme ich nicht mehr auf den MySQL-Server und auch der Webserver funktioniert nicht richtig:
Warning mySQL-Connect: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte (trying to connect via tcp://localhost:3306)

Ich habe zwar gesehen, dass andere das Problem auch kennen, aber ich habe keine Lösung gefunden.
Kann mir jemand helfen?

vielen Dank im Voraus!
asterix
 
Posts: 10
Joined: 10. February 2015 22:44
Operating System: Mac OS X

Re: XAMPP + LAN-Stecker

Postby Nobbie » 24. March 2015 21:54

asterix wrote:Ich habe zwar gesehen, dass andere das Problem auch kennen, aber ich habe keine Lösung gefunden.


LAN Stecker wieder anstecken.
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: XAMPP + LAN-Stecker

Postby asterix » 25. March 2015 12:45

Da ich den Webserver auch offline brauchen möchte, ist das keine Lösung.
Kennt jemand einen anderen Trick? Oder sogar eine Problemlösung?
asterix
 
Posts: 10
Joined: 10. February 2015 22:44
Operating System: Mac OS X

Re: XAMPP + LAN-Stecker

Postby WilliL » 25. March 2015 22:02

ich habe gerade auf einem XP-Rechner mit XAMPP 1.82b OHNE Netzwerkverbindung getestet - klappt ohne Probleme: Webserver arbeitet, Zugriff auf phpMyAdmin, Zugriff von PHP-Scripten auf Datenbanken
(sowohl die Admin-Buttos im Controllpanel v3.1.0 3.1.0 als auch über den Aufruf 'localhost')
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: XAMPP + LAN-Stecker

Postby asterix » 26. March 2015 12:19

ja das sollte der Normalfall sein.
Aber wenn es nicht funktioniert: Weiss jemand abhilfe? Irgendetwas mit IP-Adresse oder Port-Einstellungen?
Danke für Tipps!
asterix
 
Posts: 10
Joined: 10. February 2015 22:44
Operating System: Mac OS X

Re: XAMPP + LAN-Stecker

Postby WilliL » 26. March 2015 12:36

keine Ahnung was du gemacht / geändert hast - Deine Fehlerbeschreibung ist ähnlich: "Wenn ich den Stecker ziehe, geht die Lampe aus", es fehlt auch eine Info was du schon versucht hast.

schon versucht via Controlpanell auf phpMyadmin zu kommen? (Admin-Button)
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 3 guests