Zugriff aus LAN auf Unterordner will nicht klappen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Zugriff aus LAN auf Unterordner will nicht klappen

Postby Guenny2804 » 24. February 2015 09:17

Hi,

ich komme nicht mehr weiter.

Ich habe ich in der httpd-xampp.conf am Ende bei New Securtiy Feature folgende Änderungen gemacht:
(das xx habe ich nur für den Post hier rein gemacht :) )

Code: Select all
    <LocationMatch "^/(?i:(?:|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
    #Require local
    allow from 172.xx.0.0/16
    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </LocationMatch>


Zusätzlich habe ich ich in der httpd.conf das Document Root angepasst:

Code: Select all
DocumentRoot "c:/xampp/htdocs"
<Directory "c:/Xampp/htdocs">


So weit so gut. Von einem Client aus dem besagten LAN erreiche ich nun die XAMPP installion, PHPMyAdmin etc. ohne Problem - jedoch meinen angelegten Ordner "board" unter htdocs kann ich nicht erreichen bzw. meldet der Browser (Internet Explorer) zurück das die Seite nicht angezeigt werden kann.

Der Firefox zeigt die gleiche Meldung - jedoch passt er die URL zu http://localhost/board/ an.

Wo liegt mein Problem? Ich kann es mir nicht erklären :-(
Guenny2804
 
Posts: 1
Joined: 24. February 2015 09:11
Operating System: Windows

Re: Zugriff aus LAN auf Unterordner will nicht klappen

Postby Nobbie » 24. February 2015 11:49

Guenny2804 wrote:Zusätzlich habe ich ich in der httpd.conf das Document Root angepasst:

Code: Select all
DocumentRoot "c:/xampp/htdocs"
<Directory "c:/Xampp/htdocs">



Was ist daran "angepasst"?? So sieht es doch immer aus (bei Standardinstallation nach c:/xampp)? Du hast da allerings groß "Xampp" und klein "xampp" vermischt, mache das mal einheitlich. Das kann schon die Ursache sein.

Guenny2804 wrote: meldet der Browser (Internet Explorer) zurück das die Seite nicht angezeigt werden kann.


Bitte nicht Prosameldungen, sondern die vollständige Originalmeldung. Inkl. Errror Code.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Zugriff aus LAN auf Unterordner will nicht klappen

Postby cmb69 » 24. February 2015 19:14

Guenny2804 wrote:Von einem Client aus dem besagten LAN erreiche ich nun die XAMPP installion, PHPMyAdmin etc. ohne Problem - jedoch meinen angelegten Ordner "board" unter htdocs kann ich nicht erreichen bzw. meldet der Browser (Internet Explorer) zurück das die Seite nicht angezeigt werden kann.

Dann schau Dir mal die erste Zeile im geposteten Ausschnitt von httpd-xampp.conf genauer an:
Code: Select all
<LocationMatch "^/(?i:(?:|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
User avatar
cmb69
 
Posts: 22
Joined: 18. October 2012 03:09
Location: Germany
Operating System: Windows 7 Home Premium

Re: Zugriff aus LAN auf Unterordner will nicht klappen

Postby Altrea » 24. February 2015 20:37

cmb69 wrote:Dann schau Dir mal die erste Zeile im geposteten Ausschnitt von httpd-xampp.conf genauer an

Der mit der geschilderten Problematik genau garnichts zu tun hat
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Zugriff aus LAN auf Unterordner will nicht klappen

Postby cmb69 » 24. February 2015 22:25

Altrea wrote:
cmb69 wrote:Dann schau Dir mal die erste Zeile im geposteten Ausschnitt von httpd-xampp.conf genauer an

Der mit der geschilderten Problematik genau garnichts zu tun hat

Bei mir ist diese Location halt quasi anders herum konfiguriert (Require all denied), und da habe ich aus dem LAN Zugriff auf Unterordner von htdocs/, aber eben nicht auf phpMyAdmin oder das Root-Verzeichnis direkt. Ich dachte, das würde zur Problembeschreibung von Guenny2804 passen: "Von einem Client aus dem besagten LAN erreiche ich nun die XAMPP installion, PHPMyAdmin etc. ohne Problem - jedoch meinen angelegten Ordner "board" unter htdocs kann ich nicht erreichen".

Aber vermutlich hast Du recht -- ich bin Apache-Anfänger. :)
User avatar
cmb69
 
Posts: 22
Joined: 18. October 2012 03:09
Location: Germany
Operating System: Windows 7 Home Premium

Re: Zugriff aus LAN auf Unterordner will nicht klappen

Postby Altrea » 24. February 2015 22:56

cmb69 wrote:Bei mir ist diese Location halt quasi anders herum konfiguriert (Require all denied),

Was ja auch der Auslieferungszustand ist. Bestimmte sensible Bereiche sind nur von localhost erreichbar.

cmb69 wrote:und da habe ich aus dem LAN Zugriff auf Unterordner von htdocs/, aber eben nicht auf phpMyAdmin oder das Root-Verzeichnis direkt.

Auf das root Verzeichnis hast du Zugriff, nur liegt dort eine index.php die eine Weiterleitung ins Unterverzeichnis /xampp ausführt welche geschützt ist.

cmb69 wrote:Ich dachte, das würde zur Problembeschreibung von Guenny2804 passen: "Von einem Client aus dem besagten LAN erreiche ich nun die XAMPP installion, PHPMyAdmin etc. ohne Problem - jedoch meinen angelegten Ordner "board" unter htdocs kann ich nicht erreichen".

Eben nicht. Der Ordner /xampp/htdocs/board/ wird nicht über das security concept reglementiert, und genau bei diesem besteht ja das Problem.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Zugriff aus LAN auf Unterordner will nicht klappen

Postby cmb69 » 25. February 2015 22:24

Altrea wrote:Auf das root Verzeichnis hast du Zugriff, nur liegt dort eine index.php die eine Weiterleitung ins Unterverzeichnis /xampp ausführt welche geschützt ist.

Ah, danke. :)

Altrea wrote:Eben nicht. Der Ordner /xampp/htdocs/board/ wird nicht über das security concept reglementiert, und genau bei diesem besteht ja das Problem.

Na ja, Guenny2804 hat das Security Concept ja auch "umgedreht". Nun ist auf die eigentlich schützenswerten Ordner der Zugriff möglich. Ganz vielleicht (reine Spekulation) sieht die Sache ja bei Guenny2804 so aus:
Code: Select all
Require all denied
    <LocationMatch "^/(?i:(?:|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
    #Require local
    allow from 172.xx.0.0/16
    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </LocationMatch>

Wäre zwar unsinnig, würde aber das geschilderte Verhalten erklären (falls ich mich nicht irre).
User avatar
cmb69
 
Posts: 22
Joined: 18. October 2012 03:09
Location: Germany
Operating System: Windows 7 Home Premium

Re: Zugriff aus LAN auf Unterordner will nicht klappen

Postby Altrea » 25. February 2015 22:46

cmb69 wrote:Na ja, Guenny2804 hat das Security Concept ja auch "umgedreht".

Das ist reine Spekulation. Das einzige was wir bisher wissen ist, dass er das Security Concept aufgeweicht hat.
Von einem Require all denied war auch nie die Rede.

Ich tippe aus meiner Erfahrung eher darauf, dass uns Informationen vorenthalten oder falsch mitgeteilt werden.
Zum Beispiel halte ich es für viel Wahrscheinlicher, dass der Threadersteller einen HTTP Error-Code 404 (File not found) und nicht 403 (Forbidden) erhält, weil er das Verzeichnis "board" an einem falschen Ort erstellt hat oder sich bei der URL vertippt hat.

Aber ohne weitere Informationen von Guenny macht es keinen Sinn weiter zu spekulieren.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests