Xampp Interface bekommt keine Parameter

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp Interface bekommt keine Parameter

Postby Eye » 27. January 2015 02:57

Hallo ihr,

ich habe das Problem das ich mit einer App auf mein in PHP geschriebenes Interface zugreifen möchte, durch das ich Zugriff auf meine SQL Datenbank erhalte. Solange ich mich im heimischen Netzwerk befinde ist das ganze auch kein Problem. Wenn ich allerdings über meine dyndnss.net Adresse darauf zugreifen möchte, werden meine Parameter nicht mit übertragen und meine SQL Abfrage wird nicht ausgeführt. Eine Portweiterleitung des Ports 80 ist auch zu meinem mit xampp bespielten Rechner aktiv, wodurch ich die startseite von Xampp erreichen konnte. Daraufhin habe ich die startseite durch mein Interface ersetzt und kann keine Parameter hinterlegen

Kann mir da irgendwer bei helfen?
Eye
 
Posts: 3
Joined: 27. January 2015 02:51
Operating System: Windows 7

Re: Xampp Interface bekommt keine Parameter

Postby Nobbie » 27. January 2015 14:18

Das ist leider viel zu wenig Information, erläutere mal ausführlich, was Du da genau machst.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Xampp Interface bekommt keine Parameter

Postby Eye » 28. January 2015 04:32

Ich würde gerne auf meinen Apache aus xampp über etwas wie www.bla.dyndnss.net/index.php?method=GetEAN zugreifen allerdings werden meine angehängten Parameter nicht mit übertragen. Könnte das an dem DDNS Dienst liegen?
Eye
 
Posts: 3
Joined: 27. January 2015 02:51
Operating System: Windows 7

Re: Xampp Interface bekommt keine Parameter

Postby Altrea » 28. January 2015 06:41

Klar könnte es daran liegen.
Doch ohne auch nur das geringste über dein Script und die Konfiguration der beteiligten Komponenten zu wissen ist alles reine Spekulation
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Xampp Interface bekommt keine Parameter

Postby Nobbie » 28. January 2015 15:09

Eye wrote:Könnte das an dem DDNS Dienst liegen?


Glaube ich nicht.

VIelleicht hast Du irgendwo eine .htaccess, die de Parameter abhackt oder sonst so etwas. Mit DDNS hat das sicherlich nichts zu tun, ich wüßte nicht wie.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Xampp Interface bekommt keine Parameter

Postby Eye » 29. January 2015 05:10

so um das mal etwas voran zu treiben hier mein Interface das ich zum laufen bringen möchte:
Code: Select all
<?php
    $DBIP = 'localhost';
    $DBUser = 'root';
    $DBPasswort = '';
   
    /* connect to the db */
    $link = mysql_connect($DBIP,$DBUser,$DBPasswort) or die('Cannot connect to the DB');
    mysql_select_db('CO2',$link) or die('Cannot select the DB');
    mysql_query("SET NAMES 'utf8'");
    mysql_query("SET CHARACTER SET 'utf8'");
    $method = $_GET['method'];
    switch($method)
    {
        case "GetEAN":
            $EAN = $_GET['EAN'];
         $ART = $_GET['ART'];
            $query = mysql_query("
                SELECT Produktname, CO2
                FROM Produkt
                Where Code ='".$EAN."' AND Codeart ='".$ART."'
            ");
            output($query);
        break;
      case "GetEANS":
            $query = mysql_query("
                SELECT Produktname, CO2
                FROM Produkt
            ");
            output($query);
        break;       
        default:
            $query = mysql_query("
                SELECT Produktname, CO2
                FROM Produkt
            ");
            output($query);          
        break;
    }
   
    function input($eintragen)
    {
        if($eintragen == true)
        {
            echo "Eintrag war erfolgreich";
        }
        else
        {
         echo mysql_error();
        }
    }
   
    function output($query)
    {
        $rows = array();
        while($r = mysql_fetch_assoc($query))
        {
            $rows[] = $r;
        }
        print json_encode($rows);
    }
?>


im normalen Netzwerk funktioniert das auch das mir meine Datenbank den passenden Eintrag liefert. Wenn ich allerdings aus dem Netz darauf zugreifen will erscheint
Notice: Undefined index: method in C:\xampp\htdocs\index.php on line 11


Ich rufe das über
http://localhost/index.php?method=GetEAN&EAN=5449000017956&ART=EAN_13
auf und ansonsten halt den localhost durch die ddns Adresse ersetzt

falls ihr noch etwas von mir braucht schreibt mir was ihr braucht.

Vielen Dank schonmal :)
Eye
 
Posts: 3
Joined: 27. January 2015 02:51
Operating System: Windows 7

Re: Xampp Interface bekommt keine Parameter

Postby Nobbie » 29. January 2015 13:31

Setze doch mal an den Anfang des Scripts einen phpinfo() Aufruf, und zeige uns den Screenoutput (insbesondere den unteren Teil, wo die Variablen auftauchen).

Hast Du einen VirtualHost konfiguriert für die externe DNS? Oder befindet sich eine .htaccess im htdocs Verzeichnis? Was für einen Router benutzt Du, gibt es dort ggf. ein Problem mit einer Firewall o.ä.?
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 19 guests