Zugriff verweigert nach verschieben von htdocs

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Zugriff verweigert nach verschieben von htdocs

Postby pospiech » 18. January 2015 20:07

Ich habe den htdocs Ordner verschoben, d.h. eigentlich habe ich einen Link in C:\xampp\ anglegt der nach E:\Programme\xampp\htdocs zeigt, aber die Webseiten
selber zeigen mir alle Fehler mit einem Pfad E:\... an. Also habe ich die vhost Ordner gleich geändert auf
Code: Select all
<VirtualHost local-matthias.dev>
    ServerAdmin admin@localhost.com
    DocumentRoot "E:/Programme/xampp/htdocs/matthias"
    ServerName local-matthias.dev
    ServerAlias local-matthias.dev
    <Directory "E:/Programme/xampp/htdocs/matthias">
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>


Das allerdings liefert mir den Fehler 403, Zugriff verweigert.

Was muss ich ändern?
pospiech
 
Posts: 27
Joined: 17. March 2005 13:15
Location: Hannover

Re: Zugriff verweigert nach verschieben von htdocs

Postby Nobbie » 18. January 2015 20:19

pospiech wrote:Ich habe den htdocs Ordner verschoben, d.h. eigentlich habe ich einen Link in C:\xampp\ anglegt der nach E:\Programme\xampp\htdocs zeigt, aber die Webseiten
selber zeigen mir alle Fehler mit einem Pfad E:\... an.


Ich verstehe nur "Bahnhof". Grundsätzlich sind LInks, die auf lokale Partitionen verweisen (statt auf eine URL), vollkommen sinnlos, weil sie von anderen Rechnern aus nicht funktionieren. Wahrscheinlich ist das der Fehler, aber bei dieser knappen Minibeschreibung ist das zum größten Teil geraten.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: Zugriff verweigert nach verschieben von htdocs

Postby pospiech » 18. January 2015 22:38

Nobbie wrote:Ich verstehe nur "Bahnhof". Grundsätzlich sind LInks, die auf lokale Partitionen verweisen (statt auf eine URL), vollkommen sinnlos, weil sie von anderen Rechnern aus nicht funktionieren.

Die Links im Dateisystem haben nur auf dem Lokalen BS eine Bedeutung. Die Seite ist eh nur auf localhost.
Das schien auch nicht das Problem zu sein, denn diese Konfiguration scheint jetzt zu funktionieren:

Code: Select all
<VirtualHost local-matthias.dev>
    ServerAdmin admin@localhost.com
    DocumentRoot "E:/Programme/xampp/htdocs/matthias"
    ServerName local-matthias.dev
    ServerAlias local-matthias.dev
    <Directory "E:/Programme/xampp/htdocs/matthias">
      Options Indexes FollowSymLinks Includes ExecCGI
      AllowOverride All
      Order allow,deny
      Allow from all
      Require all granted
   </Directory>
</VirtualHost>
pospiech
 
Posts: 27
Joined: 17. March 2005 13:15
Location: Hannover


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests