Inno - DB in phpmyadmin

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Inno - DB in phpmyadmin

Postby Stephan46 » 18. August 2004 09:10

Hallo !

Ich habe gestern xampp für Windows in der Version 1.42 installiert.
Unter phpmyadmin habe ich in einer Datenbank Tabellen angelegt.
Standardmäßig werden diese Tabellen als Typ 'myisam' angelegt.
Wenn ich unter 'Operationen' den Tabellentyp auf 'innodb' ändern möchte
dann finde ich diesen Tabellentyp nicht.
Was mache ich verkehrt ?


m.f.G.

Stephan
Stephan46
 
Posts: 3
Joined: 17. August 2004 13:29

Postby BartonFink » 18. August 2004 12:57

Code: Select all
# Uncomment the following if you are using InnoDB tables
...
...
...


in der my.cnf (bzw my.ini) :wink:
BartonFink
 
Posts: 8
Joined: 17. April 2004 09:03

Uncomment in php.ini

Postby Stephan46 » 19. August 2004 06:41

Hallo !

Ich nochmal. Was muss in der php.ini auskommentiert werden.


m.f.G.

Stephan
Stephan46
 
Posts: 3
Joined: 17. August 2004 13:29

Danke

Postby Stephan46 » 19. August 2004 08:14

Hilfe ich habe php.ini und my.ini miteinander verwechselt.
:oops:

Ich habe in der mysql.ini jetzt folgende Einträge.

++++++++++++++++++++++++++++++++++++++

skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = C:/Programme/xampp/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = C:/Programme/xampp/mysql/
innodb_log_arch_dir = C:/Programme/xampp/mysql/

# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M

# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

+++++++++++++++++++++++++++++++++++

Mysql wurde mit diesen Einträgen neu gestartet.
Leider werden in phpmyadmin immer noch keine InnoDB angezeigt.
Hat jemand eine Idee ?


m.f.G.

Stephan
Stephan46
 
Posts: 3
Joined: 17. August 2004 13:29

Postby Wiedmann » 19. August 2004 09:59

Ich habe in der mysql.ini jetzt folgende Einträge:
skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = C:/Programme/xampp/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = C:/Programme/xampp/mysql/
innodb_log_arch_dir = C:/Programme/xampp/mysql/
...
Hat jemand eine Idee ?

http://dev.mysql.com/doc/mysql/en/Server_options.html
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests