Apache startet nach Installation von XAMPP nicht!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nach Installation von XAMPP nicht!

Postby ManfrK » 28. December 2014 20:23

Hallo,
ich habe gestern erstmalig XAMPP für Windows auf meinem Rechner installiert (Windows 7). Habe jetzt den Effekt, daß Apache nicht startet (m.M. liegt es an einem doppelt
belegten Port. Ich komme leider nach mehreren Versuchen nicht weiter, immer wieder die selben Fehlermeldungen...
Von einem ähnlichen Beitrag weiter unten (Forumsmitglied "FelixSoft2_NEW") habe ich (erfolglos) diese Lösung nachvollzogen (d.h. ich hab jetzt Apache Port 80 auf 81
geändert:
Code: Select all
Lösung
1. Klicke im XAMPP Control Panel bei Apache auf Config und dann auf "Apache (httpd.conf)"
2. im Editor auf Bearbeiten -> Suchen und zum suchen den Text "Listen 80" eingeben
dann "Listen 80" mit "Listen 81" replacen.
3. im Editor auf Bearbeiten -> Suchen und zum suchen den Text "ServerName localhost:80"
eingeben dann "ServerName localhost:80" mit "ServerName localhost:81" replacen.
4. Datei Speichern und Editor Schließen.
5. Im XAMPP Control Panel auf Config mit dem Schraubenschlüssel anklicken und
"Service and Port Settings" anklicken.
6. In den "Service Settings" im Reiter Apache bei Main Port das 80 mit 81 replacen und Save
drücken.
7. Im "Configuration of Control Panel" Save anklicken.
8. Apache Starten und glücklich sein.
Wenn man Skype hat:
Gibt es eine sache die man leicht tun kann.
1. In Skype unter Aktionen Optionen (Ctrl + ,) anklicken.
2. Im Optionen Fenster von Skype auf den Reiter Erweitert klicken und darin den
Untergeordneten Reiter Verbindung anklicken
3. Im Untergeordneten Reiter Verbindung dann den Haken bei
"Ports 80 und 443 für zusätzliche eingehende Verbindungen verwenden" entfernen.
4. Speichern anklicken
Das mit Skype hatte bei mir nur so funktioniert.


Ich bräuchte dringend eure Hilfe (möchte anschließend noch "Joomla! 2.5" installieren, doch wenn Apache schon nicht startet, hab ich da wohl keine Chance weiterzukommen...

Laut XAMPP Control Panel füge ich mal den Inhalt des Hauptfensters (1. Start MySQL, 2. Start Apache) hinzu wg. der Fehlerausgaben:

Code: Select all
20:11:47  [main]    Initialisere Control Panel
20:11:47  [main]    Windows Version: Windows 7 Professional SP1 32-bit
20:11:47  [main]    XAMPP Version: 5.6.3
20:11:47  [main]    Control Panel Version: 3.2.1  [ Compiled: May 7th 2013 ]
20:11:47  [main]    Dein Benutzerprofil besitzt keine Administratorenrechte! Das reicht aus für die meisten
20:11:47  [main]    Anwendungsfunktionen, aber wann immer du etwas mit Windows-Diensten tun möchtest,
20:11:47  [main]    wird eine Sicherheitsabfrage erscheinen oder etwas wird garnicht erst funktionieren!
20:11:47  [main]    Also denke daran diese Anwendung mit Administratorrechten zu starten!
20:11:47  [main]    XAMPP Installationsverzeichnis: "c:\xampp\"
20:11:47  [main]    Voraussetzungen werden geprüft
20:11:47  [main]    Alle Voraussetzungen sind erfüllt
20:11:47  [main]    Initialisiere Module
20:11:47  [main]    Aktiviere Autostart für Modul "MySQL"
20:11:47  [main]    Starte Check-Timer
20:11:47  [main]    Control Panel bereit
20:11:48  [mysql]    Autostart aktiv: Starte...
20:11:48  [mysql]    Versuche MySQL zu starten...
20:11:48  [mysql]    Statusänderung erkannt: gestartet
20:11:55  [Apache]    Versuche Apache zu starten...
20:11:55  [Apache]    Statusänderung erkannt: gestartet
20:11:56  [Apache]    Statusänderung erkannt: gestoppt
20:11:56  [Apache]    Fehler: Apache wurde unerwartet beendet
20:11:56  [Apache]    Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
20:11:56  [Apache]    fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
20:11:56  [Apache]    Drücke den Logs Button um error logs zu sehen und prüfe
20:11:56  [Apache]    im Windows Event Viewer für weitere Hinweise
20:11:56  [Apache]    Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
20:11:56  [Apache]    und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.


Hier jetzt noch die Error-Log-Ausgabe des Apache-Moduls nach diesen Startversuchen:

Code: Select all
[Sat Dec 27 21:11:23.877800 2014] [ssl:warn] [pid 5692:tid 232] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:11:24.565800 2014] [ssl:warn] [pid 5692:tid 232] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:11:25.184800 2014] [mpm_winnt:notice] [pid 5692:tid 232] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.6.3 configured -- resuming normal operations
[Sat Dec 27 21:11:25.184800 2014] [mpm_winnt:notice] [pid 5692:tid 232] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Sat Dec 27 21:11:25.184800 2014] [core:notice] [pid 5692:tid 232] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sat Dec 27 21:11:25.211800 2014] [mpm_winnt:notice] [pid 5692:tid 232] AH00418: Parent: Created child process 4932
[Sat Dec 27 21:11:25.909800 2014] [ssl:warn] [pid 4932:tid 244] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:11:26.282800 2014] [ssl:warn] [pid 4932:tid 244] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:11:26.346800 2014] [mpm_winnt:notice] [pid 4932:tid 244] AH00354: Child: Starting 150 worker threads.
[Sat Dec 27 21:12:03.707800 2014] [mpm_winnt:crit] [pid 4932:tid 244] AH02538: Child: Parent process exited abruptly. Child process is ending
[Sat Dec 27 21:12:03.708800 2014] [mpm_winnt:warn] [pid 4932:tid 4] (OS 995)Der E/A-Vorgang wurde wegen eines Threadendes oder einer Anwendungsanforderung abgebrochen.  : AH00341: winnt_accept: Asynchronous AcceptEx failed.
[Sat Dec 27 21:12:03.708800 2014] [mpm_winnt:error] [pid 4932:tid 4] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : AH00337: Child: Encountered too many AcceptEx faults accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software.
[Sat Dec 27 21:12:03.708800 2014] [mpm_winnt:notice] [pid 4932:tid 4] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : AH00338: winnt_mpm: falling back to 'AcceptFilter none'.
[Sat Dec 27 21:23:47.466800 2014] [ssl:warn] [pid 12648:tid 232] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:23:47.550800 2014] [core:warn] [pid 12648:tid 232] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Dec 27 21:23:47.832800 2014] [ssl:warn] [pid 12648:tid 232] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:23:47.877800 2014] [mpm_winnt:notice] [pid 12648:tid 232] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.6.3 configured -- resuming normal operations
[Sat Dec 27 21:23:47.877800 2014] [mpm_winnt:notice] [pid 12648:tid 232] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Sat Dec 27 21:23:47.877800 2014] [core:notice] [pid 12648:tid 232] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sat Dec 27 21:23:47.890800 2014] [mpm_winnt:notice] [pid 12648:tid 232] AH00418: Parent: Created child process 5332
[Sat Dec 27 21:23:48.510800 2014] [ssl:warn] [pid 5332:tid 244] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:23:48.813800 2014] [ssl:warn] [pid 5332:tid 244] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:23:48.855800 2014] [mpm_winnt:notice] [pid 5332:tid 244] AH00354: Child: Starting 150 worker threads.
[Sat Dec 27 21:32:30.084800 2014] [ssl:warn] [pid 4656:tid 232] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:32:30.636800 2014] [ssl:warn] [pid 4656:tid 232] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:32:30.677800 2014] [mpm_winnt:notice] [pid 4656:tid 232] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.6.3 configured -- resuming normal operations
[Sat Dec 27 21:32:30.677800 2014] [mpm_winnt:notice] [pid 4656:tid 232] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Sat Dec 27 21:32:30.677800 2014] [core:notice] [pid 4656:tid 232] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sat Dec 27 21:32:30.705800 2014] [mpm_winnt:notice] [pid 4656:tid 232] AH00418: Parent: Created child process 10276
Apache server shutdown initiated...
sl:warn] [pid 10276:tid 244] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:32:31.624800 2014] [ssl:warn] [pid 10276:tid 244] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Dec 27 21:32:31.671800 2014] [mpm_winnt:notice] [pid 10276:tid 244] AH00354: Child: Starting 150 worker threads.
[Sun Dec 28 00:37:40.890800 2014] [mpm_winnt:notice] [pid 4656:tid 232] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Sun Dec 28 00:37:43.001800 2014] [mpm_winnt:notice] [pid 10276:tid 244] AH00364: Child: All worker threads have exited.


Ich hoffe, jemand kann mir weiterhelfen.

Im voraus recht herzlichen Dank!

ManfrK
ManfrK
 
Posts: 6
Joined: 28. December 2014 19:56
Operating System: Windows 7 Pro

Re: Apache startet nach Installation von XAMPP nicht!

Postby Altrea » 29. December 2014 07:46

Hallo ManfrK,

Einmal bitte die apache_start.bat ausführen und dessen Rückmeldung hier posten.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nach Installation von XAMPP nicht!

Postby ManfrK » 30. December 2014 00:03

Hallo Altrea,

Einmal bitte die apache_start.bat ausführen und dessen Rückmeldung hier posten.


wie ich oben erwähnt hab, hab ich noch keine Erfahrung mit XAMPP / Joomla!. Die "apache_start.bat" find ich nirgends. Meinst Du, den "Starten"-Button vom Apache-Modul drücken (quasi
Apache normal in XAMPP starten und dann die Ausgabe posten? Ich mach das einfach mal.

Code: Select all
23:41:23  [Apache]    Fehler: Apache wurde unerwartet beendet
23:41:23  [Apache]    Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
23:41:23  [Apache]    fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
23:41:23  [Apache]    Drücke den Logs Button um error logs zu sehen und prüfe
23:41:23  [Apache]    im Windows Event Viewer für weitere Hinweise
23:41:23  [Apache]    Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
23:41:23  [Apache]    und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.


Falls Du doch eine andere Datei benötigst (evtl. in Logs v. Apache "access.log" oder "error.log") bitte nochmal melden, dann poste ich auch diese.

mit freundlichen Grüßen
ManfrK
ManfrK
 
Posts: 6
Joined: 28. December 2014 19:56
Operating System: Windows 7 Pro

Re: Apache startet nach Installation von XAMPP nicht!

Postby Altrea » 30. December 2014 01:15

ManfrK wrote:Die "apache_start.bat" find ich nirgends. Meinst Du, den "Starten"-Button vom Apache-Modul drücken (quasi
Apache normal in XAMPP starten und dann die Ausgabe posten?

Nein, ich meine Tatsächlich die Datei \xampp\apache_start.bat

Alternativ dazu kannst du auch die Windows Eingabeaufforderung öffnen, ins Verzeichnis \xampp\apache\bin\ navigieren und die Datei httpd.exe aufrufen
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nach Installation von XAMPP nicht!

Postby ManfrK » 30. December 2014 01:44

Hallo Altrea,

ich hab jetzt die "apache_start.bat" gestartet und die Ausgabe sieht dann so aus:

Code: Select all
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
httpd.exe: Syntax error on line 155 of C:/xampp/apache/conf/httpd.conf: LoadModu
le takes two arguments, a module name and the name of a shared object file to lo
ad it from

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .


Ich hoffe, es hilft weiter.

ManfrK
ManfrK
 
Posts: 6
Joined: 28. December 2014 19:56
Operating System: Windows 7 Pro

Re: Apache startet nach Installation von XAMPP nicht!

Postby Altrea » 30. December 2014 02:39

ManfrK wrote:httpd.exe: Syntax error on line 155 of C:/xampp/apache/conf/httpd.conf: LoadModule takes two arguments, a module name and the name of a shared object file to load it from

Dann poste doch mal Zeile 155 und folgende deiner C:/xampp/apache/conf/httpd.conf
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nach Installation von XAMPP nicht!

Postby ManfrK » 30. December 2014 23:23

Hallo Altrea,

hier die Datei "httpd.conf" ab Zeile 155:

Code: Select all
LoadModule rewrite_module
#LoadModule sed_module modules/mod_sed.so
#LoadModule session_module modules/mod_session.so
#LoadModule session_cookie_module modules/mod_session_cookie.so
#LoadModule session_crypto_module modules/mod_session_crypto.so
#LoadModule session_dbd_module modules/mod_session_dbd.so
LoadModule setenvif_module modules/mod_setenvif.so
#LoadModule slotmem_plain_module modules/mod_slotmem_plain.so
#LoadModule slotmem_shm_module modules/mod_slotmem_shm.so
#LoadModule socache_dbm_module modules/mod_socache_dbm.so
#LoadModule socache_memcache_module modules/mod_socache_memcache.so
LoadModule socache_shmcb_module modules/mod_socache_shmcb.so
#LoadModule speling_module modules/mod_speling.so
LoadModule ssl_module modules/mod_ssl.so
LoadModule status_module modules/mod_status.so
#LoadModule substitute_module modules/mod_substitute.so
#LoadModule unique_id_module modules/mod_unique_id.so
#LoadModule userdir_module modules/mod_userdir.so
#LoadModule usertrack_module modules/mod_usertrack.so
LoadModule version_module modules/mod_version.so
#LoadModule vhost_alias_module modules/mod_vhost_alias.so
#LoadModule watchdog_module modules/mod_watchdog.so
#LoadModule xml2enc_module modules/mod_xml2enc.so

<IfModule unixd_module>
#
# If you wish httpd to run as a different user or group, you must run
# httpd as root initially and it will switch. 
#
# User/Group: The name (or #number) of the user/group to run httpd as.
# It is usually good practice to create a dedicated user and group for
# running httpd, as with most system services.
#
User daemon
Group daemon

</IfModule>

# 'Main' server configuration
#
# The directives in this section set up the values used by the 'main'
# server, which responds to any requests that aren't handled by a
# <VirtualHost> definition.  These values also provide defaults for
# any <VirtualHost> containers you may define later in the file.
#
# All of these directives may appear inside <VirtualHost> containers,
# in which case these default settings will be overridden for the
# virtual host being defined.
#

#
# ServerAdmin: Your address, where problems with the server should be
# e-mailed.  This address appears on some server-generated pages, such
# as error documents.  e.g. admin@your-domain.com
#
ServerAdmin postmaster@localhost

#
# ServerName gives the name and port that the server uses to identify itself.
# This can often be determined automatically, but we recommend you specify
# it explicitly to prevent problems during startup.
#
# If your host doesn't have a registered DNS name, enter its IP address here.
#
ServerName localhost:81

#
# Deny access to the entirety of your server's filesystem. You must
# explicitly permit access to web content directories in other
# <Directory> blocks below.
#
<Directory />
    AllowOverride none
    Require all denied
</Directory>

#
# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.
#

#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "C:/xampp/htdocs"
<Directory "C:/xampp/htdocs">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.4/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks Includes ExecCGI

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   AllowOverride FileInfo AuthConfig Limit
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Require all granted
</Directory>

#
# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
#
<IfModule dir_module>
    DirectoryIndex index.php index.pl index.cgi index.asp index.shtml index.html index.htm \
                   default.php default.pl default.cgi default.asp default.shtml default.html default.htm \
                   home.php home.pl home.cgi home.asp home.shtml home.html home.htm
</IfModule>

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<Files ".ht*">
    Require all denied
</Files>

#
# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog "logs/error.log"

#
# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel warn

<IfModule log_config_module>
    #
    # The following directives define some format nicknames for use with
    # a CustomLog directive (see below).
    #
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common

    <IfModule logio_module>
      # You need to enable mod_logio.c to use %I and %O
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
    </IfModule>

    #
    # The location and format of the access logfile (Common Logfile Format).
    # If you do not define any access logfiles within a <VirtualHost>
    # container, they will be logged here.  Contrariwise, if you *do*
    # define per-<VirtualHost> access logfiles, transactions will be
    # logged therein and *not* in this file.
    #
    #CustomLog "logs/access.log" common

    #
    # If you prefer a logfile with access, agent, and referer information
    # (Combined Logfile Format) you can use the following directive.
    #
    CustomLog "logs/access.log" combined
</IfModule>

<IfModule alias_module>
    #
    # Redirect: Allows you to tell clients about documents that used to
    # exist in your server's namespace, but do not anymore. The client
    # will make a new request for the document at its new location.
    # Example:
    # Redirect permanent /foo http://www.example.com/bar

    #
    # Alias: Maps web paths into filesystem paths and is used to
    # access content that does not live under the DocumentRoot.
    # Example:
    # Alias /webpath /full/filesystem/path
    #
    # If you include a trailing / on /webpath then the server will
    # require it to be present in the URL.  You will also likely
    # need to provide a <Directory> section to allow access to
    # the filesystem path.

    #
    # ScriptAlias: This controls which directories contain server scripts.
    # ScriptAliases are essentially the same as Aliases, except that
    # documents in the target directory are treated as applications and
    # run by the server when requested rather than as documents sent to the
    # client.  The same rules about trailing "/" apply to ScriptAlias
    # directives as to Alias.
    #
    ScriptAlias /cgi-bin/ "C:/xampp/cgi-bin/"

</IfModule>

<IfModule cgid_module>
    #
    # ScriptSock: On threaded servers, designate the path to the UNIX
    # socket used to communicate with the CGI daemon of mod_cgid.
    #
    #Scriptsock cgisock
</IfModule>

#
# "C:/xampp/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "C:/xampp/cgi-bin">
    AllowOverride All
    Options None
    Require all granted
</Directory>

<IfModule mime_module>
    #
    # TypesConfig points to the file containing the list of mappings from
    # filename extension to MIME-type.
    #
    TypesConfig conf/mime.types

    #
    # AddType allows you to add to or override the MIME configuration
    # file specified in TypesConfig for specific file types.
    #
    #AddType application/x-gzip .tgz
    #
    # AddEncoding allows you to have certain browsers uncompress
    # information on the fly. Note: Not all browsers support this.
    #
    #AddEncoding x-compress .Z
    #AddEncoding x-gzip .gz .tgz
    #
    # If the AddEncoding directives above are commented-out, then you
    # probably should define those extensions to indicate media types:
    #
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz

    #
    # AddHandler allows you to map certain file extensions to "handlers":
    # actions unrelated to filetype. These can be either built into the server
    # or added with the Action directive (see below)
    #
    # To use CGI scripts outside of ScriptAliased directories:
    # (You will also need to add "ExecCGI" to the "Options" directive.)
    #
    AddHandler cgi-script .cgi .pl .asp

    # For type maps (negotiated resources):
    #AddHandler type-map var

    #
    # Filters allow you to process content before it is sent to the client.
    #
    # To parse .shtml files for server-side includes (SSI):
    # (You will also need to add "Includes" to the "Options" directive.)
    #
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
</IfModule>

#
# The mod_mime_magic module allows the server to use various hints from the
# contents of the file itself to determine its type.  The MIMEMagicFile
# directive tells the module where the hint definitions are located.
#
<IfModule mime_magic_module>
    #
    # The mod_mime_magic module allows the server to use various hints from the
    # contents of the file itself to determine its type.  The MIMEMagicFile
    # directive tells the module where the hint definitions are located.
    #
    MIMEMagicFile "conf/magic"
</IfModule>


#
# Customizable error responses come in three flavors:
# 1) plain text 2) local redirects 3) external redirects
#
# Some examples:
#ErrorDocument 500 "The server made a boo boo."
#ErrorDocument 404 /missing.html
#ErrorDocument 404 "/cgi-bin/missing_handler.pl"
#ErrorDocument 402 http://www.example.com/subscription_info.html
#

#
# MaxRanges: Maximum number of Ranges in a request before
# returning the entire resource, or one of the special
# values 'default', 'none' or 'unlimited'.
# Default setting is to accept 200 Ranges.
#MaxRanges unlimited

#
# EnableMMAP and EnableSendfile: On systems that support it,
# memory-mapping or the sendfile syscall may be used to deliver
# files.  This usually improves server performance, but must
# be turned off when serving from networked-mounted
# filesystems or if support for these functions is otherwise
# broken on your system.
# Defaults: EnableMMAP On, EnableSendfile Off
#
#EnableMMAP off
#EnableSendfile off

# Supplemental configuration
#
# The configuration files in the conf/extra/ directory can be
# included to add extra features or to modify the default configuration of
# the server, or you may simply copy their contents here and change as
# necessary.

# Server-pool management (MPM specific)
Include conf/extra/httpd-mpm.conf

# Multi-language error messages
Include conf/extra/httpd-multilang-errordoc.conf

# Fancy directory listings
Include conf/extra/httpd-autoindex.conf

# Language settings
Include conf/extra/httpd-languages.conf

# User home directories
Include conf/extra/httpd-userdir.conf

# Real-time info on requests and configuration
Include conf/extra/httpd-info.conf

# Virtual hosts
Include conf/extra/httpd-vhosts.conf

# Local access to the Apache HTTP Server Manual
#Include conf/extra/httpd-manual.conf

# Distributed authoring and versioning (WebDAV)
#Attention! WEB_DAV is a security risk without a new userspecific configuration for a secure authentifcation
#Include conf/extra/httpd-dav.conf

# Various default settings
#Include conf/extra/httpd-default.conf
# Implements a proxy/gateway for Apache.
Include "conf/extra/httpd-proxy.conf"
# Various default settings
Include "conf/extra/httpd-default.conf"
# XAMPP settings
Include "conf/extra/httpd-xampp.conf"

# Configure mod_proxy_html to understand HTML4/XHTML1
<IfModule proxy_html_module>
Include conf/extra/proxy-html.conf
</IfModule>

# Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf
#
# Note: The following must must be present to support
#       starting without SSL on platforms with no /dev/random equivalent
#       but a statically compiled-in mod_ssl.
#
<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
</IfModule>
#
# uncomment out the below to deal with user agents that deliberately
# violate open standards by misusing DNT (DNT *must* be a specific
# end-user choice)
#
#<IfModule setenvif_module>
#BrowserMatch "MSIE 10.0;" bad_DNT
#</IfModule>
#<IfModule headers_module>
#RequestHeader unset DNT env=bad_DNT
#</IfModule>

# XAMPP: We disable operating system specific optimizations for a listening
# socket by the http protocol here. IE 64 bit make problems without this.

AcceptFilter http none

# AJP13 Proxy
<IfModule mod_proxy.c>
<IfModule mod_proxy_ajp.c>
Include "conf/extra/httpd-ajp.conf"
</IfModule>
</IfModule>
Include "C:/xampp/apps/joomla/conf/httpd-prefix.conf"


Ja, diese Zeile hatte ich Anfangs nach der Anleitung im Forum (siehe oben) nach dieser abgeändert, d.h. gekürzt.
Aber vor dieser Änderung hat sich Apache auch schon nicht starten lassen. :?:

ManfrK
ManfrK
 
Posts: 6
Joined: 28. December 2014 19:56
Operating System: Windows 7 Pro

Re: Apache startet nach Installation von XAMPP nicht!

Postby Altrea » 30. December 2014 23:38

ManfrK wrote:Aber vor dieser Änderung hat sich Apache auch schon nicht starten lassen. :?:

Das mag ja sein, aber JETZT ist diese Zeile der Auslöser.
Also bitte wieder in den Urzustand zurücksetzen, erst danach können wir weitere Startprobleme analysieren.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nach Installation von XAMPP nicht!

Postby ManfrK » 01. January 2015 20:35

Hallo Altrea,

vielen herzlichen Dank für die schnelle Hilfe. Habe die original Zeile wieder hergestellt und jetzt startet Apache korrekt. Ich hatte allerdings die Ports auf 81, 443 umgestellt. Aber das
sollte ja auch o.k. sein.
Code: Select all
20:17:36  [main]    Initialisere Control Panel
20:17:36  [main]    Windows Version: Windows 7 Professional SP1 32-bit
20:17:36  [main]    XAMPP Version: 5.6.3
20:17:37  [main]    Control Panel Version: 3.2.1  [ Compiled: May 7th 2013 ]
20:17:37  [main]    Dein Benutzerprofil besitzt keine Administratorenrechte! Das reicht aus für die meisten
20:17:37  [main]    Anwendungsfunktionen, aber wann immer du etwas mit Windows-Diensten tun möchtest,
20:17:37  [main]    wird eine Sicherheitsabfrage erscheinen oder etwas wird garnicht erst funktionieren!
20:17:37  [main]    Also denke daran diese Anwendung mit Administratorrechten zu starten!
20:17:37  [main]    XAMPP Installationsverzeichnis: "c:\xampp\"
20:17:37  [main]    Voraussetzungen werden geprüft
20:17:37  [main]    Alle Voraussetzungen sind erfüllt
20:17:37  [main]    Initialisiere Module
20:17:37  [main]    Aktiviere Autostart für Modul "Apache"
20:17:37  [main]    Aktiviere Autostart für Modul "MySQL"
20:17:37  [main]    Starte Check-Timer
20:17:37  [main]    Control Panel bereit
20:17:37  [Apache]    Autostart aktiv: Starte...
20:17:37  [Apache]    Versuche Apache zu starten...
20:17:37  [mysql]    Autostart aktiv: Starte...
20:17:37  [mysql]    Versuche MySQL zu starten...
20:17:38  [Apache]    Statusänderung erkannt: gestartet
20:17:38  [mysql]    Statusänderung erkannt: gestartet

Leider hab ich jetzt ein anderes Problem: wenn ich jetzt im Browser die Seite "http://localhost" aufrufe, kommt die Meldung >"Diese Webseite ist nicht verfügbar."
D.h ich komme jetzt nicht mehr auf die Startseite von XAMPP.
Kannst Du/ihr mir da nochmal weiterhelfen? Liegt das evtl. doch an den geänderten Ports????

Viele Grüße und noch ein gesundes neues Jahr 2015

ManfrK
ManfrK
 
Posts: 6
Joined: 28. December 2014 19:56
Operating System: Windows 7 Pro

Re: Apache startet nach Installation von XAMPP nicht!

Postby ManfrK » 01. January 2015 20:49

Hallo,

hab jetzt selber eine Lösung gefunden, um auf die XAMPP-Seite zu kommen. Und zwar hab ich "http://localhost:81" eingegeben (wg. dem geänderten Port 80 auf 81....)
Jetzt komm ich da drauf, allerdings halt nur mit Zusatz ":81". Etwas ungewöhnlich, aber geht. Kanns da mit der Homepage-Anzeige über Joomla 2.5 evtl. Probleme geben?
Und ist es normal, daß auf der Willkommenseite von XAMPP beim deutschen Text die Umlaute nicht richtig angezeigt werden? Kann ich das irgendwo ändern?

Viele Grüße nochmal

ManfrK
ManfrK
 
Posts: 6
Joined: 28. December 2014 19:56
Operating System: Windows 7 Pro

Re: Apache startet nach Installation von XAMPP nicht!

Postby Altrea » 01. January 2015 21:23

ManfrK wrote:Und zwar hab ich "http://localhost:81" eingegeben (wg. dem geänderten Port 80 auf 81....)
Jetzt komm ich da drauf, allerdings halt nur mit Zusatz ":81". Etwas ungewöhnlich, aber geht.

Das ist der Preis wenn man von den Standardwerten abweicht. Da gibt es auch keine andere Lösung für, du musst zwingend den Port in der URL mitgeben.

ManfrK wrote:Kanns da mit der Homepage-Anzeige über Joomla 2.5 evtl. Probleme geben?

Es kann Probleme geben, wenn du Joomla nicht korrekt mitteilst, wie der HTTP Port lautet. Die meisten Content Management Systeme (CMS) verwenden einen URL builder um URLs selbst zu generieren. Kennt Joomla nicht den korrekten Port, kann es passieren dass diese URLs falsch generiert werden und damit Verlinkungen, CSS Dateien, JS Dateien, etc nicht korrekt funktionieren.
Wie man Joomla diesbezüglich korrekt konfiguriert fragst du aber besser in einem Joomla Support Forum.

ManfrK wrote:Und ist es normal, daß auf der Willkommenseite von XAMPP beim deutschen Text die Umlaute nicht richtig angezeigt werden? Kann ich das irgendwo ändern?

Jein, es ist ein Bug der mit neueren XAMPP Versionen behoben werden muss.
Lies dazu am besten mal folgenden Thread: viewtopic.php?f=4&t=69881
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests