Apache startet nicht!!!!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht!!!!

Postby FelixSoft2_NEW » 19. December 2014 13:33

Bei mir stimmt etwas nicht!
Wenn ich Apche starte kommt folgender Fehler text:
Code: Select all
13:32:38  [Apache]    Problem detected!
13:32:38  [Apache]    Port 80 in use by "Unable to open process" with PID 4!
13:32:38  [Apache]    Apache WILL NOT start without the configured ports free!
13:32:38  [Apache]    You need to uninstall/disable/reconfigure the blocking application
13:32:38  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
13:32:38  [Apache]    Problem detected!
13:32:38  [Apache]    Port 443 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 8952!
13:32:38  [Apache]    Apache WILL NOT start without the configured ports free!
13:32:38  [Apache]    You need to uninstall/disable/reconfigure the blocking application
13:32:38  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
13:32:38  [Apache]    Attempting to start Apache app...
13:32:39  [Apache]    Status change detected: running
13:32:39  [Apache]    Status change detected: stopped
13:32:39  [Apache]    Error: Apache shutdown unexpectedly.
13:32:39  [Apache]    This may be due to a blocked port, missing dependencies,
13:32:39  [Apache]    improper privileges, a crash, or a shutdown by another method.
13:32:39  [Apache]    Press the Logs button to view error logs and check
13:32:39  [Apache]    the Windows Event Viewer for more clues
13:32:39  [Apache]    If you need more help, copy and post this
13:32:39  [Apache]    entire log window on the forums

Wenn ich dass XAMPP Control Panel starte kommt nur dass hier:
Code: Select all
13:15:35  [main]    Initializing Control Panel
13:15:36  [main]    Windows Version: Windows 8  64-bit
13:15:36  [main]    XAMPP Version: 5.6.3
13:15:36  [main]    Control Panel Version: 3.2.1  [ Compiled: May 7th 2013 ]
13:15:36  [main]    You are not running with administrator rights! This will work for
13:15:36  [main]    most application stuff but whenever you do something with services
13:15:36  [main]    there will be a security dialogue or things will break! So think
13:15:36  [main]    about running this application with administrator rights!
13:15:36  [main]    XAMPP Installation Directory: "c:\server\"
13:15:36  [main]    Checking for prerequisites
13:15:36  [main]    All prerequisites found
13:15:36  [main]    Initializing Modules
13:15:36  [main]    Starting Check-Timer
13:15:36  [main]    Control Panel Ready


Zu Skype und port-blocking:
80: belegt von System
443: belegt von Skype

81: Frei
444: Frei

mit Port 81 und 444 kommt dieser Fehlertext:
Code: Select all
13:28:48  [Apache]    Attempting to start Apache app...
13:28:48  [Apache]    Status change detected: running
13:28:48  [Apache]    Status change detected: stopped
13:28:48  [Apache]    Error: Apache shutdown unexpectedly.
13:28:48  [Apache]    This may be due to a blocked port, missing dependencies,
13:28:48  [Apache]    improper privileges, a crash, or a shutdown by another method.
13:28:48  [Apache]    Press the Logs button to view error logs and check
13:28:48  [Apache]    the Windows Event Viewer for more clues
13:28:48  [Apache]    If you need more help, copy and post this
13:28:48  [Apache]    entire log window on the forums


BITTE HELFT MIR!!!!!!
FelixSoft2_NEW
 
Posts: 2
Joined: 19. December 2014 13:26
Operating System: Windows 8.1

Re: Apache startet nicht!!!!

Postby Altrea » 19. December 2014 13:58

Skype kannst du in den Einstellungen abgewöhnen Ports 80 und 443 zu verwenden.

Und zu den Ports 81 und 444, wo und wie hast du die eingestellt?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht!!!!

Postby FelixSoft2_NEW » 19. December 2014 14:10

Ich habe es geschafft und alle die immer noch nach einer lösung suchen hier ist eine lösung:

-Bearbeitet: Altrea deinen Post habe ich erst gesehen als dieser hier fertig war ;)

Lösung
1. Klicke im XAMPP Control Panel bei Apache auf Config und dann auf "Apache (httpd.conf)"
2. im Editor auf Bearbeiten -> Suchen und zum suchen den Text "Listen 80" eingeben
dann "Listen 80" mit "Listen 81" replacen.
3. im Editor auf Bearbeiten -> Suchen und zum suchen den Text "ServerName localhost:80"
eingeben dann "ServerName localhost:80" mit "ServerName localhost:81" replacen.
4. Datei Speichern und Editor Schließen.
5. Im XAMPP Control Panel auf Config mit dem Schraubenschlüssel anklicken und
"Service and Port Settings" anklicken.
6. In den "Service Settings" im Reiter Apache bei Main Port das 80 mit 81 replacen und Save
drücken.
7. Im "Configuration of Control Panel" Save anklicken.
8. Apache Starten und glücklich sein.
Wenn man Skype hat:
Gibt es eine sache die man leicht tun kann.
1. In Skype unter Aktionen Optionen (Ctrl + ,) anklicken.
2. Im Optionen Fenster von Skype auf den Reiter Erweitert klicken und darin den
Untergeordneten Reiter Verbindung anklicken
3. Im Untergeordneten Reiter Verbindung dann den Haken bei
"Ports 80 und 443 für zusätzliche eingehende Verbindungen verwenden" entfernen.
4. Speichern anklicken
Das mit Skype hatte bei mir nur so funktioniert.
FelixSoft2_NEW
 
Posts: 2
Joined: 19. December 2014 13:26
Operating System: Windows 8.1


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests