... bitte helfen!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

... bitte helfen!

Postby Miko » 28. November 2014 22:39

vor ein paar jahren habe ich xampp mit einem Win xp pc, nur zum ausprobieren, ohne probleme benutzen können.

nun ist es wichtig und nichts geht...:
ich
(als "nicht studierter" pc user mit nur "etwas" mehr als basiswissen - bin gamer, leider kein techniker)
möchte eine umfangreiche info-webseite mit blog und webshop erstellen und vorher auf meinem laptop alles ausführlich testen.

bitnami, mit xampp, worldpress und anderen "stacks" scheint mir da, weil "idiotensicher und besonders für anfänger geeignet", genau das richtige, zu sein.

kann mir bitte trotzdem jemand beim start helfen?

mein laptop läuft mit windows 8.1, die installierte xampp version ist: 5.6.3.

ich habe die ports in den apache konfigs mehrfach auch in hohe nummern gewechselt, mit und ohne firewall startet der server (auch ausgeführt als admin) nicht.
hier hänge ich und komme nicht weiter.

im log-fenster steht folgendes:

22:18:54 [main] Initialisere Control Panel
22:18:54 [main] Windows Version: Windows 8 64-bit
22:18:54 [main] XAMPP Version: 5.6.3
22:18:54 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
22:18:54 [main] Mit Administratorrechten gestartet - gut!
22:18:54 [main] XAMPP Installationsverzeichnis: "c:\program files (x86)\xampp\"
22:18:54 [main] ACHTUNG: Der XAMPP Installationspfad enthält Leerzeichen. Dies könnte die Funktionalität von Programmen/Scripten beeinflussen
22:18:54 [main] ACHTUNG: Der XAMPP Installationspfad enthält Sonderzeichen. Dies könnte die Funktionalität von Programmen/Scripten beeinflussen
22:18:54 [main] Voraussetzungen werden geprüft
22:18:54 [main] Alle Voraussetzungen sind erfüllt
22:18:54 [main] Initialisiere Module
22:18:54 [Apache] Initialisiere Modul...
22:18:54 [Apache] Prüfe ob Modul existiert...
22:18:54 [Apache] Prüfe benötigte Tools...
22:18:54 [Apache] Überprüfe Dienst (name="Apache2.4"): Dienst nicht installiert
22:18:54 [Apache] Dienst-Pfad: Dienst nicht installiert
22:18:54 [Apache] Überprüfe Standardports...
22:18:54 [mysql] Initialisiere Modul...
22:18:54 [mysql] Prüfe ob Modul existiert...
22:18:54 [mysql] Prüfe benötigte Tools...
22:18:54 [mysql] Überprüfe Dienst (name="mysql"): Dienst nicht installiert
22:18:54 [mysql] Dienst-Pfad: Dienst nicht installiert
22:18:54 [mysql] Überprüfe Standardports...
22:18:54 [filezilla] Initialisiere Modul...
22:18:54 [filezilla] Prüfe ob Modul existiert...
22:18:54 [filezilla] Prüfe benötigte Tools...
22:18:54 [filezilla] Überprüfe Dienst (name="FileZillaServer"): Dienst nicht installiert
22:18:54 [filezilla] Dienst-Pfad: Dienst nicht installiert
22:18:54 [filezilla] Überprüfe Standardports...
22:18:54 [mercury] Initialisiere Modul...
22:18:54 [mercury] Prüfe ob Modul existiert...
22:18:54 [mercury] Prüfe benötigte Tools...
22:18:54 [mercury] Überprüfe Standardports...
22:18:54 [Tomcat] Initialisiere Modul...
22:18:54 [Tomcat] Prüfe ob Modul existiert...
22:18:54 [Tomcat] Prüfe benötigte Tools...
22:18:54 [Tomcat] Überprüfe Dienst (name="Tomcat7"): Dienst nicht installiert
22:18:54 [Tomcat] Dienst-Pfad: Dienst nicht installiert
22:18:54 [Tomcat] Überprüfe Standardports...
22:18:54 [main] Starte Check-Timer
22:18:54 [main] Control Panel bereit
22:21:24 [Apache] Überprüfe Standardports...
22:21:24 [Apache] Versuche Apache zu starten...
22:21:24 [Apache] Führe aus: "c:\program files (x86)\xampp\apache\bin\httpd.exe"
22:21:24 [Apache] Rückgabecode: 0
22:21:24 [Apache] Statusänderung erkannt: gestartet
22:21:25 [Apache] Statusänderung erkannt: gestoppt
22:21:25 [Apache] Fehler: Apache wurde unerwartet beendet
22:21:25 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
22:21:25 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
22:21:25 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
22:21:25 [Apache] im Windows Event Viewer für weitere Hinweise
22:21:25 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
22:21:25 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.


es ist mir wirklich wichtig mit der neuen webseite, ich bitte um hilfe beim xampp und evtl. beim installieren eines cms, eines blogs und der shopsoftware...
evtl, kann ich, wenn die neue seite technisch funzt, einen kleinen geldbetrag als dankeschön "spenden".
Miko
 
Posts: 2
Joined: 28. November 2014 21:50
Location: Steeg / Tirol
Operating System: Windows8.1

Re: ... bitte helfen!

Postby Altrea » 28. November 2014 22:55

Hallo Miko,

Miko wrote:ich habe die ports in den apache konfigs mehrfach auch in hohe nummern gewechselt

mache dies bitte rückgängig, das ist nicht hilfreich, wenn man die Ursache nicht kennt.

Miko wrote:22:18:54 [main] XAMPP Installationsverzeichnis: "c:\program files (x86)\xampp\"
22:18:54 [main] ACHTUNG: Der XAMPP Installationspfad enthält Leerzeichen. Dies könnte die Funktionalität von Programmen/Scripten beeinflussen
22:18:54 [main] ACHTUNG: Der XAMPP Installationspfad enthält Sonderzeichen. Dies könnte die Funktionalität von Programmen/Scripten beeinflussen

Der Log zeigt dir doch schon eine Ursache auf. Du hast XAMPP in ein nicht empfohlenes Verzeichnis installiert.
Installiere XAMPP in das empfohlene Verzeichnis C:\xampp\

Ob es noch weitere Startverhindernde Ursachen gibt können wir erst dann klären.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: ... bitte helfen!

Postby Miko » 30. November 2014 14:11

danke für die hilfe!

habe alles deinstalliert und im standartverzeichnis neu istalliert.

14:07:02 [main] Initializing Control Panel
14:07:02 [main] Windows Version: Windows 8 64-bit
14:07:02 [main] XAMPP Version: 5.6.3
14:07:02 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
14:07:02 [main] Running with Administrator rights - good!
14:07:02 [main] XAMPP Installation Directory: "c:\xampp\"
14:07:02 [main] Checking for prerequisites
14:07:02 [main] All prerequisites found
14:07:02 [main] Initializing Modules
14:07:02 [Apache] Problem detected!
14:07:02 [Apache] Port 80 in use by "Unable to open process" with PID 4!
14:07:02 [Apache] Apache WILL NOT start without the configured ports free!
14:07:02 [Apache] You need to uninstall/disable/reconfigure the blocking application
14:07:02 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
14:07:02 [main] Starting Check-Timer
14:07:02 [main] Control Panel Ready
14:07:32 [Apache] Problem detected!
14:07:32 [Apache] Port 80 in use by "Unable to open process" with PID 4!
14:07:32 [Apache] Apache WILL NOT start without the configured ports free!
14:07:32 [Apache] You need to uninstall/disable/reconfigure the blocking application
14:07:32 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
14:07:32 [Apache] Attempting to start Apache app...
14:07:32 [Apache] Status change detected: running
14:07:33 [Apache] Status change detected: stopped
14:07:33 [Apache] Error: Apache shutdown unexpectedly.
14:07:33 [Apache] This may be due to a blocked port, missing dependencies,
14:07:33 [Apache] improper privileges, a crash, or a shutdown by another method.
14:07:33 [Apache] Press the Logs button to view error logs and check
14:07:33 [Apache] the Windows Event Viewer for more clues
14:07:33 [Apache] If you need more help, copy and post this
14:07:33 [Apache] entire log window on the forums
Miko
 
Posts: 2
Joined: 28. November 2014 21:50
Location: Steeg / Tirol
Operating System: Windows8.1

Re: ... bitte helfen!

Postby Altrea » 30. November 2014 15:04

Wenn du des englischen mächtig bist, schau dir diesen Beitrag von mir mal an: [FGA] solving Port 80 in use by PID 4 (HTTP.sys) issue
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: ... bitte helfen!

Postby Lwngwen » 03. December 2014 16:42

Windows in in der Version 8 noch eigensinniger geworden.
Ob es bei deinem Problem hilft, kann ich jetzt nicht sagen.
Aber gewöhnt euch an, Installationen IMMER mit der rechten Maustaste anzuklicken und AUSFÜHREN ALS ADMINISTRATOR zu wählen.
Die meisten Probleme werden damit beseitigt....
Lwngwen
 
Posts: 3
Joined: 03. December 2014 15:50
Operating System: Windows Linux


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests