Umlaute werden falsch dargestellt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Re: Umlaute werden falsch dargestellt

Postby Schwarzmond » 08. December 2014 06:31

Manfred62 wrote:
Was muss ich denn jetzt wo ändern, dass zum einen die localhost-Seite korrekt dargestellt wird - und was, damit meine Websiten wieder korrekt dargestellt werden?

Für die localhost-Seite --> die de.php in utf-8 speichern (wie schon beschrieben).
Unter Sublime Text:
"File - Save with Encoding - UTF-8"
Unter PSPad:
"Format - UTF-8"


Das klappt gar nicht.
Wenn ich die "de.php" mit dem Texteditor mit UTF-8 Kodierung speicher, ist die localhost-Seite weiß, dann wird die gar nicht mehr erkannt. Wenn ich wieder unter ANSI speicher, geht es (bis auf die Sonderzeichen)...
Schwarzmond
 
Posts: 17
Joined: 21. April 2013 11:16
Operating System: Windows7

Re: Umlaute werden falsch dargestellt

Postby Altrea » 08. December 2014 07:14

Schwarzmond wrote:Das klappt gar nicht.Wenn ich die "de.php" mit dem Texteditor mit UTF-8 Kodierung speicher, ist die localhost-Seite weiß, dann wird die gar nicht mehr erkannt. Wenn ich wieder unter ANSI speicher, geht es (bis auf die Sonderzeichen)...

Welchen Editor verwendest du?
Achte darauf, dass UTF-8 OHNE ByteOrderMark (BOM) gespeichert wird.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Umlaute werden falsch dargestellt

Postby Manfred62 » 08. December 2014 17:06

Schwarzmond wrote:...
Wenn ich die "de.php" mit dem Texteditor mit UTF-8 Kodierung speicher, ist die localhost-Seite weiß, dann wird die gar nicht mehr erkannt. Wenn ich wieder unter ANSI speicher, geht es (bis auf die Sonderzeichen)...

lade dir mal die Datei runter und leg die ins Verzeichnis.
Link: https://app.box.com/s/iku9wowqbk2p8t6t9y0i
Das ist meine in utf-8 gespeicherte de.php. Geht es dann (die localhost Seite)?
Wenn ja, dann ist dein Editor das Problem --> FAQ lesen (Konfiguration usw.).
Manfred62
 
Posts: 6
Joined: 05. December 2014 19:21
Operating System: Windows 7

Re: Umlaute werden falsch dargestellt

Postby Schwarzmond » 08. December 2014 17:29

Hi alle,

so, nachdem ich mir deine Datei, @Manfred62, runtergeladen habe (kurz dachte ich... hm... wie war das mit Anhängen in eMails bzw. Dateien aus dem Internet... :D ) und es damit funktioniert... habe ich mich nach einem neuen Texteditor umgesehen. Und bin dabei über SRCIPTLY gestolpert... der ist speziell für Webistenprogrammierung (während WinEDT vor allem für LaTeX perfekt ist) ist... und der kann per Menüpunkt als UTF-8 ohne BOM abspeichern...
... und damit sehen jetzt auch meine Seiten so aus, wie sie sollen.

Danke an alle!
:)
Schwarzmond
 
Posts: 17
Joined: 21. April 2013 11:16
Operating System: Windows7

Re: Umlaute werden falsch dargestellt

Postby Manfred62 » 08. December 2014 17:51

Schwarzmond wrote:...Und bin dabei über SRCIPTLY gestolpert...

Besser nicht! Scriptly kann utf-8 nicht richtig und wird schon lange nicht mehr weiterentwickelt! Habe ihn selber benutzt.
Es gibt viele Editoren. Ich bin nach PSPad nun bei Sublime hängengeblieben.
Manfred62
 
Posts: 6
Joined: 05. December 2014 19:21
Operating System: Windows 7

Re: Umlaute werden falsch dargestellt

Postby Altrea » 08. December 2014 18:06

Ich kann als reinen Klartext-Editor auch Sublime Text oder Notepad++ empfehlen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Umlaute werden falsch dargestellt

Postby Schwarzmond » 08. December 2014 18:46

Hm... also Scriplty sieht gut aus und läßt sich gut bedienen. Und das mit den Umlauten klappt ja auch.

Hab jetzt a ber auch mal Sublime Text 2 installiert.
Wo stellt man dort denn UTF-8 ein?
Beim Scriptly hab ichs gleich gefunden...
:)
Schwarzmond
 
Posts: 17
Joined: 21. April 2013 11:16
Operating System: Windows7

Re: Umlaute werden falsch dargestellt

Postby Nobbie » 08. December 2014 19:24

Schwarzmond wrote:Hab jetzt a ber auch mal Sublime Text 2 installiert.
Wo stellt man dort denn UTF-8 ein?


Das würde ich im Falle des Falles ja hier fragen: http://www.sublimetext.com/support

Oder nicht?
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Umlaute werden falsch dargestellt

Postby Manfred62 » 08. December 2014 20:07

Schwarzmond wrote:...
Hab jetzt aber auch mal Sublime Text 2 installiert.
Wo stellt man dort denn UTF-8 ein?
...

Gar nicht. Das ist Standard :mrgreen: Schau nach unter "Preferences / Settings-Default".
Sublime kann nahezu unendlich konfiguriert werden. Muss man sich aber erst einarbeiten.
Aber dann möchte man ihn nicht mehr missen. Für mich persönlich der beste Editor.

Es gibt enorm viele Infos im Web:
http://www.der-zyklop.de/blog/workflow-sublime-text-2
http://www.hongkiat.com/blog/sublime-text-tips/
http://wesbos.com/category/sublime-text/
Manfred62
 
Posts: 6
Joined: 05. December 2014 19:21
Operating System: Windows 7

Re: Umlaute werden falsch dargestellt

Postby Nobbie » 08. December 2014 21:36

Manfred62 wrote:Aber dann möchte man ihn nicht mehr missen. Für mich persönlich der beste Editor.


Ach so, jetzt sehe ich das erst, das ist nur ein Editor - ich dachte das wäre irgendeine PHP basierte Software oder so.

Editoren sind natürlich im allerhöchsten Maße Geschmackssache, für mich ist seit eh und je "vi" der beste Editor von allen. Aber auch gewöhnungsbedürftig. Unter Windows habe ich aber auch gute Erfahrungen mit "TextPad" gemacht und auch "UltraEdit" ist ein sehr guter Editor. Ich habe keine Ahnung, wie die heute unterstützt werden, unter Linux benutze ich natürlich "vi".

Das muss jeder für sich selbst herausbekommen, womit er am besten zurechtkommt. Wobei genau das eben wichtig ist: WENN man sich schon mal entscheidet, dann muss man auch blind damit umgehen können. Sonst ist ein Editor eher hinderlich statt hilfreich.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Umlaute werden falsch dargestellt

Postby carlo13 » 15. December 2014 16:24

Super, nach Korrektur von langsettings.php werden die Umlaute korrekt dargestellt. :lol:
Danke, Gruss carlo13
carlo13
 
Posts: 1
Joined: 15. December 2014 15:49
Operating System: Windows 8.1

Re: Umlaute werden falsch dargestellt

Postby andre lieske » 20. January 2015 06:45

Hallo Manfred62,
Manfred62 wrote:unter "\xampp\htdocs\xampp\lang\" die Datei de.php mit Editor öffnen und in utf-8 speichern. xampp neu starten. Fertig.

So einfach ist das nicht.
Stelle ich die Datei auf UTF-8 um, werden keine Sonderzeichen ausgegeben,
die Datei muss erst komplett bearbeitet werden.
Beispiel nach Umstellung auf UTF-8
$TEXT['navi-xampp'] = "XAMPP";
$TEXT['navi-welcome'] = "Willkommen";
$TEXT['navi-status'] = "Status";
$TEXT['navi-security'] = "Sicherheitscheck";
$TEXT['navi-doc'] = "Dokumentation";
$TEXT['navi-components'] = "Komponenten";
$TEXT['navi-about'] = "xDCber XAMPP";


Die Zeichen müssen in der ganzen Datei ersetzt werden.
Benutze Notepad++ neuste Version
Gruss André
andre lieske
 
Posts: 9
Joined: 15. November 2011 07:03
Location: Berlin
XAMPP version: xampp-win32-5.6.24-1
Operating System: Windows 10 Prof.

Re: Umlaute werden falsch dargestellt

Postby Altrea » 20. January 2015 16:35

andre lieske wrote:So einfach ist das nicht.

Sogar noch einfacher, ein Neustart von XAMPP ist nämlich nichtmal von Nöten.

getestet mit der aktuellsten stable Version von Notepad++ (v6.7.4 je suis Charlie edition) und XAMPP 5.6.3 (Installer version)

Dateien "\xampp\htdocs\xampp\lang\de.php" und "\xampp\security\htdocs\lang\de.php" einfach in Notepad++ öffnen, über "Kodierung" -> "Konvertiere zu UTF-8 ohne BOM" die Datei umkonvertieren und speichern.
Anschließend u.U. den Browserverlauf löschen (bei mir reicht ein Shift+F5 zum neuanfordern).
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

In XAMPP ab 5.6 ist beim Charset der Wurm drin

Postby BobSponge » 09. June 2015 16:01

Ich muss das Thema noch mal aufnehmen. Die Diskussion pro und contra UTF-8 ist hier völlig sinnlos weil nicht zielführend. Ein Mangel muss behoben und darf nicht umgangen werden. XAMPP muss jeden Zeichensatz immer korrekt handhaben. Zudem lässt es sich nicht immer vermeiden, Daten auch mit verschiedenen Zeichensätzen auf einer Domain zu haben.

Nach parallelem Einsatz von 5,6.3, 5.6.8 und 5.5.24 in verschiedenen Partitionen arbeite ich jetzt wieder allein mit 5.5.24!

Ein großer Teil meiner Daten wird durch eine Software erzeugt, die Dateien mit UTF-8 ausgibt, weshalb ich mich (und nur deshalb und nicht aus Überzeugung) grundsätzlich (im juristischen Sinn - also mit Ausnahmen) für UTF-8 entschieden habe. Eine meiner Anwendungen "flashmp3player" greift auf Tags in mp3-Dateien zu, die zuvor von "Mp3tag" erzeugt wurden. Beide arbeiten mit ANSI und daran kann ich nichts ändern. Bis XAMPP 5.5 lief alles bestens.

HTML-Dateien mit <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/> am Anfang, sowie mit NotePad++ als ANSI gespeichert, werden vom Localhost trotzdem als angebliches UTF-8 an den Browser geschickt.

Zu den verschiedenen genannten Empfehlungen:

Änderungen an der "\xampp\htdocs\xampp\lang\de.php" sind sinnlos, weil sie nichts mit den eigentlichen Daten zu tun haben, sondern XAMPP-Meldungen betreffen.

Änderung in der "\xampp\php\php.ini" halfen nur bei den einfachen HTML-Dateien!
default_charset=""
default_charset="iso-8849-1"
default_charset="iso-8849-15"
Die einfachen HTML-Dateien werden danach in den drei Fällen korrekt angezeigt.
Die Anwendung mit den mp3-Tags bleibt auch in diesen Fällen falsch angezeigt.
Ohnehin steht das Verhalten im Widerspruch zur Aussage: "; PHP's default character set is set to empty."

Einfügen von
<?php
header('Content-Type: text/html; charset=iso-8859-1');
?>
Die einfachen HTML-Dateien werden danach korrekt angezeigt.
Die Anwendung mit den mp3-Tags bleibt auch in diesem Fall falsch angezeigt.
BobSponge
 
Posts: 1
Joined: 09. June 2015 15:30
Operating System: Windows 7

Re: In XAMPP ab 5.6 ist beim Charset der Wurm drin

Postby Nobbie » 09. June 2015 17:38

BobSponge wrote:Ein Mangel muss behoben und darf nicht umgangen werden. XAMPP muss jeden Zeichensatz immer korrekt handhaben.


Der Mangel sitzt im Zweifel vor dem Monitor. Xampp ist keine Software und kein Produkt, sondern eine Distribution. Und diese Distribution besteht aus verschiedenen Softwareprodukten und jedes dieser Produkte tut das, wie es der Anwender konfiguriert und/oder programmiert hat. Erst wenn eines der Produkte sich nicht an die Konfiguration oder Programmierung hält, ist von einem Mangel auszugehen. In allen mir bekannten Fällen ist das jedoch nicht der Fall, es ist jederzeit ein fehlendes Verständnis und entsprechend fehlerhafte Konfiguration resp. Programmierung Schuld.

Ohne Ausnahme. Der Umgang mit Zeichensätzen und das Verständnis dafür ist eben leider schwierig, es ist aber nicht zielführend, die Schuld für Fehler an der falschen Stelle zu suchen.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

PreviousNext

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests