Apache startet nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht

Postby gualen » 10. November 2014 17:45

Sorry, jetzt komme ich auch noch mit dem gleichen Problem.

Ich habe XAMPP installiert. Hatte anschließend das Problem mit dem geblockten Port 80. Habe dann das Port auf 81 geändert und konnte Apache starten.
Nach dem Start erhielt ich weitere Hinweise; u.a. für die Securtity. Daraufhin habe ich versucht ein Passwort für phpadmin zu vergeben und dabei das SQL-Passwort verändert.
Anschließend habe ich nach dem Blockierer von Port=80 gesucht und festgestellt, dass dieses durch die Skype-App blockiert war OBWOHL SKYPE NICHT AKTIV WAR. Unter Windows7 (Desktop) habe ich das Skype-Port geändert und die Skype-App beendet.
Weil ich ein ordentliches Appache haben wollte habe ich dann Appache beendet und wieder das Port=80 konfiguriert.
Seither kann ich Appache nicht mehr starten.
Ich habe XAMPP bereits einmal deinstalliert, alle Daten (aber nicht die Registry) gelöscht und dann XAMPP wieder neu installiert.
Trotzdem kann ich Apache (auch mit einem geänderten Port) nicht mehr starten.
Laut Anzeige des Windows-Task-Managers war zum Schluss keines der (mir bekannten) von Appache genutzten Ports mehr blockiert.

Die Anzeige im XAMPP Control Panel v3.2.1 lautet:
17:05:40 [main] Initialisere Control Panel
17:05:40 [main] Windows Version: Windows 8 Pro 64-bit
17:05:40 [main] XAMPP Version: 1.8.3
17:05:40 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
17:05:40 [main] Mit Administratorrechten gestartet - gut!
17:05:40 [main] XAMPP Installationsverzeichnis: "c:\xampp\"
17:05:40 [main] Voraussetzungen werden geprüft
17:05:40 [main] Alle Voraussetzungen sind erfüllt
17:05:40 [main] Initialisiere Module
17:05:40 [main] Aktiviere Autostart für Modul "Apache"
17:05:40 [main] Starte Check-Timer
17:05:40 [main] Control Panel bereit
17:05:41 [Apache] Autostart aktiv: Starte...
17:05:41 [Apache] Versuche Apache zu starten...
17:05:41 [Apache] Statusänderung erkannt: gestartet
17:05:42 [Apache] Statusänderung erkannt: gestoppt
17:05:42 [Apache] Fehler: Apache wurde unerwartet beendet
17:05:42 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
17:05:42 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
17:05:42 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
17:05:42 [Apache] im Windows Event Viewer für weitere Hinweise
17:05:42 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
17:05:42 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.
17:08:08 [main] Führe aus: "c:\xampp\apache\logs"
17:09:58 [Apache] Versuche Apache zu starten...
17:09:59 [Apache] Statusänderung erkannt: gestartet
17:10:00 [Apache] Statusänderung erkannt: gestoppt
17:10:00 [Apache] Fehler: Apache wurde unerwartet beendet
17:10:00 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
17:10:00 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
17:10:00 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
17:10:00 [Apache] im Windows Event Viewer für weitere Hinweise
17:10:00 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
17:10:00 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.
17:10:18 [main] Führe aus: "services.msc"
17:11:19 [main] Führe aus: "c:\xampp\"
17:14:45 [Apache] Versuche Apache zu starten...
17:14:45 [Apache] Statusänderung erkannt: gestartet
17:14:46 [Apache] Statusänderung erkannt: gestoppt
17:14:46 [Apache] Fehler: Apache wurde unerwartet beendet
17:14:46 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
17:14:46 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
17:14:46 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
17:14:46 [Apache] im Windows Event Viewer für weitere Hinweise
17:14:46 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
17:14:46 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.
17:15:11 [main] Führe aus: "c:\xampp\apache\logs"
17:25:33 [main] Führe aus: "c:\xampp\"
17:44:20 [Apache] Problem festgestellt!
17:44:20 [Apache] Port 80 in Benutzung von "Unable to open process" (PID 4)!
17:44:20 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
17:44:20 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
17:44:20 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
17:44:20 [Apache] Versuche Apache zu starten...
17:44:21 [Apache] Statusänderung erkannt: gestartet
17:44:22 [Apache] Statusänderung erkannt: gestoppt
17:44:22 [Apache] Fehler: Apache wurde unerwartet beendet
17:44:22 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
17:44:22 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
17:44:22 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
17:44:22 [Apache] im Windows Event Viewer für weitere Hinweise
17:44:22 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
17:44:22 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.

Alle Apache logs sind leer Obwohl ich vor der Neuinstallation auch Nachrichten in den Apache logs lesen konnte.

Wo habe ich was falslch gemacht ?
gualen
 
Posts: 2
Joined: 10. November 2014 17:26
Operating System: Win 8.1

Re: Apache startet nicht

Postby Altrea » 10. November 2014 18:12

Wenn du des englischen ein wenig mächtig bist, kannst du dir folgenden Thread durchlesen => [FGA] Apache won't start (eine deutsche Übersetzung steht leider noch aus). Da habe ich mal versucht das Problem umfassend aufzuarbeiten und verschiedene Lösungsansätze skizziert.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht

Postby gualen » 10. November 2014 22:23

Danke für die schnelle Antwort.
Bis zum Aufruf des IIS-Tools konnte ich die Aktionen des Threads durchführen. Und dann kam ein großes Fragezeichen.
1. Ich verwende PRIVAT ein Windows-8.1 System in deutscher Sprache.
2. Die englischen Bezeichnungen für Menue- und Funktionsaufrufe sind in Deutsch kaum zu finden.
3. Habe ich verstanden, dass ich die IIS-Tools erst installieren (kaufen) muss.
4. Ich habe verstanden, dass XAMPP auch auf dem Windows-8.1 System verwendet werden kann und kein Windows-Server System notwendig ist.

Ich habe die Ports für Apache auf 8080 und 8443 geändert. Damit läßt sich Apache jetzt starten und ich denke, dass ich damit zurecht komme.

Vielen Dank für die Hilfe
Günter
gualen
 
Posts: 2
Joined: 10. November 2014 17:26
Operating System: Win 8.1


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 24 guests