openssl sucht nach "opensll.cnf" nicht nach "openssl.cnf"

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

openssl sucht nach "opensll.cnf" nicht nach "openssl.cnf"

Postby DerEinzigeKlaus » 06. November 2014 11:40

Hi!

Hatte bei der Installtion von Typo3 6.2.6 auf XAMPP 1.8.3 unter Windows 7 x64 das Problem, daß die openssl Schiene nicht angesprochen werden konnte. Typo3 konnte das Programm nicht starten.
Habe dann bemerkt, daß wenn ich c:\xampp\apache\bin\openssl.exe im CMD-Fenster starte die Fehlermeldung kommt: Kann c:\xampp\apache\conf\opensll.cnf nicht finden. Man beachte SLL anstelle von SSL !!! In dem dir steht aber nur eine "openssl.cnf"!
Nach umbenennen in "opensll.cnf" lief die Sache fehlerfrei durch.

Was macht Ihr jetzt mit diesem Fehler?

Grüß Euch 8)
DerEinzigeKlaus
 
Posts: 1
Joined: 06. November 2014 11:28
Operating System: Windows 7

Re: openssl sucht nach "opensll.cnf" nicht nach "openssl.cnf

Postby Nobbie » 06. November 2014 12:21

DerEinzigeKlaus wrote:Was macht Ihr jetzt mit diesem Fehler?


Wer ist "Ihr"?
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: openssl sucht nach "opensll.cnf" nicht nach "openssl.cnf

Postby Altrea » 06. November 2014 12:26

Wenn openssl.exe schon den falschen Pfad meldet, dann steckt der Fehler entweder in der Kompilation von OpenSSL (unwahrscheinlich) oder DU hast eine Umgebungsvariable mit dem falschen Pfad gesetzt, (was ich für sehr wahrscheinlich halte, da es Anleitungen im Internet gibt, die genau diesen Fehler enthalten, bsp hier: http://alkunmedia.com/blog/installation-von-typo3-cms/)

Was machst DU jetzt mit diesem Fehler?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: openssl sucht nach "opensll.cnf" nicht nach "openssl.cnf

Postby Nobbie » 06. November 2014 15:03

Altrea wrote:da es Anleitungen im Internet gibt, die genau diesen Fehler enthalten, bsp hier: http://alkunmedia.com/blog/installation-von-typo3-cms/)


Oh je, das ist aber auch wirklich bescheuert, da hat jemand ganze Arbeit geleistet und konsequent die ganze Zeit den falschen Namen benutzt. Interessant: wenn man es WIRKLICH so macht, wie dort beschrieben, wird noch ein ganz anderer Fehler auftreten, denn die Variable "OPENSLL_CONF" wird mit einiger Sicherheit gar nicht abgefragt (weil es OPENSSL_CONF heißen muss) und dann ist es auch egal, was da drin steht....

Also man muss schon gewieft sein und nur den halben Fehler übernehmen.

Was sagt denn der EinzigeKlaus dazu?
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 19 guests