Apache startet nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht

Postby vityok » 28. October 2014 15:57

Hallo, ich habe ein Problem, der Apache-Server bei xampp startet nicht. Dabei sind folgende Fehler bei den Logs angegeben:

[Tue Oct 28 13:52:11.868691 2014] [ssl:warn] [pid 2128:tid 332] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Oct 28 13:52:12.238678 2014] [ssl:warn] [pid 2128:tid 332] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Oct 28 13:52:12.412214 2014] [mpm_winnt:notice] [pid 2128:tid 332] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.5.15 configured -- resuming normal operations
[Tue Oct 28 13:52:12.412214 2014] [mpm_winnt:notice] [pid 2128:tid 332] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Tue Oct 28 13:52:12.412214 2014] [core:notice] [pid 2128:tid 332] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Oct 28 13:52:12.427847 2014] [mpm_winnt:notice] [pid 2128:tid 332] AH00418: Parent: Created child process 9028
[Tue Oct 28 13:52:14.049417 2014] [ssl:warn] [pid 9028:tid 408] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Oct 28 13:52:14.377539 2014] [ssl:warn] [pid 9028:tid 408] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Oct 28 13:52:14.479072 2014] [mpm_winnt:notice] [pid 9028:tid 408] AH00354: Child: Starting 150 worker threads.
Adding password for user root
[Tue Oct 28 14:05:41.359922 2014] [ssl:warn] [pid 8012:tid 400] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Oct 28 14:05:41.469398 2014] [core:warn] [pid 8012:tid 400] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Oct 28 14:05:41.764400 2014] [ssl:warn] [pid 8012:tid 400] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Oct 28 14:05:41.850701 2014] [mpm_winnt:notice] [pid 8012:tid 400] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.5.15 configured -- resuming normal operations
[Tue Oct 28 14:05:41.850701 2014] [mpm_winnt:notice] [pid 8012:tid 400] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Tue Oct 28 14:05:41.850701 2014] [core:notice] [pid 8012:tid 400] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Oct 28 14:05:41.859703 2014] [mpm_winnt:notice] [pid 8012:tid 400] AH00418: Parent: Created child process 884
[Tue Oct 28 14:05:43.637908 2014] [ssl:warn] [pid 884:tid 420] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Oct 28 14:05:43.967124 2014] [ssl:warn] [pid 884:tid 420] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Oct 28 14:05:44.065020 2014] [mpm_winnt:notice] [pid 884:tid 420] AH00354: Child: Starting 150 worker threads.


Was kann man da machen? Bin sehr dankbar, wenn mir jemand hilft.
vityok
 
Posts: 9
Joined: 28. October 2014 15:53
Operating System: Windows 8

Re: Apache startet nicht

Postby Altrea » 28. October 2014 17:04

Hallo,

führe erstmal apache_start.bat aus um eine Aussagekräftige Fehlermeldung zu bekommen.
Häufigste Ursache sind blockierte Ports durch IIS oder Skype.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht

Postby vityok » 28. October 2014 17:30

Wenn ich versuche, Apache zu starten, zeigt er mir folgende Fehlermeldung an:

Fehler: Apache wurde unerwartet beendet
17:34:09 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
17:34:09 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
17:34:09 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
17:34:09 [Apache] im Windows Event Viewer für weitere Hinweise
17:34:09 [Apache] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters
17:34:09 [Apache] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.

Ist das mit apache_start.bat gemeint?

An Skype liegt es nicht, es ist ausgeschaltet.
vityok
 
Posts: 9
Joined: 28. October 2014 15:53
Operating System: Windows 8

Re: Apache startet nicht

Postby Altrea » 28. October 2014 17:48

Nein, apache_start.bat ist eine Datei in deinem XAMPP Ordner.
Diese Datei ausführen und die Rückmeldung davon hier posten
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht

Postby vityok » 28. October 2014 18:24

Apache 2 is starting ...
httpd.exe: Syntax error on line 560 of C:/xampp/apache/conf/httpd.conf: [IfModule takes one argument, Container for directives based on existence of specified modules

Apache konnte nicht gestartet werden
vityok
 
Posts: 9
Joined: 28. October 2014 15:53
Operating System: Windows 8

Re: Apache startet nicht

Postby Altrea » 28. October 2014 18:28

Dann poste mal Zeile 555 und folgende deiner httpd.conf
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht

Postby vityok » 28. October 2014 18:37

# XAMPP: We disable operating system specific optimizations for a listening
# socket by the http protocol here. IE 64 bit make problems without this.

AcceptFilter http none

# AJP13 Proxy
<IfModule mod_proxy.c>
<IfModule mod_proxy_ajp.c>
Include "conf/extra/httpd-ajp.conf"
</IfModule>
</IfModule>
<IfModule mpm_winnt_module> ThreadStackSize 8388608 </IfModule>
vityok
 
Posts: 9
Joined: 28. October 2014 15:53
Operating System: Windows 8

Re: Apache startet nicht

Postby Nobbie » 28. October 2014 18:46

Du hast irgendwo einen Fehler in die httpd.conf eingebaut, denn die normale (ausgelieferte) httpd.conf hat gar nicht so viele Zeilen. Wahrscheinlich fehlt irgendwo eine abschließende Klammer (oder Kleinerzeichen) oder so.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Apache startet nicht

Postby Altrea » 28. October 2014 18:53

Entferne mal die letzte Zeile aus deiner httpd.conf
Hintergrund ist folgender: Apache Konfigurationsdateien unterstützen genau EINE Direktive pro Zeile.
Deine Zeile enthält gleich drei.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht

Postby vityok » 28. October 2014 18:58

Ich habe die letzte Zeile gelöscht, die ich zuvor hinzugefügt habe, weil ich versucht habe, einen Fehler bei typo3 zu beheben.

Jetzt funktioniert's wieder! Vielen Dank! Auch an Alterna!
vityok
 
Posts: 9
Joined: 28. October 2014 15:53
Operating System: Windows 8

Re: Apache startet nicht

Postby vityok » 28. October 2014 18:59

Habe bereits entfernt, danke
vityok
 
Posts: 9
Joined: 28. October 2014 15:53
Operating System: Windows 8

Re: Apache startet nicht

Postby vityok » 28. October 2014 19:01

Top Moderator übrigens!
vityok
 
Posts: 9
Joined: 28. October 2014 15:53
Operating System: Windows 8

Re: Apache startet nicht

Postby Altrea » 28. October 2014 19:06

Nichts zu danken.
Wie gesagt, falls du die Einstellung aus der letzten Zeile setzen möchtest, schreibe sie korrekt, also eine Direktive pro Zeile
Code: Select all
<IfModule mpm_winnt_module>
   ThreadStackSize 8388608
</IfModule>
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht

Postby vityok » 28. October 2014 19:18

Danke, kannst du mir vielleicht noch sagen, wie ich in den Admin-Bereich bei Typo3 gelange?
vityok
 
Posts: 9
Joined: 28. October 2014 15:53
Operating System: Windows 8

Re: Apache startet nicht

Postby vityok » 28. October 2014 19:25

hab schon gefunden
vityok
 
Posts: 9
Joined: 28. October 2014 15:53
Operating System: Windows 8

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests