Apache Server 2.0.49 - Kann keine Dateien herrunterladen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache Server 2.0.49 - Kann keine Dateien herrunterladen

Postby lexaiden » 14. August 2004 23:04

Hi,

leider hab ich über die Boardsuche nichts gefunden das mir geholfen hat, also wenn das Thema schon behandelt wurde, dann gebt mir doch bitte den Link dahin. Danke.

Das Problem:
Große Bilder, Archive, Audiodateien etc. werden einfach nicht übermittelt. Egal ob interen, also LAN oder aber von außen also WAN. Es werden ein paar Kilobyte übertragen und dann kommt die Fehlermeldung "Serververbidnung wurde zurückgesetzt". Ich glaub zumindestens das sie so hieß, denn ich bekomme sie irgendwie nicht mehr. Warum auch immer... die Dateien werden auf alle Fälle nicht übermittelt und ich weiss nicht wieso! *grummel*

Das ganze geht weder über HTTP noch über HTTPS.

Hat da wer eine Idee? Oder aber einen Link, denn ich finde nichts im Netz, wahrscheinlich ist es so banal das es schon wieder zu schwer für mich ist..

Hatte vorher schon einen selbst zusammengeschusterten Apache von www.apache.org , das selbe Problem. Internetseite können Problemlos aufgerufen werden, auch größere.

Beispiel:
- Die Datei wgp.htm (631Kb) kann angezeigt werden
- Die Datei wgp.rar (173Kb) kann nicht herruntergeladen werden. Nach 64Kb bricht der Download - nun ohne Fehlermeldung - ab.

Das System:
WinXP Pro SP1
PIII-S 1133Mhz 512Kb
Asus CUSL2
512MB SD RAM PC 133

Gestartete Dienste:
Serv-U (FTP Server)
Apache (HTTP/ HTTPS Server)
VNC (Remote Software)
eMule (P2P Client)
NOD32 (Virenscanner)
Sygate Personal Firewall Pro
Imond (Remote Client für den FLI4L Router)
MBM (MotherBoardMonitor zur überwachung der Systemdaten)

und ein paar Windows interne XP Dienste.
lexaiden
 
Posts: 3
Joined: 14. August 2004 22:58

Postby Kristian Marcroft » 14. August 2004 23:43

Hi,

versuch mal bitte folgendes in deine httpd.conf einzutragen...
und zwar vor die LoadModules:

Code: Select all
EnableMMAP off
EnableSendfile off


anschliessend Apache neustarten..
So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby lexaiden » 15. August 2004 00:06

Ja wie geil ist das denn *g*
Es funktioniert, besten Dank!

Nur um meine Neugier zu befriedigen, woran lag es denn nun? Was habe ich mit dem Zweizeiler verändert?
lexaiden
 
Posts: 3
Joined: 14. August 2004 22:58

Postby Kristian Marcroft » 15. August 2004 00:49

Hi,

# EnableMMAP: Control whether memory-mapping is used to deliver
# files (assuming that the underlying OS supports it).
# The default is on; turn this off if you serve from NFS-mounted
# filesystems. On some systems, turning it off (regardless of
# filesystem) can improve performance; for details, please see
# http://httpd.apache.org/docs-2.0/mod/co ... enablemmap
#
#EnableMMAP off

#
# EnableSendfile: Control whether the sendfile kernel support is
# used to deliver files (assuming that the OS supports it).
# The default is on; turn this off if you serve from NFS-mounted
# filesystems. Please see
# http://httpd.apache.org/docs-2.0/mod/co ... lesendfile
#
#EnableSendfile off


evtl. ist "EnableSendfile" sogar überflüssig. Kannst ja mal testen und hier berichten... ;)

So long
KriS

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby lexaiden » 15. August 2004 10:29

Hi,
EnableMMAP off scheint überflüssig zu sein, denn ohne geht es immernoch, zumindestens im LAN.
Wenn ich EnableSendfile off wegnehme hab ich wieder den Fehler das Dateien nicht bis zum Ende übertragen werden...

Danke nochmal :-)
lexaiden
 
Posts: 3
Joined: 14. August 2004 22:58


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests