Autostart Windows Server 2008 R2

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Autostart Windows Server 2008 R2

Postby TeamBob » 24. September 2014 07:40

Hallo

Ich bin gerade dabei eine CMS in unser Firmennetzwerk aufzusetzen und habe dazu Xampp
auf den Server auf Laufwerk D: installiert. Es ist auch ohne weiteres möglich Xampp/Apache und MySQL zu starten
und man kann auch von jeden Rechner per localhost... drauf zugreifen.
Ich habe mich als Admin per Remotdesktopcontrol auf den Server angemeldet und dabei alles aufgesetzt.
Das Problem ist jetzt, dann wenn ich mich wieder abmelde vom Server, auch Xampp mit geschlossen wird
und die Webseite nicht mehr erreichbar ist. Ich muss mich dazu erst wieder einloggen und dann wieder Xampp
starten.
Wie bekomm ich es hin, dass es auf den Server im Hintergrund läuft?

Vielen Dank
TeamBob
 
Posts: 8
Joined: 08. September 2014 10:33
Operating System: Windows Server 2008 R2

Re: Autostart Windows Server 2008 R2

Postby Nobbie » 24. September 2014 08:53

Als Dienst starten.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: Autostart Windows Server 2008 R2

Postby TeamBob » 24. September 2014 09:04

und wie genau muss ich das einstellen?
TeamBob
 
Posts: 8
Joined: 08. September 2014 10:33
Operating System: Windows Server 2008 R2

Re: Autostart Windows Server 2008 R2

Postby Altrea » 24. September 2014 10:07

im XAMPP control panel die jeweiligen Svc Checkfelder setzen (aufs rote X klicken)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Autostart Windows Server 2008 R2

Postby TeamBob » 24. September 2014 11:58

Also ich habe die roten X angeklickt und habe auch bei Apache und MySQL einen Hacken dran.
Jedoch wenn ich jetzt die Dienste starte, dann kann ich nicht merh auf localhost zugreifen und bekomme
immer eine Fehlermeldung.
Im xampp Panel fällt auch auf, dann wenn ich MySQL als Dienst aktviere und dann starte, dann
steht bei MySQl nicht der Port 3006, sondern ich bekomme die standardfehlermeldung mit Port geblockt, keine berechtigung.....etc.
Wenn ich Apache als Dienst laufen lassen und MySQL nicht,sondern nur starte, dann komm ich auf die Seite rauf,
nur nicht wenn ich MySQL als Dienst setze.
Woran kann das liegen?


*Update*
Ok hab den Fehler gefunden.
Man musste in der Ini Datei den ganz genauen Pfad eingeben. Beim akivieren der Ports gehts auch ohne, aber sobald MySQL
als Dienst läuft und nicht auf C: ist muss man das da auch hinterlegen.
TeamBob
 
Posts: 8
Joined: 08. September 2014 10:33
Operating System: Windows Server 2008 R2


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 3 guests