localhost sehr sehr langsam

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

localhost sehr sehr langsam

Postby PeterMG » 27. August 2014 11:01

Hallo Community,
als User mit eher bescheidenen Kenntnissen habe ich vor einiger Zeit Xampp installiert und mit Joomla einfache Webseiten erstellt. Nach längerer Pause habe ich jetzt versucht, diese wieder aufzurufen. Apache und mysql lassen sich im Xampp-Controll-Panel normal starten, unter „Module Dienst“ stehen die roten Kreuze.
Localhost (127.0.0.1 gleichermaßen) braucht ewig lange, um eine Seite aufzubauen (teilweise 1 Minute). Das gilt für alle Seiten, die ich erstellt habe. Gleiches beim Klick auf einen Button. Phänomen tritt auch beim Aufruf des Backends von Joomla auf. Teilweise ist ein Aufruf auch nicht möglich. Die Ports 80 und 443 sind von httpd.exe besetzt, was vermutlich richtig sein dürfte. Abschalten der Firewall und von Defender zeigt keine Verbesserung.
Die intensive Suche nach Malware pp ist ohne Erfolg geblieben.
Die error-logs haben folgenden Inhalt:
Apache error-log:
[Wed Aug 27 10:33:26.914486 2014] [ssl:warn] [pid 4952:tid 392] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Aug 27 10:33:27.027537 2014] [core:warn] [pid 4952:tid 392] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Aug 27 10:33:27.172754 2014] [ssl:warn] [pid 4952:tid 392] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Aug 27 10:33:27.243534 2014] [mpm_winnt:notice] [pid 4952:tid 392] AH00455: Apache/2.4.9 (Win32) OpenSSL/1.0.1g PHP/5.5.11 configured -- resuming normal operations
[Wed Aug 27 10:33:27.243534 2014] [mpm_winnt:notice] [pid 4952:tid 392] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:13:13
[Wed Aug 27 10:33:27.243534 2014] [core:notice] [pid 4952:tid 392] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Aug 27 10:33:27.247538 2014] [mpm_winnt:notice] [pid 4952:tid 392] AH00418: Parent: Created child process 3348
[Wed Aug 27 10:33:27.971396 2014] [ssl:warn] [pid 3348:tid 392] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Aug 27 10:33:28.235364 2014] [ssl:warn] [pid 3348:tid 392] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Aug 27 10:33:28.311048 2014] [mpm_winnt:notice] [pid 3348:tid 392] AH00354: Child: Starting 150 worker threads.

Msql error log:
2014-08-27 10:37:27 2352 [Note] Plugin 'FEDERATED' is disabled.
2014-08-27 10:37:27 c04 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2014-08-27 10:37:27 2352 [Note] InnoDB: Using atomics to ref count buffer pool pages
2014-08-27 10:37:27 2352 [Note] InnoDB: The InnoDB memory heap is disabled
2014-08-27 10:37:27 2352 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2014-08-27 10:37:27 2352 [Note] InnoDB: Compressed tables use zlib 1.2.3
2014-08-27 10:37:27 2352 [Note] InnoDB: Not using CPU crc32 instructions
2014-08-27 10:37:27 2352 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2014-08-27 10:37:27 2352 [Note] InnoDB: Completed initialization of buffer pool
2014-08-27 10:37:27 2352 [Note] InnoDB: Highest supported file format is Barracuda.
2014-08-27 10:37:27 2352 [Note] InnoDB: The log sequence numbers 1625987 and 1625987 in ibdata files do not match the log sequence number 201807247 in the ib_logfiles!
2014-08-27 10:37:27 2352 [Note] InnoDB: Database was not shutdown normally!
2014-08-27 10:37:27 2352 [Note] InnoDB: Starting crash recovery.
2014-08-27 10:37:27 2352 [Note] InnoDB: Reading tablespace information from the .ibd files...
2014-08-27 10:37:27 2352 [Note] InnoDB: Restoring possible half-written data pages
2014-08-27 10:37:27 2352 [Note] InnoDB: from the doublewrite buffer...
2014-08-27 10:37:27 2352 [Note] InnoDB: 128 rollback segment(s) are active.
2014-08-27 10:37:27 2352 [Note] InnoDB: Waiting for purge to start
2014-08-27 10:37:27 2352 [Note] InnoDB: 5.6.16 started; log sequence number 201807247
2014-08-27 10:37:27 2352 [Note] Server hostname (bind-address): '*'; port: 3306
2014-08-27 10:37:27 2352 [Note] IPv6 is available.
2014-08-27 10:37:27 2352 [Note] - '::' resolves to '::';
2014-08-27 10:37:27 2352 [Note] Server socket created on IP: '::'.


Trotz intensiver mehrtägiger Suche habe ich bisher keine Lösung gefunden. Daher bin ich für jeden Tipp sehr dankbar. :)
MfG
Peter
PeterMG
 
Posts: 2
Joined: 27. August 2014 10:11
Operating System: win 8.1

Re: localhost sehr sehr langsam

Postby Nobbie » 27. August 2014 12:37

Der Titel ist sicherlich nicht so richtig, nicht "localhost" ist sehr sehr langsam, sondern Joomla ist sehr sehr langsam. Das ist ein bekanntes Problem unter Xampp, eine durchschlagende Lösung unter Windows habe ich noch nicht gesehen, es hängt wahrscheinlich damit zusammen, dass Joomla wahnsinnig viele Datenbankrequest auf den localhost ausführt, was wahrscheinlich zu einem Engpass führt.

Wenn Du "Joomla Xampp langsam" in Google eingibst, bekommst Du massenhaft Treffer angezeigt. Man fummelt sich da so durch, verschiedenste Lösungsversuche werden da ausprobiert.

Ich selbst würde das ganze auf Linux portieren, in aller Regel läuft das performanter als unter Windows. Wenn das keine Option ist, würde ich der Reihe nach versuchen:

a) Apache nicht auf "localhost" betreiben, sondern auf der IP der Netzwerkkarte (meistens so in der Art 192.168.1.24), das hängt vom Router usw. ab, welche IP das genau ist. Das wird über die LISTEN Anweisung in httpd.conf festgelegt.

b) die MySQL Datenbank wird seit einiger Zeit als InnoDB ausgeliefert (das ist eine bestimmte sog. "Engine"). Die ist auch erheblich langsamer als die vormals benutzte Engine MyISAM. Man kann aber immer noch auf MyISAM umstellen und dann auch die Joomla Datenbanke auf MyISAM umstellen. ACHTUNG: vorher ein Backup der Datenbanken machen!!

c) MySQL so konfigurieren, dass nicht via TCPIP und Port 3306 kommuniziert wird, sondern via "Socket". Die entsprechenden Einstellungen kann man in my.ini (bzw. my.cnf) im MySQL/bin Ordner durchführen. Dann belasten die Datenbankzugriffe nicht auch noch den localhost.

d) in anderen Foren (insbesondere auch mal bei Joomla) nachfragen, wo denn da soviele Ressourcen gefressen werden und welche Optimierungsmöglichkeiten es gibt.

Fakt ist, dass es nicht an localhost an sich liegt und auch nicht an Xampp an sich, es gibt jede Menge andere Scripts die laufen einwandfrei. Manchmal liegt es auch an irgendwelchen Firewalls und Virenwächtern usw., die den TCPIP Traffic überwachen und die einfach das System ausbremsen. Würde ich auch mal schauen, dass das alles abgeschaltet wird.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: localhost sehr sehr langsam

Postby PeterMG » 27. August 2014 12:49

Hallo Nobbie,

danke für die schnelle Antwort. Firewalls und Virenwächter hatte ich alle ausgeschaltet.

Deine Lösungsvorschläge werde ich mal ausprobieren. Kann ich denn davon ausgehen, dass die geposteten Fehlermeldungen alle nicht relevant sind?

Mir ist unverständlich, dass die gleiche Anwendung wenige Wochen zuvor ohne jegliches Performance-Problem gelaufen ist.

Herzl. Grüße :)

Peter
PeterMG
 
Posts: 2
Joined: 27. August 2014 10:11
Operating System: win 8.1

Re: localhost sehr sehr langsam

Postby Nobbie » 27. August 2014 12:54

PeterMG wrote:Kann ich denn davon ausgehen, dass die geposteten Fehlermeldungen alle nicht relevant sind?


Da sind keine Fehlermeldungen. Das meiste sind nur "Notice" (= Anmerkung) und wenige Warnungen (warn). Es ist kein einziger Fehler darunter (error).

PeterMG wrote:Mir ist unverständlich, dass die gleiche Anwendung wenige Wochen zuvor ohne jegliches Performance-Problem gelaufen ist.


Das bedeutet in aller Regel, dass in der Zwischenzeit irgendetwas installiert wurde, was empfindlich in das System eingreift. Ob das reine Abschalten von Virentools beispielsweise den Urzustand auch herstellt, kann ich nicht beurteilen.

Vielleicht ist auch irgendein Windows Update Schuld, vielleicht eine Anpassung für IPv6, oder oder oder... jedenfalls scheint es darauf hinzuweisen, dass es nicht grundsätzlich an Xampp liegt.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: localhost sehr sehr langsam

Postby Altrea » 27. August 2014 15:56

Nobbie wrote:vielleicht eine Anpassung für IPv6

Das habe ich eher im Verdacht. localhost namensauflösung zu IPv6 mit Fallback auf IPv4 kann schon zu großen Verzögerungen bei großen CMSen wie Joomla führen.
Ich würde daher als allererstes für Joomla als Datenbankhost 127.0.0.1 statt localhost verwenden.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost sehr sehr langsam

Postby MH2013 » 28. August 2014 06:42

Altrea wrote:Ich würde daher als allererstes für Joomla als Datenbankhost 127.0.0.1 statt localhost verwenden.

Ja, mit der IP statt dem "localhost" läuft es bei mir auch wesentlich besser.
MH2013
 
Posts: 11
Joined: 28. January 2013 13:36
Operating System: Win 8


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests