Windowsdienst und Mysql-Service(Server)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Windowsdienst und Mysql-Service(Server)

Postby strongbow2005 » 13. August 2004 00:13

Hallo wer kann mir helfen!
Habe zu Testzwecken "Foxserv" verwendet und nun "Xampp" leider hat Windows also Foxserv den MySQL Server als Dienst in den "Port 3306" geschrieben.Nun habe ich Xampp installiert und auch mysql leider habe ich nun Probleme mit MySql da der Dienst nicht startet

//MySQL-Datenbank DEAKTIVIERT//
C:\xampp>mysql_start
Diese Eingabeforderung nicht waehrend des Running beenden
Please dont close Window while MySQL is running
MySQL is trying to start
Please wait ...
MySQL is starting with mysql\bin\my.cnf (console)
Can't start server: Bind on TCP/IP port: No error
040813 1:07:02 Do you already have another mysqld server running on port: 3306
?
040813 1:07:02 Aborting

040813 1:07:02 mysql\bin\mysqld: Shutdown Complete

//

So wie entferne ich den alten MysqlServer??Hab schon mit regedit probiert aber hab keinen alten pfad gefunden auch in der my.cnf ist auch nichts zu finden....

Thx für die Hilfe
strongbow2005
 
Posts: 6
Joined: 12. August 2004 23:57

Postby Nappi » 13. August 2004 10:55

Versuche mal den Dienst des MySQL-Services zu beenden.

Will heißen

Offne "Systemsteuerungen" - starte "Verwaltung" - starte "Dienste" scroll unter Namen so lange runter bis du "MySQL" oder etwas vergleichbares findest (ich weis nicht wie Foxserv den Dienst einträgt) - Doppelklick auf den Eintrag - unter "Allgemein" bei "Dienststatus" auf "beenden" klicken und bei "Starttyp" die Auswahl auf "Deaktiviert" markieren. Alles schließen den Rechner neu Starten und nun sollte MySQL wieder von Hand gestartet werden können.

Nappi
Nappi
 
Posts: 5
Joined: 12. August 2004 20:17

Postby strongbow2005 » 13. August 2004 14:21

Das ist ja das Problem eingetragen ist Xampp

MySQL-Dienst=

C:\xampp\mysql\bin\mysqld-nt --defaults-file=C:\xampp\mysql\bin\my.cnf mysql

es ist der Port 3306 den beide verwenden möchten also xampp und foxserve hat sich diesen Port irgendwo reserviert..
strongbow2005
 
Posts: 6
Joined: 12. August 2004 23:57

Postby Wiedmann » 13. August 2004 14:34

Dein grundsätzliches Problem ist, dass du den Server schon als Dienst gestartet hast und ihn dann nochmal als Konsolenanwendung starten willst. Bei diesem 2. Start meckert er dann, weil der Server ja schon läuft.

Beende doch den Dienst über die Computerverwaltung und stell dann die Startart gleich auf "manuell" um. Wenn der Dienst dann beendet ist, kannst du den Server dann über die Batchdatei starten (xampp_start).

Oder du arbeitest gleich mit den installierten Diensten und läßt das Starten mit der Batchdatei...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Keinen Dienst mehr

Postby strongbow2005 » 13. August 2004 14:55

Den Dienst habe ich rausgenommen also manuell gestartet das Problem ist aber weiterhin da?

mysql_uninstallservice

noch immer die Fehlermeldung...
********************************************************
C:\xampp>xampp_start
Diese Eingabeforderung nicht waehrend des Runnings beenden ...
Zum stoppen bitte die xampp_stop benutzen!
Please do not close this window while running ...
Use the xampp_stop for shutdown!

Please wait [Bitte warten] [Fri Aug 13 15:47:51 2004] [notice] Disabled use of A
cceptEx() WinSock2 API
Can't start server: Bind on TCP/IP port: No error
040813 15:47:51 Do you already have another mysqld server running on port: 3306
?
040813 15:47:51 Aborting

040813 15:47:51 mysql\bin\mysqld.exe: Shutdown Complete

...

### APACHE + MYSQL IS STARTING NOW ###

*******************************************************
MySQL-Datenbank DEAKTIVIRT

Wo ist der 2.Server???Nicht in der my.ini...

Habe in der Registrie

ControlSet001 (ROOT)und ControlSet002 unter 2 mal Mysql kann da eine zuviel sein und wenn ja welche??

thx
strongbow2005
 
Posts: 6
Joined: 12. August 2004 23:57

Postby Wiedmann » 13. August 2004 15:10

Nur weil du "mysql_uninstallservice" ausführst, heisst das nicht das etwas deinstaliert wurde (hab ich was von uninstall geschrieben?)....

Mach halt einfach was ich geschrieben habe. Beende die MySQL-Dienste und stelle sie auf manuell um (egal wieviel da sind, jeden halt).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Sorry kein MySql Dienst

Postby strongbow2005 » 13. August 2004 15:26

Es ist kein Dienst eingetragen also MySql ist nicht eingetragen scheint auch nirgends auf deshalb mach ich mir ja sorgen wo dieses blöde ding läuft. :roll:
lg strongbow


ABER kein MySql

normal text export
Last edited by strongbow2005 on 13. August 2004 15:49, edited 1 time in total.
strongbow2005
 
Posts: 6
Joined: 12. August 2004 23:57

Postby Wiedmann » 13. August 2004 15:41

Mit was für einem Programm hast du denn das gemacht? (das nächste mal vielleicht auch auf den Code-Button drücken).

Mach das mal mit "services.msc" oder "msinfo32.exe" oder "msconfig.exe".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests