xampp 1.8.3 startet Apache nicht mehr...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp 1.8.3 startet Apache nicht mehr...

Postby Paykoman » 29. April 2014 19:20

Hallöchen,

da ich die password_*-Funktionen in mein Script integrieren möchte, musste ich eben auch xampp updaten damit ich die aktuelle PHP-version zur Verfügung habe.

Die Installation lief soweit reibungslos bis auf am Anfang kam ne Warnung meldung aber ik weiß nimmer was da stand ausser man solle nach der installation iwas machen, leider zeigt er da aber nichts mehr an war iwas mit "AOC" oder so ähnlich...

Naja jedenfalls lief nach der Installation alles, ich habe meine Backups aufgespielt, httpd.conf angepasst und apache aus/an gemacht und er startet nun nicht mehr.
20:19:35 [Apache] Attempting to start Apache service...
20:19:35 [Apache] Executing "net start "Apache2.4""
20:19:38 [Apache] Return code: 0


Auch mit der original Datei startet er nicht, es liegt also nicht an der conf und die Backups sind nur datenbanken und ordner im htpdocs Ordner gewesen daran sollte es also auch nicht scheitern.

Netstat zeigt soweit keine Fehler wegen Ports an und da stellt sich mir nun die Frage was das Problem sein könnte?


MFG: Paykoman
Paykoman
 
Posts: 8
Joined: 03. January 2011 20:25

Re: xampp 1.8.3 startet Apache nicht mehr...

Postby Paykoman » 30. April 2014 10:17

Hmm niemand wo helfen kann?
Meinen Server konnte ich nun erfolgreich auf php 5.5 updaten jetzt muss ich es natürlich auch lokal haben damit ich weiterhin auch lokal entwickeln kann was ja nicht geht wenn ich Funktionen Nutzte die erst ab 5.5 vorhanden sind.
Wäre da echt dankbar für eure Hilfe damit ich weiter entwickeln kann =(

MFG: Pay
PS: Muss hier und da gerade noch was am Server einrichten dann werde ich die Installation von xampp noch mal machen um zu sehen was er da am Anfang meckert...


:: EDIT::

---------------------------
Warning
---------------------------
Important! Because an activated User Account Control (UAC) on your sytem some functions of XAMPP are possibly restricted. With UAC please avoid to install XAMPP to C:\Program Files (x86) (missing write permisssions). Or deactivate UAC with msconfig after this setup.
---------------------------
OK
---------------------------



Ich check nicht ganz was der da von mir will, zu einem habe ich es eh unter D:/ und nicht C:/ installiert und zum anderen warum UAC da probleme machen soll ist mir unklar, da wie er schon sagt ich es activiert habe etc. brauch ich das dann nicht auch damit meine Windowsnutzer etc. weiter hin funktionieren?

Aber ich denke das sollte letzendlich nciht das Problem sein warum apache nicht mehr startet oder?
Paykoman
 
Posts: 8
Joined: 03. January 2011 20:25

Re: xampp 1.8.3 startet Apache nicht mehr...

Postby Altrea » 30. April 2014 14:58

Paykoman wrote:Hmm niemand wo helfen kann?

Mit der Informationslage sicher nicht.
Zuerst einmal solltest du die Windows Dienste wieder entfernen und die XAMPP Komponenten ohne diese versuchen zu starten.
Und wenn das nicht funktioniert benötigen wir erstmal informationen aus den jeweiligen Logdateien.
Sollte sich Apache nicht starten lassen kannst du es auch mal über die apache_start.bat Datei probieren, die zumindest den Grund zurückliefern sollte, weshalb Apache nicht starten mag.

Paykoman wrote:Ich check nicht ganz was der da von mir will

Steht doch alles da, man muss es nur lesen

Paykoman wrote:zu einem habe ich es eh unter D:/ und nicht C:/ installiert

Dann sollte dir klar sein, dass der Part mit dem Installationsverzeichnis dich nicht betrifft.
Mit eingeschalteter UAC sind bestimmte Verzeichnisse besonders geschützt, unter anderem auch das Programme Verzeichnis unter C:\.

Paykoman wrote:und zum anderen warum UAC da probleme machen soll ist mir unklar, da wie er schon sagt ich es activiert habe etc. brauch ich das dann nicht auch damit meine Windowsnutzer etc. weiter hin funktionieren?

Nein. Es ist ein Versuch von Microsoft den Standardadministrator auf Windows Systemen zu beschränken (ähnlich wie es bei *nix Systemen seit Jahr und Tag der Fall ist). Dies ist meiner Meinung nach aber sehr halbherzig umgesetzt worden und führt daher bei einigen Programmen zu Problemen.
Würdest du die UAC abschalten wäre allerdings die "als Administrator ausführen" Funktion in anderen Benutzerkontexten beeinträchtigt.

Mit eingeschalteter UAC solltest du halt nur daran denken, dass XAMPP mit erhöhten Administratorrechten gestartet wird (rechtsclick -> ausführen als Administrator). Dann ist das kein Problem mehr.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp 1.8.3 startet Apache nicht mehr...

Postby Paykoman » 30. April 2014 15:33

Hallo,

danke für deine Antwort.
Beim rum tüffteln habe ich dann vorhin auch über die separate datei den Handler gestartet dort gab es dan durch aus mehr Informationen alsi m Kontrollzenter, warum auch immer, dachte gerade dafür kann man extra fehler dort anzeigen lassen.

Naja wie es auch sein mag, jetzt läuft es jeden falls.

MFG: Pay
Paykoman
 
Posts: 8
Joined: 03. January 2011 20:25

Re: xampp 1.8.3 startet Apache nicht mehr...

Postby Altrea » 30. April 2014 15:58

Und jetzt lässt du den Beitrag hier so stehen, ohne die Ursache zu nennen?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests