Text mit Sonderzeichen wird in Textfeldern nicht angezeigt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Text mit Sonderzeichen wird in Textfeldern nicht angezeigt

Postby Gurrru » 13. April 2014 08:33

Hi,

ich habe ein Script (selbst erstellt) was unter einer älteren Xampp version, Installiert vor ca. 1,5 Jahren ebenfalls unter Windows7, perfekt funktioniert hat.

Jetzt ist ein neuer Rechner da und ich habe die aktuelle Version von Xampp vor ca. 2 Wochen installiert.
alles funktioniert, bis auf eines:

Texte mit Sonderzeichen, die aus einer mySQL Datenbank geladen werden, werden im Browser korrekt dargestellt. Jetzt möchte ich den Text ändern, dafür wird der Text in einer Form in Textfeldern dargestellt. Sobald ein Sonderzeichen vorkommt (ä,ü,ö,–, usw.) bleiben die Textfelder aber einfach leer.

Folgendes ist mir aufgefallen (Die Variable " $tplout['namede_l']" speichert das was in einem der Textfelder ausgegeben werden soll)

Das funktioniert nicht:
Code: Select all
$tplout['namede_l']=htmlspecialchars(stripslashes($row['epname_de']));


Das hingegen funktioniert:
Code: Select all
$tplout['namede_l']=stripslashes($row['epname_de']);


Warum ist das so? Ich verstehe es nicht.

In der php.ini und in der my.ini ist kein charset gesetzt.
In der phpino() steht: default_charset - no value

Die betreffenden mySQL Tabellen verwenden alle latin1_german1_ci

Diese Einstellungen sind identisch mit der Installation auf meinem alten Rechner.

Über Google habe ich etwas zum Thema Oracle gefunden (hab ich nie benutzt und ich kenne mich dabei auch nicht aus), dort hat jemand behauptet die Lösung wäre wenn
putenv("NLS_LANG=GERMAN_GERMANY.WE8ISO8859P1");

am Anfang des Scripts gesetzt wird. Hat bei mir nicht funktioniert. Keine veränderung.

Auch das verändern des Charset in php und/oder mySQL führt nur dazu das Sonderzeichen im Browser nicht korrekt und in den Textfeldern weiterhin gar nicht dargestellt werden.

Ich danke schon mal fürs Lesen :)
Gurrru
 
Posts: 1
Joined: 13. April 2014 08:17
Operating System: Windows 7

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests