Sicherheitskonzept xampp mit Win 8.1

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Sicherheitskonzept xampp mit Win 8.1

Postby wonk » 15. February 2014 16:55

Hallo,
ich habe xampp in c:/xampp unter Windows 8.1 installiert um lokal erstellte Webseiten zu prüfen. Es sind keine Erweiterungen installiert, auch php/MyAdmin nicht. Mit der original httpd.conf erhalte ich mit IE mit URL 127.0.0.1 und localhost "normal" die XAMPP-Startseite.
Wenn ich in der httpd.conf jedoch einen zusätzlichen directory-Eintrag erstelle, z.B.
Directory "C:/meine_lokale_Webseite"
erhalte ich beim Start von Apache
16:33:05 [Apache] Error: Apache shutdown unexpectedly.
16:33:05 [Apache] This may be due to a blocked port, missing dependencies,
16:33:05 [Apache] improper privileges, a crash, or a shutdown by another method.
16:33:05 [Apache] Press the Logs button to view error logs and check
16:33:05 [Apache] the Windows Event Viewer for more clues
16:33:05 [Apache] If you need more help, copy and post this
16:33:05 [Apache] entire log window on the forums
Das error.log enthält keine Einträge. Die Windows-Firewall hatte ich vorsichtshalber deaktiviert.
Die Ereignisprotokollierung zeigt für mich nichts Relevantes.
Woran kann es liegen?

mfG wonk
Last edited by wonk on 19. February 2014 18:32, edited 1 time in total.
wonk
 
Posts: 18
Joined: 21. June 2012 08:59
XAMPP Version: 1.8.3-3
Operating System: Windows 8.1

Re: Sicherheitskonzept xampp mit Win 8.1

Postby wonk » 15. February 2014 17:33

Hallo,
ich sehe gerade selbst, dass das Handbuch, welches einen solchen Konfigurationseintrag vorsieht wohl veraltet ist.

Wenn ich statt dessen aber setze:
DocumentRoot "C:/meine_lokale_webseite"
<Directory "C:/meine_lokale_webseite">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>
startet Apache zwar fehlerfrei, beim Zugriff auf die Seite mit 127.0.0.1 oder localhost mit IE erhalte ich aber error 403, Zugriff verweigert.
Ein Ausschalten der Firewall hilft nicht.
Das error.log sagt:
[authz_core:error] [pid 4244:tid 1724] [client ::1:50745] AH01630: client denied by server configuration: C:/meine_lokale_webseite/
Das acess.log:
::1 - - [15/Feb/2014:17:31:01 +0100] "GET / HTTP/1.1" 403 1143 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko"

Was sagt mir das nun alles?
Danke, wonk
Last edited by wonk on 19. February 2014 18:32, edited 1 time in total.
wonk
 
Posts: 18
Joined: 21. June 2012 08:59
XAMPP Version: 1.8.3-3
Operating System: Windows 8.1

Re: Sicherhietskonzept xampp mit Win 8.1

Postby Altrea » 15. February 2014 19:57

Hallo wonk,

wonk wrote:Wenn ich in der httpd.conf jedoch einen zusätzlichen directory-Eintrag erstelle, z.B.
Directory "C:/meine_lokale_Webseite"
erhalte ich beim Start von Apache
[...]
Woran kann es liegen?

Da es ohne diese Anpassung funktioniert, kann es nur an dieser Anpassung liegen.
Im Zweifel verwendest du eine nicht gültige Syntax.
Da du uns die genaue Schreibweise aber nicht zeigst, kann dir niemand genau sagen woran es liegt.

wonk wrote:Wenn ich statt dessen aber setze:
DocumentRoot "C:/meine_lokale_webseite"
<Directory "C:/meine_lokale_webseite">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>
startet Apache zwar fehlerfrei, beim Zugriff auf die Seite mit 127.0.0.1 oder localhost mit IE erhalte ich aber error 403, Zugriff verweigert.
Ein Ausschalten der Firewall hilft nicht.
Das error.log sagt:
[authz_core:error] [pid 4244:tid 1724] [client ::1:50745] AH01630: client denied by server configuration: C:/meine_lokale_webseite/
Das acess.log:
::1 - - [15/Feb/2014:17:31:01 +0100] "GET / HTTP/1.1" 403 1143 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko"

Was sagt mir das nun alles?

Das sagt dir, dass der Zugriff auf diese Ressource von einer Apache-Serverkonfiguration verboten wird.
In deinem Fall liegt das daran, dass du die veraltete Apache 2.2 Access Syntax verwendest. Diese hat sich seit Apache 2.4 stark verändert.
Deine Anpassungen greifen zwar, aber überschreiben die Standardregeln nicht.

Verwende stattdessen die neue Syntax. In etwa so:
Code: Select all
<Directory "C:/meine_lokale_webseite">
    AllowOverride None
    Options None
    Require all granted
</Directory>


Warum du eine DocumentRoot Zeile setzt erschließt sich mir nicht. Es wird nicht empfohlen den Standard-DocumentRoot zu verändern.
Möchtest du einen zusätzlichen DocumentRoot setzen würde ich stattdessen virtual hosts empfehlen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6820
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Sicherhietskonzept xampp mit Win 8.1

Postby wonk » 16. February 2014 15:17

Hallo,
danke für die Hinweise, jetzt funktioniert es.
Allerdings kommt man durch Einfügen von <virtualhost 127.0.0.1>... nicht mehr direkt an die Doku unter c:/xampp/htdocs ran.
Die Auflösung von "localhost" funktioniert unter Win8.1 auch nicht richtig, aber das macht hier nichts.
Gruss, wonk
wonk
 
Posts: 18
Joined: 21. June 2012 08:59
XAMPP Version: 1.8.3-3
Operating System: Windows 8.1

Re: Sicherhietskonzept xampp mit Win 8.1

Postby Altrea » 16. February 2014 15:21

wonk wrote:Allerdings kommt man durch Einfügen von <virtualhost 127.0.0.1>... nicht mehr direkt an die Doku unter c:/xampp/htdocs ran.

Und schon wieder der Hinweis, dass uns die vollständige Syntax deiner Änderung fehlt.
Daher: Du hast es falsch gemacht, aber wir können dir nicht zeigen, wie du es richtig machen kannst.

wonk wrote:Die Auflösung von "localhost" funktioniert unter Win8.1 auch nicht richtig, aber das macht hier nichts.

Die Auflösung von localhost funktioniert so wie von Microsoft für Windows 8.1 definiert.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6820
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Sicherhietskonzept xampp mit Win 8.1

Postby wonk » 17. February 2014 10:17

Hallo!
Ich habe in die httpd.conf eingefügt:
<Directory "C:/meine_lokale_webseite">
AllowOverride None
Options None
Require all granted
</Directory>

<VirtualHost 127.0.0.1>
# ServerAdmin webmaster@host.foo.com
DocumentRoot C:/meine_lokale_webseite
ServerName AhE
</VirtualHost>

Den Directory-Eintrag <Directory "C:/xampp/htdocs">... habe ich gelassen, ebenso DocumentRoot "C:/xampp/htdocs".

Ich weiß nicht, wie Win8.1 localhost auflöst. Ich habe jetzt in der hosts-Datei eingetragen 127.0.0.1 localhost. Dann funktioniert der Zugriff auf c:/xampp/htdocs über localhost immerhin mit IE, nicht aber mit Firefox, siehe auch viewtopic.php?f=4&t=68067.

Gruss, wonk
wonk
 
Posts: 18
Joined: 21. June 2012 08:59
XAMPP Version: 1.8.3-3
Operating System: Windows 8.1

Re: Sicherhietskonzept xampp mit Win 8.1

Postby Nobbie » 17. February 2014 15:50

Das geht so nicht. Dir fehlen wichtige Grundlagen.

Wenn man überhaupt irgendeinen VirtualHost angibt, muss man JEDE Domain, die man verwalten will, als VirtualHost anlegen. Die "externe" Angabe ServerName usw. wird ignoriert. Mit anderen Worten: wenn Du localhost irgendie und irgendwo sehen willst, musst Du dafür einen VirtualHost anlegen.
Nobbie
 
Posts: 6997
Joined: 09. March 2008 13:04

Re: Sicherhietskonzept xampp mit Win 8.1

Postby wonk » 18. February 2014 10:49

Hallo,
das mit den fehlenden Grundlagen ist natürlich richtig. Ich möchte Apache halt nur zur lokalen Kontrolle meiner Webseite nutzen.

Ich habe also jetzt angelegt:
<VirtualHost 127.0.0.2>
DocumentRoot "C:/xampp/htdocs"
ServerName Apache
</VirtualHost>
Damit bekomme ich dann Zugriff auf die Doku.

Mit locahost funktioniert es aber trotzdem nicht richtig, macht aber nichts.

Danke, wonk
wonk
 
Posts: 18
Joined: 21. June 2012 08:59
XAMPP Version: 1.8.3-3
Operating System: Windows 8.1

Re: Sicherhietskonzept xampp mit Win 8.1

Postby Nobbie » 18. February 2014 11:02

wonk wrote:<VirtualHost 127.0.0.2>


Wieso 127.0.0.2??

wonk wrote:Mit locahost funktioniert es aber trotzdem nicht richtig, macht aber nichts.


Weil Du immer noch etwas falsch machst, da wir ebenfalls immer noch nicht sehen, WAS Du machst, können wir Dir auch nicht sagen, was Du falsch machst.
Nobbie
 
Posts: 6997
Joined: 09. March 2008 13:04

Re: Sicherhietskonzept xampp mit Win 8.1

Postby wonk » 19. February 2014 09:51

Hallo!
Mit den 2 VirtualHost-Einträgen erreiche ich jetzt im Browser mit 127.0.0.1 meine lokale Homepage, 127.0.0.2 die Apache-Doku. Welche Information bruachst Du denn noch?
Gruss, wonk
wonk
 
Posts: 18
Joined: 21. June 2012 08:59
XAMPP Version: 1.8.3-3
Operating System: Windows 8.1

Re: Sicherhietskonzept xampp mit Win 8.1

Postby Altrea » 19. February 2014 12:09

Man könnte es auch einfach richtig konfigurieren, indem mal einen vhost für localhost, der orangenen XAMPP Administrationsseite und einen anderen vhost für AhE definiert.
Das sagt dir Nobbie auch schon die ganze Zeit, aber bisher machst du uns nicht den Anschein, als hättest du das je so probiert.
Zumindest sehe ich hier keinen einzigen Eintrag von dir wo beide vhosts in derselben Konfiguration zu finden sind.

Mir ist deine Konfiguration relativ Wurscht. Wenn du mit dem gehampel von wegen 127.0.0.2 leben kannst. Mich würd' das nerven.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6820
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Sicherhietskonzept xampp mit Win 8.1

Postby Nobbie » 19. February 2014 13:23

wonk wrote:Welche Information bruachst Du denn noch?


Ich brauche gar nichts, Du hast ein Problem mit falsch konfiguriertem Apache. Dann lassen wir es eben so.
Nobbie
 
Posts: 6997
Joined: 09. March 2008 13:04

Re: Sicherhietskonzept xampp mit Win 8.1

Postby wonk » 19. February 2014 18:30

Hallo,
wenn Ihr meintet mit Einträgen
<VirtualHost Apache>
DocumentRoot "C:/xampp/htdocs"
ServerName Apache
</VirtualHost>
und
<VirtualHost AhE>
DocumentRoot "C:/mein_lokale_webseite"
ServerName AhE
</VirtualHost>
könnte ich dann im Browser mit der URL Apache bzw. Ahe auf die beiden lokalen Sites zugreifen:

DAS ist unter Win8.1. NICHT der Fall.
Gruss wonk
wonk
 
Posts: 18
Joined: 21. June 2012 08:59
XAMPP Version: 1.8.3-3
Operating System: Windows 8.1

Re: Sicherhietskonzept xampp mit Win 8.1

Postby Nobbie » 19. February 2014 21:05

wonk wrote:Hallo,
wenn Ihr meintet mit Einträgen


Nein, das meine ich nicht. Ich meine damit, dass mit diesen wild fehlerhaften und verfälschten und somit unbrauchbaren Müllauszügen sowieso keine Hilfe möglich ist und da Du Dich (obwohl Du es es bist, der hier um Hilfe fragt) mit Händen und Füßen dagegen wehrst, endlich mal echte und brauchbare Auszüge hier einzustellen, auch weiterhin keine Hilfe möglich sein wird und ich insbesondere auch keinen Bock mehr auf diesen Schwachsinn habe. Zuviel ist zuviel.

In dieser intensiven Form habe ich Beratungsresistenz nur selten erlebt. Aber egal - jeder wie er will. Ich klinke mich jetzt aus. Tschö.
Nobbie
 
Posts: 6997
Joined: 09. March 2008 13:04

Re: Sicherheitskonzept xampp mit Win 8.1

Postby Altrea » 20. February 2014 06:12

Probiers doch mal so
Code: Select all
<VirtualHost *:80>
    DocumentRoot "C:/xampp/htdocs"
    ServerName localhost
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:/mein_lokale_webseite"
    ServerName AhE
    <Directory "C:/meine_lokale_webseite">
        AllowOverride None
        Options None
        Require all granted
    </Directory>
</VirtualHost>


Alles andere hängt an der Namensauflösung deines Windows 8.1 Systems. Das solltest du natürlich prüfen ob localhost und AhE korrekt nach 127.0.0.1 aufgelöst werden (oder von mir aus auch nach ::1 wenn du IPv6 bevorzugst)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6820
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: BlackBaer and 13 guests