Apache startet nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht

Postby meivin123 » 02. January 2014 21:26

Hallo,
ich wollte gerade meinen Apache Server starten und er startet nicht mehr.
Gestern hat er noch funktioniert.
Hier ist das Errorlog:
Code: Select all
[Wed Jan 01 03:58:13.334736 2014] [ssl:warn] [pid 2560:tid 272] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Wed Jan 01 03:58:13.361738 2014] [core:warn] [pid 2560:tid 272] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Jan 01 03:58:13.832765 2014] [ssl:warn] [pid 2560:tid 272] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Wed Jan 01 03:58:13.941771 2014] [mpm_winnt:notice] [pid 2560:tid 272] AH00455: Apache/2.4.4 (Win32) OpenSSL/1.0.1e PHP/5.5.3 configured -- resuming normal operations
[Wed Jan 01 03:58:13.941771 2014] [mpm_winnt:notice] [pid 2560:tid 272] AH00456: Server built: Feb 23 2013 12:42:00
[Wed Jan 01 03:58:13.941771 2014] [core:notice] [pid 2560:tid 272] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Jan 01 03:58:13.949771 2014] [mpm_winnt:notice] [pid 2560:tid 272] AH00418: Parent: Created child process 9052
[Wed Jan 01 03:58:14.576807 2014] [ssl:warn] [pid 9052:tid 284] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Wed Jan 01 03:58:15.105837 2014] [ssl:warn] [pid 9052:tid 284] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Wed Jan 01 03:58:15.133839 2014] [mpm_winnt:notice] [pid 9052:tid 284] AH00354: Child: Starting 150 worker threads.


WObei heute ja eigentlich der 2.1 ist.
Evtl. ist die Zeit falsch eingestellt oder Apache schreibt nichts ins error log.
meivin123
 
Posts: 7
Joined: 02. January 2014 21:23
Operating System: Windows 7 Ultimate x64

Re: Apache startet nicht

Postby Altrea » 02. January 2014 22:18

Hallo meivin123,

meivin123 wrote:WObei heute ja eigentlich der 2.1 ist.
Evtl. ist die Zeit falsch eingestellt oder Apache schreibt nichts ins error log.

Eher letzteres.

Was wir benötigen ist der vollständige Inhalt des XAMPP control panel log Fensters.
Hilfreich könnte auch die Rückgabemeldungen der apache_start.bat sein.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht

Postby meivin123 » 03. January 2014 00:26

Code: Select all
00:13:12  [main]    Initializing Control Panel
00:13:12  [main]    Windows Version: Windows 7 Ultimate SP1 64-bit
00:13:12  [main]    XAMPP Version: 1.8.3
00:13:12  [main]    Control Panel Version: 3.2.1  [ Compiled: May 7th 2013 ]
00:13:12  [main]    Running with Administrator rights - good!
00:13:12  [main]    XAMPP Installation Directory: "c:\xampp\"
00:13:12  [main]    Checking for prerequisites
00:13:12  [main]    All prerequisites found
00:13:12  [main]    Initializing Modules
00:13:12  [Tomcat]    Problem detected!
00:13:12  [Tomcat]    Port 8080 in use by ""C:\Program Files (x86)\National Instruments\Shared\NI WebServer\ApplicationWebServer.exe" -user"!
00:13:12  [Tomcat]    Tomcat WILL NOT start without the configured ports free!
00:13:12  [Tomcat]    You need to uninstall/disable/reconfigure the blocking application
00:13:12  [Tomcat]    or reconfigure Tomcat and the Control Panel to listen on a different port
00:13:12  [main]    Starting Check-Timer
00:13:12  [main]    Control Panel Ready
00:13:14  [Apache]    Attempting to start Apache app...
00:13:14  [Apache]    Status change detected: running
00:13:14  [Apache]    Status change detected: stopped
00:13:14  [Apache]    Error: Apache shutdown unexpectedly.
00:13:14  [Apache]    This may be due to a blocked port, missing dependencies,
00:13:14  [Apache]    improper privileges, a crash, or a shutdown by another method.
00:13:14  [Apache]    Press the Logs button to view error logs and check
00:13:14  [Apache]    the Windows Event Viewer for more clues
00:13:14  [Apache]    If you need more help, copy and post this
00:13:14  [Apache]    entire log window on the forums
meivin123
 
Posts: 7
Joined: 02. January 2014 21:23
Operating System: Windows 7 Ultimate x64

Re: Apache startet nicht

Postby Altrea » 03. January 2014 00:37

Nun benötigen wir definitiv noch die Rückgabemeldungen der apache_start.bat.
Bitte führe diese also per Doppelklick oder Befehl in der Eingabeaufforderung aus.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht

Postby meivin123 » 03. January 2014 07:48

In welchem Ordner ist die?
Ich hab keine gefunden, nur die apache_installservice.bat und die apache_uninstallservice.bat
meivin123
 
Posts: 7
Joined: 02. January 2014 21:23
Operating System: Windows 7 Ultimate x64

Re: Apache startet nicht

Postby Altrea » 03. January 2014 08:08

C:\xampp\apache_start.bat ?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht

Postby meivin123 » 03. January 2014 08:42

Code: Select all
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
AH00526: Syntax error on line 51 of C:/xampp/apache/conf/extra/httpd-ssl.conf:
Invalid command 'SSLCipherSuite', perhaps misspelled or defined by a module not

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .
meivin123
 
Posts: 7
Joined: 02. January 2014 21:23
Operating System: Windows 7 Ultimate x64

Re: Apache startet nicht

Postby Altrea » 03. January 2014 08:57

Hast du irgendwelche Änderungen an den Apache Konfigurationsdateien vorgenommen?
Zum Beispiel das mod_ssl Modul in der httpd.conf auskommentiert?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache startet nicht

Postby meivin123 » 03. January 2014 09:44

ja, jetzt gehts.
hatte es aber vprher auskommentiert als es schon nicht mehr ging.
meivin123
 
Posts: 7
Joined: 02. January 2014 21:23
Operating System: Windows 7 Ultimate x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests