XAMPP unter Windows Home Server 2011

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP unter Windows Home Server 2011

Postby backfischmedia » 25. October 2013 00:34

Hallo da draußen

Ich bin noch neu hier und mit dieser Konstellation von XAMPP erst ganz frisch unterwegs. Bisher nutzte ich XAMPP Lokal auf meinem Rechner unter Windows 7 als Testumgebung um Webseiten in CMS zu basteln. Hat auch prima geklappt. Nun sind wir aber zu zweit und würden die Testumgebung gerne auf unseren WHS 2011 umlegen, somit kann dann jeder gleichzeitig daran werkeln. So weit so gut.
Unsere Umgebung besteht somit also aus zwei Rechnern mit Windows 7, und einem WHS 2011. Alles Lokal über einen Router verbunden. Hab nun XAMPP 1.8.3 auf dem WHS 2011 installiert. Musste die Ports vom Apache auf 8080 und 444 ändern, damit er nicht mit dem WHS eigenen Server kollidiert. XAMPP läuft nun tadellos, startet und ist auch stabil. Ich kann nun über den lokalen Browser (IE 7) mit der URL : localhost:8080 arbeiten. XAMPP Admin geht oder auch unsere kleinen Projekte die wir mit contao erstellen. Funktioniert alles prima.
Jetzt das Problem.
Das ganze funktioniert leider nicht mehr sobald ich von einem der beiden Rechner auf die Sache zugreifen möchte. Sobald ich auf einem der beiden Client die URL eintippe: 25.117.144.155/localhost:88/beispielwebsite (ist jetzt eben ein Beispiel) bekomm ich einen Laufzeitfehler, und die Seite lässt sich nicht darstellen, genauso wie auch nicht das XAMPP Admin Tool.
Haben jetzt schon tagelang herumprobiert, und kommen nicht darauf. Hat denn da jemand eine Idee? Vielleicht wenn ihr Angaben bekommt? Schreibt uns einfach an, falls ihr eine Idee habt.
Da wir da noch nicht so erfahren sind, sagt uns bitte was ihr eventuell für Angaben braucht um da etwas beurteilen zu können. Würden uns freuen was zu lesen...Danke schon mal
backfischmedia
 
Posts: 1
Joined: 25. October 2013 00:18
XAMPP Version: 5.5.19
Operating System: WHS 2011

Re: XAMPP unter Windows Home Server 2011

Postby Altrea » 25. October 2013 06:20

Hi backfischmedia,

backfischmedia wrote:Hab nun XAMPP 1.8.3 auf dem WHS 2011 installiert.

Ich würde auf Grund eines noch nicht behobenen Bugs mit MySQL lieber XAMPP 1.8.2 verwenden. Mehr dazu hier: viewtopic.php?f=16&t=66746

backfischmedia wrote:Sobald ich auf einem der beiden Client die URL eintippe: 25.117.144.155/localhost:88/beispielwebsite (ist jetzt eben ein Beispiel) bekomm ich einen Laufzeitfehler

zu recht. Was macht das localhost in der URL?
Richtig müsste es http://IP-des-WHS:88/beispielwebsite heißen

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests