XAMPP via Netzlaufwerk

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP via Netzlaufwerk

Postby Milchbazi » 30. July 2004 16:23

Hallo,

ich bin nun schon seit längerem ein großer xampp anhänger und hatte bisher keine größeren Probleme. Nun ist es leider soweit. Und zwar habe ich xampp auf ein Netzlaufwerk unseres Servers kopiert um nun darüber sämtliche scripts von xampp wie apache, mysql, etc. zu starten - aber lokal. Und zwar möchte ich via der Windows-Funktion Offline-Dateien sowohl meinen Firmenrechner als auch meinen Laptop immer up to date halten. Das ganze funktionierte früher immer nur über den Ordner htdocs, aber dabei wurden die MySQL-Tabellen nicht syncronisiert.

Das Ganze funktioniert soweit auch relativ gut, nur muss ich apache und mysql via command starten, bzw. beenden. Der Versuch alles über Dienste laufen zu lassen scheiterte mit dem Fehler: Das System kann den angegebenen Pfad nicht finden.

Weiß irgendjemand rat? Das starten sollte möglichst automatisch (über regestry oder autostart) und vor allem im Hintergrund funktionieren.

Vielen Dank für eure Tipps!

LG aus Saarbrücken
Milchbazi

PS: Ich nutzte XAMPP 1.4.5
Milchbazi
 
Posts: 6
Joined: 03. June 2004 12:11

Postby Kristian Marcroft » 30. July 2004 16:42

Hi,

versuchs mal als Dienst zu installieren...
aber nicht über die Batch dateien, sondern eher mit dem Pfad...
aber anstatt von G:\xampp\apache\bin\apache blalba
Machst du es so:

\\Namevomserver\Freigabenname\xampp\apache\bin blabla

Die Syntax dafür findest du in den Batches...
Allerdings würde ich den Dienst NICHT automatisch starten lassen.
Aus dem einfachen Grund das es sehr schön Fehlermeldungen geben kann, wenn keine Netzverbindung mehr besteht, bzw sie unterbrochen wird.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Milchbazi » 30. July 2004 17:02

Nein, leider nicht. Ich habe sämtliche Varianten ausprobiert. Er mäckert immer "ServerRoot must be a valid Directory" und

The Apache service named reported the following error:
>>> Syntax error on line 57 of //w2kserver/tobias$/xampp/apache/conf/httpd.conf: .

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

Also von dem Pfad nicht abschecken lassen, hab sowohl das, wie auch S: und auch ohne alles probiert.
Milchbazi
 
Posts: 6
Joined: 03. June 2004 12:11

Postby Kristian Marcroft » 30. July 2004 17:06

Hey,

schonmal eine Freigabe OHNE $ versucht?

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Milchbazi » 30. July 2004 17:19

Ja, hilft nix. Aber immerhin funktioniert ja xampp_start.exe

Die könnte ich ja mal in die registry schreiben und im Hintergrund laufen lassen. Mal schauen was passiert :-)
Milchbazi
 
Posts: 6
Joined: 03. June 2004 12:11

Postby Milchbazi » 30. July 2004 17:28

So. Was passiert ist war doch net so toll. Zwar funktionieren sowohl apache als auch mysql, aber ich habe immer noch das dicke schwarze command fenster welches sich weder im Hintergrund mit /background noch minimiert starten lässt. Dann hab ich überlegt dass ich ja ne batch-datei schreiben könnt zum Starten von xampp_start.exe sowie das Schließen des Fensters. Aber wenn ich das Fenster schließe läuft auch apache net mehr.

So, irgendwelche Vorschläge? :-)
Milchbazi
 
Posts: 6
Joined: 03. June 2004 12:11


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests