echo Ausgabe funktioniert nicht! Aller Anfang scheint schwer

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

echo Ausgabe funktioniert nicht! Aller Anfang scheint schwer

Postby philthad » 26. September 2013 08:27

Guten Morgen,

ich fange gerade an PHP zu lernen und da scheitert es schon an der echo-Ausgabe mit xampp.
Code: Select all
<html>
<head>
<title></title>
</head>
<body>
<?
echo "blaldlalald";
?>
</body>
</html>


Wenn ich die Seite über localhost aufrufe, ist nichts sichtbar(aber auch keine Fehlermeldung). Wenn ich mir den Quelltext angucke, wurde auch nichts formatiert.

Anders ist es wenn ich schreibe:
Code: Select all
<body>
<?="blaldlalald";
?>
</body>


Dann funktioniert es und im Seitenquelltext finde ich auch nur noch "blaldlalald".
Habe mal die 1. ausgeschriebene Variante auf meinem Webspace getestet und da klappt es wunderbar.
Woran könnte es liegen?

Aller Anfang scheint schwer zu sein :D

Grüße
Phil
philthad
 
Posts: 3
Joined: 26. September 2013 08:14
XAMPP Version: 5.5.19
Operating System: Windows 7 64bit

Re: echo Ausgabe funktioniert nicht! Aller Anfang scheint sc

Postby Altrea » 26. September 2013 08:31

Hallo Phil,

Das liegt daran, dass in PHP standardmäßig die Kurztags <? ?> (short open tag) ausgeschaltet sind um Inkompatibilitäten mit den XML Tags zu vermeiden.
Es ist best practice die vollständige Variante <?php ?> oder für zum Beispiel Ausgaben in Templates die Kurzvariante für echo <?= ?> zu verwenden, da letztere nicht von der Einstellung betroffen ist.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6474
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: echo Ausgabe funktioniert nicht! Aller Anfang scheint sc

Postby philthad » 27. September 2013 06:56

Altrea wrote:Hallo Phil,

Das liegt daran, dass in PHP standardmäßig die Kurztags <? ?> (short open tag) ausgeschaltet sind um Inkompatibilitäten mit den XML Tags zu vermeiden.
Es ist best practice die vollständige Variante <?php ?> oder für zum Beispiel Ausgaben in Templates die Kurzvariante für echo <?= ?> zu verwenden, da letztere nicht von der Einstellung betroffen ist.

mit freundlichen Grüßen,
Altrea


Ich danke dir. So klappt alles wunderbar.
philthad
 
Posts: 3
Joined: 26. September 2013 08:14
XAMPP Version: 5.5.19
Operating System: Windows 7 64bit


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests