Mod_Proxy lädt keine Bilder

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Mod_Proxy lädt keine Bilder

Postby YOGI » 22. July 2004 20:53

Hallo zusammen,

ich habe xampp 1.4.4 auf Windows 2003 Server instaliert und möchte einen Tobit Mail Server (Port 81) über proxy an meine statische IP anbinden.

Dazu habe ich alle proxy module eingeladen und folgende Zeilen in der http.conf geändert

<IfModule mod_proxy.c>
ProxyRequests Off
ProxyPass /joerg/ http://192.168.0.250:81/joerg+hermes/

</IfModule>

Der Zugriff auf HTML Dateien geht super aber es werden keine Bild Informationen gesendet.
Das Errorlog sieht wie folgt aus :
[Thu Jul 22 21:18:10 2004] [error] [client 192.168.0.52] File does not exist: E:/apachefriends/xampp/htdocs/joerg+hermes, referer: http://192.168.0.250/joerg/
[Thu Jul 22 21:18:10 2004] [error] [client 192.168.0.52] File does not exist: E:/apachefriends/xampp/htdocs/joerg+hermes, referer: http://192.168.0.250/joerg/
[Thu Jul 22 21:18:10 2004] [error] [client 192.168.0.52] File does not exist: E:/apachefriends/xampp/htdocs/joerg+hermes, referer: http://192.168.0.250/joerg/

Es ist mir zwar klar, dass er die Bilder so nicht laden kann, habe aber leider keine Idee mehr wie ich den Pfad zu den Bildern gültig bekomme. I

Kann mir jemand weiterhelfen ?

Grüße und Dank

Jörg
YOGI
 
Posts: 3
Joined: 19. July 2004 10:12

Postby Wiedmann » 22. July 2004 21:47

Zwar nur ein Versuch... aber versuch es mal mit "%2B" anstatt mit "+".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby YOGI » 23. July 2004 06:50

Wiedmann wrote:Zwar nur ein Versuch... aber versuch es mal mit "%2B" anstatt mit "+".

Hat leider nicht funktioniert.
Aber schonmal DANKE !
YOGI
 
Posts: 3
Joined: 19. July 2004 10:12

Postby Wiedmann » 23. July 2004 09:01

Nächster Versuch:
ProxyPass /joerg http://192.168.0.250:81/joerg+hermes
ProxyPassReverse /joerg http://192.168.0.250:81/joerg+hermes

(Nebenbemerkung: Das was du vorhast, hab ich bei mir auch nur mit einem Redirect auf einen VHost und dort dann ein Proxy-Pass zum Ziel hinbekommen... Und nachdem das lief, hab ich das dann so gelassen.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Das mit dem Proxy Pass Reverse geht leider auch nicht.

Postby YOGI » 23. July 2004 21:39

Hallo
leider klappt das mit dem ProxyPass auch nicht.
Wie sieht den eine solche VHost Cofig aus?
Habe so etwas noch nie gemacht.

Kann mir jemand einen Tipp geben ?

Grüße Jörg
YOGI
 
Posts: 3
Joined: 19. July 2004 10:12


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests