Directory verändert/nix funzt mehr

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Directory verändert/nix funzt mehr

Postby Drullo321 » 20. July 2004 15:12

Ich habe xampp auf G:/Serveradministration/xampp installiert.
Dann habe ich G:/Root/ angelegt und eine index rein
Dann die httpd.conf geöffnet und die beiden Sachen DocumentRoot und
Directory, dort je die Sachen in "G:/Root" geändert.
Browsercache gelöscht , Xampp das erste mal gestartet und es kommt immer wenn ich Xampp starte halt die Wahl nach Englisch und Deutsch aber beides funzt net, dann sacht der immer:

http://localhost/xampp/lang.php?de

NOT FOUND

The requested URL /xampp/lang.php was not found on this server.
Drullo321
 
Posts: 46
Joined: 30. June 2004 18:30

Postby Drullo321 » 20. July 2004 15:40

Wenn ich auf http://localhost gehe kommt auch die Startpage, sicherlich aber ich möchte das wenn ich Xampp starte auch normal ins Xampp Menü komme!
Drullo321
 
Posts: 46
Joined: 30. June 2004 18:30

Postby Drullo321 » 20. July 2004 16:26

Das sagt die FAQ(Kommentar von Torsten):

Es muß damit die Admin-Seiten weiter funktionieren die Index.html und im Ordner xampp die splash.php und status.php um an einigen Stellen im Pfad geändert werden. Die lang.php habe ich nur eimal mit dem Editor geöffnet und geschlossen, dann gehts.



ABER was muss ich genau verändern?
Drullo321
 
Posts: 46
Joined: 30. June 2004 18:30

Postby Drullo321 » 20. July 2004 18:46

Kann mir keiner helfen. WIll endlich losproggen? Oder versteht ihr net was ich will?


Also:

Wie oben genannt die Verzeichnisse geändert. Rufe ich http://localhost auf kommt auch die entsprechende index-Seite

Wenn ich xampp starte und auf deutsch klicke kommt die Error seite, ich will aber ins Webinterface und Hilfe udn Suche haben keine Hilfe erbracht
Drullo321
 
Posts: 46
Joined: 30. June 2004 18:30

Postby Wiedmann » 20. July 2004 19:04

httpd.conf
Code: Select all
Alias /xampp "G:/Serveradministration/xampp/htdocs/xampp/"
<Directory "G:/Serveradministration/xampp/htdocs/xampp">
   Order Allow,Deny
   Allow from all
</Directory>
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Drullo321 » 20. July 2004 19:13

thx nur wo,

ich finde nur Alias webalizer
Alias csimcache usw usw, die Suche danach hat auch nix ergeben
Drullo321
 
Posts: 46
Joined: 30. June 2004 18:30

Postby Drullo321 » 20. July 2004 19:19

Ahah, habe es einfach mal irgendwo in der httpd.conf eingefügt, thx funzt alles
Drullo321
 
Posts: 46
Joined: 30. June 2004 18:30

Postby Drullo321 » 20. July 2004 19:21

Nur eine weitere Frage. Als ich damals noch nicht das Verzeichnis für die index.-Datei aufm Localhost isntalliert hatte war beim Stattus alles grün bis auf die untersten beiden. Nun ist auch Server Side Includes deaktiviviert, warum das?
Drullo321
 
Posts: 46
Joined: 30. June 2004 18:30

Postby Wiedmann » 20. July 2004 19:38

Weil ich für das XAMPP-Verzeichnis jetzt keine Options mehr aktiviert habe. (Der Punkt würde jetzt eh nur anzeigen was in diesem einem Verzeichnis aktiviert ist und nicht was im DocumentRoot gültig ist)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Drullo321 » 20. July 2004 19:53

jep und wie mache ich es, das es richtig angezeigt wird was im Documentroot aktiv ist?
Drullo321
 
Posts: 46
Joined: 30. June 2004 18:30

Postby Wiedmann » 20. July 2004 20:21

Du tust den DokumentRoot wieder da hin wo er war, oder du kopierst das Xampp-Verzeichnis in den neuen DokumentRoot.

Letztendlich ist das aber nicht so wichtig. Wenn es dir dann besser geht, machst du noch ein:
Options +Includes
AddType text/html .shtml
AddHandler server-parsed .shtml

in den Directory-Block von gerade eben rein...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests