xampp und *.pl

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp und *.pl

Postby data » 20. July 2004 13:23

hallo,

bin neu hier :D

aber egal. zum thema. also, ich bin nun auch stolzer besitzer der neuesten xampp version, die wirklich überraschend easy funktioniert und zu installieren war. da schonmal fettes kompliment an die entwickler. wirklich toll.

nun aber wirklich zum thema. also, ich hab im cgi-bin mal folgende datei erstellt:

Code: Select all
#!C:\apachefriends\xampp\perl\bin\perl.exe -w

use strict;
use CGI::Carp qw(fatalsToBrowser);

print "Content-type: text/html\n\n";
print '<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">', "\n";
print "<html><head><title>Test-Ausgabe</title></head><body>\n";
print "<h1>Hurra, es klappt!</h1>\n";
print "</body></html>\n";


die ganze heisst test.pl und ich hab die von http://de.selfhtml.org/cgiperl/intro/perlpc.htm
wenn ich die nun aufrufe, bekomme ich immer nen 500 internal server error.

wenn ich die direkt über die eingabeaufforderung mit ...perl ../../test.pl aufrufe, sagt er mir das er strict nicht finden kann.

kann ja wer will mal jeder ausprobieren, der eine frische unveränderte xampp version hat. würde mich wundern wenn er andere ergebnisse bekommt.

also, was muss ich tun, damit *.pl dateien wirklich und richtig funktionieren? die cgi.cgi und die perltest.cgi im cgi-bin tun es auf jedenfall. muss ich noch irgendwas installieren oder so?

thx 4 help!

data
data
 
Posts: 2
Joined: 20. July 2004 13:02

Postby Rolidor » 20. July 2004 21:09

Morsche
Wenn ich die Sache richtig einschätze, brauchst du das Perl-Addon. Im XAMPP-Paket ist wohl nur perl.exe enthalten.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby data » 22. July 2004 10:29

jo. das wars :D
data
 
Posts: 2
Joined: 20. July 2004 13:02


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests