session

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

session

Postby billa » 18. July 2004 15:20

Hallo, in der php.ini steht :

session.save_path= ".;c:\xampp\tmp"

wenn ich das in:

session.save_path= "c:\xampp\tmp"

abändere, bekomme ich dann irgendwelche Probleme mit xampp?

Wozu wird das ( .; ) gebraucht?
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Postby Rolidor » 18. July 2004 16:16

Hallo.
Der Punkt ist eine relative Pfadangabe und bezieht sich auf das aktuelle Verzeichnis. Warum willst du das ändern?

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Antwort

Postby billa » 18. July 2004 18:59

HAllo, versuche ein Script zu installieren und bekomme immer dies Fehlermeldung: session.save_path= ".;c:\xampp\tmp" not writetable
Erst wenn ich es so "c:\xampp\tmp" mache funktioniert es.
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Postby Rolidor » 18. July 2004 19:03

Dann mach! Sollte keine negativen Auswirkungen haben.

Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby Wiedmann » 18. July 2004 19:06

session.save_path = "c:\xampp\tmp"

So ist es auch korrekt. Das ".;", falls es vorhanden war, ist an dieser Stelle falsch.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

antwort

Postby billa » 18. July 2004 21:04

Danke, mache ich, war mir unsicher.
Wenn es nichts macht ist es ok.
Warum sind die zwei Zeichen dann überhaupt vorhanden?
Wenn man sie an dieser Stelle nicht benötigt.
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Postby Wiedmann » 18. July 2004 21:43

Warum sind die zwei Zeichen dann überhaupt vorhanden?
Wenn man sie an dieser Stelle nicht benötigt.

Da ich ja schon geschrieben habe, das die dort falsch sind (nicht nur "nicht benötigt") hat wohl jemand einen Fehler gemacht...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Rolidor » 18. July 2004 23:13

Hi Wiedmann.
Ich hab da noch ein paar ältere Versionen von PHP in meiner Gruft und mal nachgeschaut. Der Punkt ist in allen Inis vorhanden. Hatte mir bislang auch keine Schwierigkeiten bereitet.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby Wiedmann » 19. July 2004 01:18

Der Punkt ist in allen Inis vorhanden.

Dann redest du aber von php.ini's aus älteren XAMPP - Versionen.? In orginalen INI's vom PHP-Projekt steht das bestimmt nicht so drin...

Hatte mir bislang auch keine Schwierigkeiten bereitet.

Worin man mal wieder sieht, das etwas Falsches, ein auf den ersten Blick korrektes Ergebnis liefern kann ;-)

Code: Select all
session.save_path = ".;c:\xampp\tmp"
                     ^

Anstelle dieses Punktes erwartet hier PHP eine Zahl (wenn zusätzlich auch ein Semikolon vorhanden ist). Das das hier noch niemand aufgefallen ist, liegt daran, dass
a) PHP (bisher) nicht wirklich prüft ob dort eine Zahl ist und
b) der Punk zu 0 evaluiert.

Für PHP sieht das also aus wie "0;c:\xampp\tmp" und entspricht in der Wirkung einem einfachen "c:\xampp\tmp".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Rolidor » 19. July 2004 02:09

Morsche.
Wiedmann wrote:Dann redest du aber von php.ini's aus älteren XAMPP - Versionen.?

Jain. Ich hab immer ein wenig früher das Update mit dem direkten Einspielen einer neueren (und auch älteren) PHP-Version gemacht. Woran ich aber bei meinem Posting vorher nicht gedacht habe ist, dass ich mir die entsprechende Zeile wohl einfach immer wieder aus der XAMPP-php.ini rüberkopiert habe. :oops:

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby billa » 19. July 2004 08:47

Hallo, bitte entschuldigt, dass ich euren Dialog unterbreche. Mir ist noch weiteres aufgefallen. Ich bekomme die fehlermeldung: apache.exe hat Fehler
verursacht und wirdgeschlossen. Starten Sie das Programm neu. Ein Fehlerprotokoll wird erstellt. nachdem ich das von euch hier gelesen habe, habe ich mir eine ältere php.ini besorgt, reingespielt...und die Fehlermeldung ist weg. in der Apache Error-Log steht:
[Mon Jul 19 09:20:56 2004] [notice] Parent: Created child process 1176
[Mon Jul 19 09:20:59 2004] [notice] Child 1176: Child process is running
[Mon Jul 19 09:20:59 2004] [notice] Child 1176: Acquired the start mutex.
[Mon Jul 19 09:20:59 2004] [notice] Child 1176: Starting 250 worker threads.
[Mon Jul 19 09:24:37 2004] [notice] Parent: child process exited with status 3221225725 -- Restarting.
[Mon Jul 19 09:24:39 2004] [notice] Parent: Created child process 1572
[Mon Jul 19 09:24:42 2004] [notice] Child 1572: Child process is running
[Mon Jul 19 09:24:42 2004] [notice] Child 1572: Acquired the start mutex.
[Mon Jul 19 09:24:42 2004] [notice] Child 1572: Starting 250 worker threads.

Irgend etwas scheint in der php.ini noch nicht richtig zu sein.

Kann ich die ältere php.ini in der neuen xammp-Version drin lassen? Oder gibt das eventuell andere Fehler? Denn mit dieser geht bei mir soweit ich sehen kann, alles.
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Postby billa » 19. July 2004 13:23

So, habe mich weiter reingearbeitet.
Bin die php.ini Stück für Stück durchgegangen und habe festgestellt, wenn ich das folgende weg lasse, dann geht es plötzlich:

[Zend]
;zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=1023
;zend_extension="c:\xampp\php\zendOptimizer\lib\Optimizer-2.5.2\php-4.3.x\ZendOptimizer.dll"
zend_extension_ts="c:\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts="c:\xampp\php\zendOptimizer\lib\Optimizer-2.5.2"
;zend_optimizer.license_path="c:\xampp\licenses\zendOptimizer\license.txt"

Für was wird das gebraucht? Kann ich es weglassen? Denn ohne geht bei mir jetzt anscheinend alles. Muß allerdings noch weiter testen.
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Postby Rolidor » 19. July 2004 14:09

Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby Wiedmann » 19. July 2004 14:15

zend_optimizer.optimization_level=1023

Vor kurzem hab ich das schonmal geschrieben hier im Forum...
Diese Option kann einen Wert von 0 bis 15 annehmen. Der Standardwert ist:
zend_optimizer.optimization_level = 15

Für was wird das gebraucht?

Ist zum Beschleunigen von PHP.

Kann ich es weglassen?

Ja. Dazu diese Zeile mit einem ";" auskommentieren:
;zend_extension_ts="c:\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"

Mit der Anpassung des Wertes "zend_optimizer.optimization_level" sollte es dann eigentlich gehen.

Zu bemerken ist noch, dass die Version 2.5.2 Probleme mit der benutzten ZLib haben kann. Die wird z.B. auch gern von Forenscripte aktiviert. Abhilfe bietet dann der Update auf Version 2.5.3 .
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby billa » 19. July 2004 18:35

Hallo, das hörte sich zuerst ja ganz gut an, was ihr mir da geschrieben habt.
Also habe ich mir von http://www.zend.com/store/products/optimizer-faq.php den zent-Optimizer heruntergeladen und installiert. Leider ging dann das ganze xampp nicht mehr. So war ich gezwungen eine neue xampp installation durchzuführen. Aber darin habe ich in der Zwischenzeit Übung, so daß es schnell ging. Habe mir die neueste xampp 1.4.5 heruntergeladen, angepasst und installiert.
Leider gibt es damit noch mehr Fehler als mit der 1.4.4
Nur wenn ich unter Zent alles auskommentiere dann läuft mein Portal einwandfrei. Ich werde den zent-optimizer halt gezwungenermaßen nicht nutzen.
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests