Fehler bei erneutem Start von xampp

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehler bei erneutem Start von xampp

Postby anamchara » 18. July 2004 06:57

Hallo zusammen,

wenn ich xampp das erste mal starte geht das problemlos. Wenn ich es dann beende und später erneut starte erhalte ich folgende Fehlermeldung:

Can´t start Server: Bind on TCP/IP port: No error
040703 19:25:09 Do you already have another mysqld server running on port 3306 ?
040703 19:25:09 Aborting
040703 19:25:09 mysql\bin\mysql.exe: Shutdown complete...

### APACHE + MYSQL IS STARTING NOW ###

Ich würde mich sehr freuen, wenn mir da jemand helfen kann.

Anamchara
anamchara
 
Posts: 4
Joined: 18. July 2004 05:55

Postby Rolidor » 18. July 2004 12:39

Hallo.
MYSQL Fehler wrote:040703 19:25:09 Do you already have another mysqld server running on port 3306 ?

Offensichtlich beendest du nach dem ersten start nur den Apachen. Starte und beende das Zeug mal, wie du es bisher tatest und schaue mal in den Taskmanager. Da sollte sich noch 'mysqld' zeigen.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby anamchara » 18. July 2004 13:54

Rolidor wrote:Offensichtlich beendest du nach dem ersten start nur den Apachen. Starte und beende das Zeug mal, wie du es bisher tatest und schaue mal in den Taskmanager. Da sollte sich noch 'mysqld' zeigen.


Stimmt genau. Ich hab es jetzt über den taskmanager beendet. Aber das ist ja nicht gerade eine elegante Lösung (auch wenn ich damit leben könnte). Ich hab das Ganze ja mit dem Installer installiert und starte das Programm über den Programmpunkt 'xampp basic start' und beenden soll ich es ja mit 'xampp basic stopp'. Stimmt da was mit der Installation nicht? Muss ich noch irgendwas verändern?

Vielen Dank jedenfalls schon mal dafür, dass ich nicht jedes Mal den Rechner neu starten muss (ist mir richtig peinlich dass ich vergessen habe in den Taskmanager zu schauen) :oops:

Anamchara
anamchara
 
Posts: 4
Joined: 18. July 2004 05:55

Postby Rolidor » 18. July 2004 14:57

Hallo.
Möglicherweise hast du ein Passwort für den 'root-user' in MySQL vergeben. Dann kannst du MySQL nur mittels 'mysqladmin.exe -uroot -pDeinPasswort shutdown' beenden. Basic_start und Basic_stop sind wohl nur für den schnellen Einstieg gedacht.

@apachefriends: Vielleicht könntet ihr das ja als Kommandozeilenoption mit einbauen?

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby anamchara » 18. July 2004 21:16

Hallo,

Rolidor wrote:Möglicherweise hast du ein Passwort für den 'root-user' in MySQL vergeben.


Kann man das unfreiwillig? Denn ich erinnere mich nicht, so etwas vergeben zu haben.

Ich habe das Ganze aufgespielt, um Typo3 verwenden zu können. Bei der Installation lässt sich dann aber keine Datenbank erstellen. Kann es sein, dass das dieses Mysql Problem ist und gar nichts mit der Typo3 Installation zu tun hat?

Vielleicht fällt ja jemandem etwas über nacht ein :wink:

Ich geb jedenfalls für heute auf. Vielen Dank für deine Ratschläge Rolidor.

Anamchara
anamchara
 
Posts: 4
Joined: 18. July 2004 05:55

Postby Rolidor » 18. July 2004 23:06

Hallo
anamchara wrote:Kann man das unfreiwillig?
Nein!
Typo hatte ich vor langer Zeit mal ausprobiert. Ich erinnere mich da an ein Setup-Skript. Muss man da nicht Passwort für den Administrationszugriff angeben? Halte es allerdings für unwahrscheinlich, dass das Skript das Root-Passwort ändert. Wäre aber dennoch möglich, da 'Basic_start' die DB-Engine als Root startet.
Guck doch mal, ob du in Typo ein leeres Passwort für den Admin eingeben kannst und probiers dann nochmal. Eine andere (etwas gewaltsame) Lösung wäre es, das XAMPP-Paket neu zu installieren und es erst einmal ohne Typo auszuprobieren. Wenns da funzt, legst du mittels PhpMyAdmin einen weiteren User an, unter dem du MySQL vor der Installation des CMS startest.
Wie das geht, wurde hier im Forum schon öfter besprochen.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests