Migration Apache HTTP-Server --> XAMPP

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Migration Apache HTTP-Server --> XAMPP

Postby PB » 10. July 2004 22:49

Hallo zusammen,

ich setze zur Zeit unter Windows 2000 Server den Apache HTTP-Server V 2.0.43 ein und möchte auf XAMPP migrieren, da ich PHP und MySQL benötige.

Gibt es eine Möglichkeit, die Migration so durchzuführen, daß die Konfigurationen des HTTP-Servers erhalten bleiben und nicht manuell nachgezogen werden müssen?

Vielen Dank schon mal für Eure schnelle Hilfe.

PB
PB
 
Posts: 2
Joined: 10. July 2004 22:32

Postby Rolidor » 11. July 2004 00:40

Morsche.
Wenn du dir deine Config-Dateien sicherst und später in die XAMPP-Installation überträgst, sollte das eigentlich möglich sein. Am besten lässt du deinen jetzigen Apachen genau dort, wo er ist und installierst XAMPP in ein anderes Verzeichnis. Danach muss wahrscheinlich nur die 'httpd.conf' im 'xampp\apache\conf' Verzeichnis angepasst werden. Dazu benutzt du am besten ein Tool, wie examdiff o.ä. zum Vergleichen der Datei bei deiner jetzigen Installation und dem XAMPP. Augenmerk ist dabei vor allem auf die Einträge 'Listen', 'DocumentRoot' und die korrespondierenden 'Directory'-Einträge zu legen.
Wahrscheinlich sind in deiner bisherigen 'httpd.conf' weniger Einträge zu ändern. Die spielst du dann zum XAMPP rüber. Vor der Änderung aber unbedingt eine Sicherungskopie der originalen Dateien behalten! Bei umfangreichen Änderungen und daraus resultierendem Fehlverhalten des Servers sind die Ursachen dafür manchmal nur mühsam aufzuspüren. Wenns wider Erwarten in die Hose geht, hast du dann noch deine funktionierende Installation.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby PB » 11. July 2004 09:19

Vielen Dank, ich habe das alles gemacht: die httpd.conf vom HTTP-Server in das .../XAMPP/apache/conf-Verzeichnis übernommen und einfach angepaßt. Danach hatte ich die Fehlermeldung beim Starten, daß *-Ports und non-*-Ports (also IP-basierte virtual hosts und namens-basierte virtual hosts) nicht nebeneinander existieren können.

Ursache: bei der Anpassung der httpd.conf hatte ich die Anweisung "Include conf/ssl.conf" übernommen. Dort ist i.Ggs. zu meiner httpd.conf ein IP-basierter virtual host definiert. Ich habe versucht, daraus einen namens-basierten virtual host zu machen. Ergebnis: XAMPP startet ohne die Fehlermeldung, der Browser kommt hoch mit dem XAMPP-Logo, nach Auswahl einer Sprache kommt eine leere Seite. Auch alle anderen Seiten, die von dem Host gehostet werden, kommen mit einer leeren Seite.

Hier die ssl.conf (habe alle Kommentare gelöscht):
Listen 443
LoadModule ssl_module modules/mod_ssl.so
LoadFile "C:/+ Anwendungen/XAMPP/apache/bin/libeay32.dll"
LoadFile "C:/+ Anwendungen/XAMPP/apache/bin/ssleay32.dll"

SSLSessionCache dbm:logs
SSLSessionCacheTimeout 600
<VirtualHost *>

DocumentRoot "C:/+ Anwendungen/XAMPP/htdocs"
ServerName localhost:443
ServerAlias _default_:443
ServerAdmin admin@bornsch.de
ErrorLog logs/sslerror.log

SSLEngine on

SSLCertificateFile "C:/+ Anwendungen/XAMPP/apache/conf/ssl.crt/server.crt"

SSLCertificateKeyFile "C:/+ Anwendungen/XAMPP/apache/conf/ssl.key/server.key"

<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>
<Directory "C:/+ Anwendungen/XAMPP/cgi-bin">
SSLOptions +StdEnvVars
</Directory>

SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0

</VirtualHost>

Was ist daran noch verkehrt?

PB
PB
 
Posts: 2
Joined: 10. July 2004 22:32

Postby Rolidor » 11. July 2004 10:42

Morsche.
Bin kein SSL-Spezialist, glaube aber, dass es daran liegt:
<VirtualHost *>

Der SSL-Host darf nur auf einer Adresse definiert sein und auch nur auf Port 443 horchen. In der XAMPP- 'ssl.conf':
<VirtualHost _default_:443>
# <VirtualHost 127.0.0.1:443>

Kannst es dir also aussuchen.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests