Brauche hilfe pass setzen!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Brauche hilfe pass setzen!

Postby Porto » 09. July 2004 19:34

Also ich hab bei phpmyadmin über das interface alle gelöscht habe nur das root mit % gelassen so jetzt habe ich dort ein passwort gesetzt Porto.
So als ich den server neu starte ist Mysql deaktiviert und komme in phpmyadmin nicht mehr rein.
Server localhost

Fehler

MySQL meldet:
#1045 - Access denied for user: 'root@localhost' (Using password: NO)

So ich dachte das liekgt an der datei config.inc.php

$cfg['blowfish_secret'] = ''; // $cfg['blowfish_secret'] = 'password';

/**
* Server(s) configuration
*/
$i = 0;
// The $cfg['Servers'] array starts with $cfg['Servers'][1]. Do not use $cfg['Servers'][0].
// You can disable a server config entry by setting host to ''.
$i++;
$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port'] = ''; // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket'] = ''; // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type'] = 'tcp'; // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['compress'] = FALSE; // Use compressed protocol for the MySQL connection
// (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['controluser'] = 'root'; // MySQL control user settings
// (this user must have read-only
$cfg['Servers'][$i]['controlpass'] = ''; // access to the "mysql/user"
// and "mysql/db" tables)
$cfg['Servers'][$i]['auth_type'] = 'http'; // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = 'porto'; // MySQL password (only needed
// with 'config' auth_type)
$cfg['Servers'][$i]['only_db'] = ''; // If set to a db-name, only
// this db is displayed
// at left frame
// It may also be an array
// of db-names
$cfg['Servers'][$i]['verbose'] = ''; // Verbose name for this host - leave blank to show the hostname

$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin'; // Database used for Relation, Bookmark and PDF Features
// (see scripts/create_tables.sql)
// - leave blank for no support
// DEFAULT: 'phpmyadmin'
$cfg['Servers'][$i]['bookmarktable'] = 'PMA_bookmark'; // Bookmark table
// - leave blank for no bookmark support
// DEFAULT: 'PMA_bookmark'
$cfg['Servers'][$i]['relation'] = 'PMA_relation'; // table to describe the relation between links (see doc)
// - leave blank for no relation-links support
// DEFAULT: 'PMA_relation'
$cfg['Servers'][$i]['table_info'] = 'PMA_table_info'; // table to describe the display fields
// - leave blank for no display fields support
// DEFAULT: 'PMA_table_info'
$cfg['Servers'][$i]['table_coords'] = 'PMA_table_coords'; // table to describe the tables position for the PDF schema
// - leave blank for no PDF schema support
// DEFAULT: 'PMA_table_coords'
$cfg['Servers'][$i]['pdf_pages'] = 'PMA_pdf_pages'; // table to describe pages of relationpdf
// - leave blank if you don't want to use this
// DEFAULT: 'PMA_pdf_pages'
$cfg['Servers'][$i]['column_info'] = 'PMA_column_info'; // table to store column information
// - leave blank for no column comments/mime types
// DEFAULT: 'PMA_column_info'
$cfg['Servers'][$i]['history'] = 'PMA_history'; // table to store SQL history
// - leave blank for no SQL query history
// DEFAULT: 'PMA_history'
$cfg['Servers'][$i]['verbose_check'] = TRUE; // set to FALSE if you know that your PMA_* tables
// are up to date. This prevents compatibility
// checks and thereby increases performance.
$cfg['Servers'][$i]['AllowDeny']['order'] // Host authentication order, leave blank to not use
= '';
$cfg['Servers'][$i]['AllowDeny']['rules'] // Host authentication rules, leave blank for defaults
= array();


Habe dort den
$cfg['Servers'][$i]['controluser'] = 'pma';
auf
$cfg['Servers'][$i]['controluser'] = 'root'; gesetzt weil dachte es lag weil ich den POMa gelöscht habe ?
Aber nein server bleibt weiterhin down.
Achso habe noch auf http gestellt und das pass gleich wie bei phpmyadmin auf porto gestellt.
Warum deaktiviert er den SQl datenserver.

Danke für die hilfe schon im vorraus
Last edited by Porto on 10. July 2004 02:06, edited 1 time in total.
Porto
 
Posts: 12
Joined: 06. July 2004 11:33

Postby Wiedmann » 09. July 2004 20:02

Also ich hab bei phpmyadmin über das interface alle gelöscht habe nur das root mit % gelassen so jetzt habe ich dort ein passwort gesetzt Porto.
So als ich den server neu starte ist Mysql deaktiviert und komme in phpmyadmin nicht mehr rein.
...
MySQL meldet:
#1045 - Access denied for user: 'root@localhost' (Using password: NO)

Das war eine schlechte Idee. Der root@% hat sogut wie keine Rechte. Dein Standard-(Super)-User war root@localhost.

Ich schätze mal, das einfachste für dich wäre MySQL neu zu Installieren. (Sollte eigentlich langen aus dem XAMPP-Archiv das Verzeichnis "/xampp/mysql/data" an die passende Stelle zu entpacken.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Porto » 09. July 2004 20:19

Es lagt genau da dran :)
Super danke :)
Habe alle gelöscht nur root@localhost gelassen und mit ein password verpasst und die das pass auch in confic.inc.php eingetragen läuft wie geölt :)
Vieleicht sollte diese kleinigkeit mal in der Faq erwähnt werden für noobs wie mich.

mfg
PORTO
Porto
 
Posts: 12
Joined: 06. July 2004 11:33

Postby Porto » 09. July 2004 20:38

ein kleines Problem gibt es da doch :(
Solange ich das gemcht habe und xampp nicht neu starte is alles ok.
Aber sobald ich xampp startet ist wieder das gleiche die SQL datenbank ist down wenn ich phphmyadmin in gehe will er #1045 - Access denied for user: 'pma@localhost' (Using password: NO)
Warum PMA den habe ich doch gelöscht ?


mfg
Porto
Porto
 
Posts: 12
Joined: 06. July 2004 11:33

Postby Kristian Marcroft » 09. July 2004 20:47

Hi,

zu unterstellen, die FAQ sei sehr dürftig finde ich sehr hart!
Besonders wenn es von einem selbsternanntem "noob"!!!
Wenn du mal in die FAQ geschaut hättest, hättest auch folgendes gefunden:
http://faq.kwm-web.info/index.php?sid=4 ... 11&lang=de

Dort solltest du dem Rat folgen, in der config.inc.php folgendes zu ändern:

$cfg['Servers'][$i]['auth_type'] = 'config';
auf
$cfg['Servers'][$i]['auth_type'] = 'cookie';


So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Porto » 09. July 2004 22:30

Ich na j deine faq gibt keine lösung warscheinlich hast du mein problem auh nicht verstanden.
Ich hab statt config schon auf http umgestelt ;)
Also brauch ich cookie nicht.
Das problem ist ich ändere das pass und bei neustart von Xampp ist mysql datenbank deaktiviert.
ich hab alle gelöscht ausser root@localhost stehen lassen und mit ein pass versehen.
Aber was will er mit PMA wie man oben sehen kann.

mfg
Porto

hier meine config

// You can disable a server config entry by setting host to ''.
$i++;
$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port'] = ''; // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket'] = ''; // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type'] = 'tcp'; // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['compress'] = FALSE; // Use compressed protocol for the MySQL connection
// (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['controluser'] = 'pma'; // MySQL control user settings
// (this user must have read-only
$cfg['Servers'][$i]['controlpass'] = ''; // access to the "mysql/user"
// and "mysql/db" tables)
$cfg['Servers'][$i]['auth_type'] = 'http'; // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = 'porto1971'; // MySQL password (only needed
// with 'config' auth_type)
$cfg['Servers'][$i]['only_db'] = ''; // If set to a db-name, only
// this db is displayed
// at left frame
// It may also be an array
// of db-names
$cfg['Servers'][$i]['verbose'] = ''; // Verbose name for this host - leave blank to show the hostname

$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin'; // Database used for Relation, Bookmark and PDF Features
// (see scripts/create_tables.sql)
// - leave blank for no support
// DEFAULT: 'phpmyadmin'
$cfg['Servers'][$i]['bookmarktable'] = 'PMA_bookmark'; // Bookmark table
// - leave blank for no bookmark support
// DEFAULT: 'PMA_bookmark'
$cfg['Servers'][$i]['relation'] = 'PMA_relation'; // table to describe the relation between links (see doc)
// - leave blank for no relation-links support
// DEFAULT: 'PMA_relation'
$cfg['Servers'][$i]['table_info'] = 'PMA_table_info'; // table to describe the display fields
// - leave blank for no display fields support
// DEFAULT: 'PMA_table_info'
$cfg['Servers'][$i]['table_coords'] = 'PMA_table_coords'; // table to describe the tables position for the PDF schema
// - leave blank for no PDF schema support
// DEFAULT: 'PMA_table_coords'
$cfg['Servers'][$i]['pdf_pages'] = 'PMA_pdf_pages'; // table to describe pages of relationpdf
// - leave blank if you don't want to use this
// DEFAULT: 'PMA_pdf_pages'
$cfg['Servers'][$i]['column_info'] = 'PMA_column_info'; // table to store column information
// - leave blank for no column comments/mime types
// DEFAULT: 'PMA_column_info'
$cfg['Servers'][$i]['history'] = 'PMA_history'; // table to store SQL history
// - leave blank for no SQL query history
// DEFAULT: 'PMA_history'
$cfg['Servers'][$i]['verbose_check'] = TRUE; // set to FALSE if you know that your PMA_* tables
// are up to date. This prevents compatibility
// checks and thereby increases performance.
$cfg['Servers'][$i]['AllowDeny']['order'] // Host authentication order, leave blank to not use
= '';
$cfg['Servers'][$i]['AllowDeny']['rules'] // Host authentication rules, leave blank for defaults
= array();
Porto
 
Posts: 12
Joined: 06. July 2004 11:33

Postby Kristian Marcroft » 09. July 2004 22:55

Porto wrote:#1045 - Access denied for user: 'pma@localhost' (Using password: NO)
Warum PMA den habe ich doch gelöscht ?


Wieso lässt du nicht erstmal alle User drin? und vergibst nur Passwds?
Und obige fehlermeldung kommt, weil phpmyadmin über den sogenannten "pma" User mit mysql komunizieren möchte.

Wonach würde man dann wohl suchen in der config.inc.php?
hmm... pma?

aber pma sollte weiterhin als User drin bleiben...

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Porto » 10. July 2004 02:05

So das Problem wurde huet abend mit Kris gelöst :)
Danke nochmal Kris und sorry wegen der FAQ ich bin zu ungeduldig und wie ein kleinkind sofort die FAQ beschuldigt ;) Was zu unrecht ist.
Bin jetzt müde an alle newbies die das auch wissen möchten werde das morgen allias heute abend Posten wie ich das mit Kris gelöst habe he he besser wie Kris mir geholfen hat das zu lösen :lol:

mfg
porto
Porto
 
Posts: 12
Joined: 06. July 2004 11:33

Postby Porto » 10. July 2004 09:49

Hi Kris ich kann sql nicht runterfahren egal wie ob ich den xampp_stop.exe benutze doder direct den sql Stop.
Schau hier das zeigt er mir an wenn ich xampp runtefahren möchte http://home.arcor.de/lelo/sql.JPG

Und wenn ich mein rechner wieder hochfahre und xammp starte da gucke ich mir status an und er sagt das die mysql datenbank Deaktiviert ist ?
Das kann doch nicht möglich sein wenn wir ein passwort setzen das er nicht mehr will ?
Hab nur das gemacht was du gestern gesgat hast.


mfg
Porto
Porto
 
Posts: 12
Joined: 06. July 2004 11:33

Postby Rolidor » 10. July 2004 10:51

Morsche.
Die Start- und Stopdateien, die mit XAMPP kommen sind für die Defaultkonfig. Wenn du für den Root ein PW vergeben hast, brauchst du das auch, wenn du MySQL runterfahren willst. Ist ja Sinn und Zweck der Sache, dass das nicht jeder kann. Ändere die 'mysql_stop.bat' folgendermaßen:
Code: Select all
mysql\bin\mysqladmin -uroot -pDeinPasswort shutdown


Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby Porto » 10. July 2004 11:09

Ich glaube ist erledigt Kris hat gesgat brauch nichts zu machen einfach den rechner runterfahren wird alles automatisch gemacht oder muss ich diese zeile doch nocht einsetzen ?
Porto
 
Posts: 12
Joined: 06. July 2004 11:33

Postby Kristian Marcroft » 10. July 2004 11:17

Hi,

ich habe dir erklärt, wie du MySQL als Dienst installierst, und dann brauchst du das nicht mehr anpassen.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests