Chat Problem....

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Chat Problem....

Postby Brueckenhauer » 07. July 2004 16:59

Ich habe einen chat der auf cgi aufbaut, also habe ich das verzeichnis ins cgi verzeichnis reingeschoben und dann dann aufgerufen nur da kommt:

Internal Server Error

Was muss ich machen das das nicht mehr passiert?

Hier noch ein paar Infos:
- Es ist eine install.pl Datei
- Ich nutze die neuste version von Xampp
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby Wiedmann » 07. July 2004 17:38

Ein Blick ins error.log wäre nicht schlecht.

Ansonsten meint die Glaskugel das du wohl den SheBan (1. Zeile im Script) anpassen solltest --> Pfad zum Perl - Interpreter
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Brueckenhauer » 07. July 2004 20:21

[Wed Jul 07 20:59:19 2004] [error] [client 80.134.247.113] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't create child process: 720003: install.pl
[Wed Jul 07 20:59:19 2004] [error] [client 80.134.247.113] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't spawn child process: E:/xampp/cgi-bin/chat/install.pl


wie pfad anpassen? was muss ich da eintragen?
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby Wiedmann » 07. July 2004 20:50

wie pfad anpassen? was muss ich da eintragen?

In der ersten Zeile vom Script befindet sich wohl eine Zeile wie:
#!/usr/bin/perl

Das mußt du austauschen gegen z.B. sowas:
#!C:/xampp/perl/bin/perl.exe

Da muß halt hin, wo sich die Datei genau befindet.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Brueckenhauer » 07. July 2004 21:13

ok, habe den pfad an meinen angepasst und wieder versucht, aber immer noch das gleiche....
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby Heini_net » 08. July 2004 07:48

Brueckenhauer wrote:ok, habe den pfad an meinen angepasst und wieder versucht, aber immer noch das gleiche....


also in etwa so?: #!E:/xampp/perl/bin/perl.exe ?

Mfg. Heini
User avatar
Heini_net
 
Posts: 520
Joined: 25. July 2003 15:43
Location: hier

Postby Brueckenhauer » 08. July 2004 09:02

ja genau so....
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby Kristian Marcroft » 08. July 2004 12:05

Hi,

dieses Chatscript heisst nicht zufällig GTChat und läuft nicht auf Windows?

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Brueckenhauer » 08. July 2004 12:26

doch es ist gtchat...
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby Heini_net » 08. July 2004 18:04

Brueckenhauer wrote:doch es ist gtchat...



kannste knicken.. soweit ich weiss läuft es nur unter Linux.. hatte es damals auch versucht und nicht hinbekommen..

Mfg. Heini
User avatar
Heini_net
 
Posts: 520
Joined: 25. July 2003 15:43
Location: hier


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests